summaryrefslogtreecommitdiffstats
path: root/debian/lenny/applications/tdeio-ftps/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-09-13 09:56:12 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-09-13 09:56:12 +0200
commit35d5990302db69a9d3d60d7915b2e30194b37939 (patch)
treefc54ba66f412a0663ded4f25661175646779298d /debian/lenny/applications/tdeio-ftps/debian/rules
parent4d840737b301cf320555f00712a6a0a34d363c74 (diff)
downloadtde-packaging-35d5990302db69a9d3d60d7915b2e30194b37939.tar.gz
tde-packaging-35d5990302db69a9d3d60d7915b2e30194b37939.zip
DEB tdeio-ftps: Switch to cmake
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian/lenny/applications/tdeio-ftps/debian/rules')
-rwxr-xr-xdebian/lenny/applications/tdeio-ftps/debian/rules45
1 files changed, 16 insertions, 29 deletions
diff --git a/debian/lenny/applications/tdeio-ftps/debian/rules b/debian/lenny/applications/tdeio-ftps/debian/rules
index 14f8d0476..30b49e897 100755
--- a/debian/lenny/applications/tdeio-ftps/debian/rules
+++ b/debian/lenny/applications/tdeio-ftps/debian/rules
@@ -1,37 +1,24 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
-include debian/cdbs/kde.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/debian-qt-kde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
+# never build in parallel, regardless of DEB_BUILD_OPTIONS.
+DEB_BUILD_PARALLEL = true
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
- dh_testdir
-
- # Regenerate build system
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- autoreconf --install && automake -f && \
- $(MAKE) -f admin/Makefile.common && \
- touch debian/stamp-bootstrap
-
-clean::
- dh_testdir
- rm -f debian/stamp-bootstrap
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"