summaryrefslogtreecommitdiffstats
path: root/debian/lenny/kdeartwork/debian/cdbs/uploaders.mk
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-13 02:02:05 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-13 02:02:05 -0500
commit0230383d0fd9c5cccca2b5b4364df2afefb532da (patch)
tree4dbd6723c2ae3d9cbcf09d66409b3c45f4aab643 /debian/lenny/kdeartwork/debian/cdbs/uploaders.mk
parenta7685cf788cda0cfe0caac5b27090abbb66848f4 (diff)
downloadtde-packaging-0230383d0fd9c5cccca2b5b4364df2afefb532da.tar.gz
tde-packaging-0230383d0fd9c5cccca2b5b4364df2afefb532da.zip
Add kdeartwork to Debian Lenny and Debian Squeeze
Diffstat (limited to 'debian/lenny/kdeartwork/debian/cdbs/uploaders.mk')
-rw-r--r--debian/lenny/kdeartwork/debian/cdbs/uploaders.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/lenny/kdeartwork/debian/cdbs/uploaders.mk b/debian/lenny/kdeartwork/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/debian/lenny/kdeartwork/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders