summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/libraries/libkdcraw
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-08-03 14:44:58 -0500
commit0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6 (patch)
treec0d0d652fef20159e78fa20b2567661bd7db8e41 /debian/squeeze/libraries/libkdcraw
parent6b027437fd51e7874aaffed9e395ddf7913c3ab4 (diff)
downloadtde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.tar.gz
tde-packaging-0cc79c34f5e9be7eced52b0565e8e79acfa5f4e6.zip
Add initial Debian Lenny/Squeeze packaging as well as symlink Lucid to Maverick
Diffstat (limited to 'debian/squeeze/libraries/libkdcraw')
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/cdbs/buildvars.mk86
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/cdbs/debian-qt-kde.mk109
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/cdbs/kde.mk97
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/cdbs/team-members16
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/cdbs/uploaders.mk29
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/cdbs/versions.pl19
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/changelog128
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/compat1
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/control35
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/control.in35
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/copyright72
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/docs2
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/libkdcraw3-trinity-dev.install4
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/libkdcraw3-trinity.install1
-rwxr-xr-xdebian/squeeze/libraries/libkdcraw/debian/rules18
-rw-r--r--debian/squeeze/libraries/libkdcraw/debian/watch3
16 files changed, 655 insertions, 0 deletions
diff --git a/debian/squeeze/libraries/libkdcraw/debian/cdbs/buildvars.mk b/debian/squeeze/libraries/libkdcraw/debian/cdbs/buildvars.mk
new file mode 100644
index 000000000..23d4709dc
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/cdbs/buildvars.mk
@@ -0,0 +1,86 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2002,2003 Colin Walters <walters@debian.org>
+# Description: Defines some useful variables, but no rules
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_rules_buildvars
+_cdbs_rules_buildvars = 1
+
+CDBS_VERSION = something
+
+# Common useful variables
+DEB_SOURCE_PACKAGE := $(strip $(shell egrep '^Source: ' debian/control | cut -f 2 -d ':'))
+DEB_VERSION := $(shell dpkg-parsechangelog | egrep '^Version:' | cut -f 2 -d ' ')
+DEB_NOEPOCH_VERSION := $(shell echo $(DEB_VERSION) | cut -d: -f2-)
+DEB_UPSTREAM_VERSION := $(shell echo $(DEB_NOEPOCH_VERSION) | sed 's/-[^-]*$$//')
+DEB_ISNATIVE := $(shell dpkg-parsechangelog | egrep '^Version:' | perl -ne 'print if not /^Version:\s*.*-/;')
+
+# Split into arch/indep packages
+ifneq ($(DEB_INDEP_PACKAGES),cdbs)
+DEB_INDEP_PACKAGES := $(filter-out $(DONT_BUILD), $(strip $(shell $(_cdbs_scripts_path)/list-packages indep)))
+DEB_ARCH_PACKAGES := $(filter-out $(DONT_BUILD), $(filter-out $(DEB_INDEP_PACKAGES),$(strip $(shell $(_cdbs_scripts_path)/list-packages same))))
+endif
+# Split into normal and udeb packages
+ifeq ($(DEB_UDEB_PACKAGES),)
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+DEB_UDEB_PACKAGES = $(filter-out $(DONT_BUILD),$(filter %-udeb, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+else
+DEB_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES), $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+endif
+# Too much bother for now. If someone complains we'll fix it.
+#DEB_ARCH_UDEB_PACKAGES = $(filter %-udeb, $(DEB_ARCH_PACKAGES))
+#DEB_INDEP_UDEB_PACKAGES = $(filter %-udeb, $(DEB_INDEP_PACKAGES))
+# A handy list of every package, udeb or not
+DEB_ALL_PACKAGES = $(filter-out $(DONT_BUILD),$(DEB_PACKAGES) $(DEB_UDEB_PACKAGES))
+DEB_INDEP_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_INDEP_PACKAGES)))
+DEB_ARCH_REGULAR_PACKAGES = $(filter-out $(DONT_BUILD), $(filter-out $(DEB_UDEB_PACKAGES),$(DEB_ARCH_PACKAGES)))
+
+DEB_DBG_PACKAGES = $(filter-out $(DONT_BUILD), $(filter %-dbg, $(DEB_ARCH_PACKAGES) $(DEB_INDEP_PACKAGES)))
+
+# Some support for srcdir != builddir builds.
+# These are relative to the root of the package
+DEB_SRCDIR ?= .
+DEB_BUILDDIR ?= $(strip $(DEB_SRCDIR))
+
+# Miscellaneous bits
+DEB_ARCH = $(shell dpkg --print-architecture)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_HOST_GNU_SYSTEM)
+DEB_HOST_GNU_CPU ?= $(shell dpkg-architecture -qDEB_HOST_GNU_CPU)
+DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_BUILD_GNU_SYSTEM ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_SYSTEM)
+DEB_BUILD_GNU_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_CPU)
+DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+DEB_BUILD_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_CPU)
+DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
+
+ifeq ($(words $(DEB_ALL_PACKAGES)),1)
+ DEB_DESTDIR = $(CURDIR)/debian/$(strip $(DEB_ALL_PACKAGES))/
+else
+ DEB_DESTDIR = $(CURDIR)/debian/tmp/
+endif
+
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), cdbs (>= 0.4.23-1.1)
+
+endif
diff --git a/debian/squeeze/libraries/libkdcraw/debian/cdbs/debian-qt-kde.mk b/debian/squeeze/libraries/libkdcraw/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..47e83ef4a
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,109 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+include debian/cdbs/uploaders.mk
+
+DEB_PATCHDIRS := debian/patches/common debian/patches
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/kde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/kde/HTML/en/$$pkg; \
+ done
+
+clean::
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/squeeze/libraries/libkdcraw/debian/cdbs/kde.mk b/debian/squeeze/libraries/libkdcraw/debian/cdbs/kde.mk
new file mode 100644
index 000000000..5b6508f8c
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/cdbs/kde.mk
@@ -0,0 +1,97 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/kde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include/kde"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-prehook-impl::
+ mkdir -p po
+ -XGETTEXT=/usr/bin/kde-xgettext EXTRACTATTR=/opt/trinity/bin/extractattr sh $(DEB_SRCDIR)/admin/cvs.sh extract-messages
+ -for file in po/*pot; do \
+ sed "s/charset=CHARSET/charset=UTF-8/" -i $$file; \
+ done
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+ rm -rf po/*.pot
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/squeeze/libraries/libkdcraw/debian/cdbs/team-members b/debian/squeeze/libraries/libkdcraw/debian/cdbs/team-members
new file mode 100644
index 000000000..05761af6e
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/cdbs/team-members
@@ -0,0 +1,16 @@
+Sune Vuorela <debian@pusling.com>
+Ana Beatriz Guerrero Lopez <ana@debian.org>
+Fathi Boudra <fboudra@free.fr>
+Modestas Vainius <geromanas@mailas.com>
+Josh Metzler <joshdeb@metzlers.org>
+Isaac Clerencia <isaac@debian.org>
+Adeodato Simó <dato@net.com.org.es>
+Adeodato Simo <dato@net.com.org.es>
+Christopher Martin <chrsmrtn@debian.org>
+Daniel Schepler <schepler@debian.org>
+Sarah Hobbs <hobbsee@ubuntu.com>
+Nacho Barrientos Arias <nacho@debian.org>
+Ricardo Javier Cardenes Medina <rcardenes@debian.org>
+Ricardo Cardenes <rcardenes@debian.org>
+Armin Berres <trigger+debian@space-based.de>
+Francesco Pedrini <francesco.pedrini@gmail.com>
diff --git a/debian/squeeze/libraries/libkdcraw/debian/cdbs/uploaders.mk b/debian/squeeze/libraries/libkdcraw/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders
diff --git a/debian/squeeze/libraries/libkdcraw/debian/cdbs/versions.pl b/debian/squeeze/libraries/libkdcraw/debian/cdbs/versions.pl
new file mode 100644
index 000000000..9ce11d8a3
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/-[^-]+$//;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "KDE-Version3=$version3\n";
+print "KDE-Version2=$version2\n";
+print "KDE-Next-Version3=$version3_next\n";
+print "KDE-Next-Version2=$version2_next\n";
diff --git a/debian/squeeze/libraries/libkdcraw/debian/changelog b/debian/squeeze/libraries/libkdcraw/debian/changelog
new file mode 100644
index 000000000..d4eda6180
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/changelog
@@ -0,0 +1,128 @@
+libkdcraw-trinity (0.1.9-0ubuntu1) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 July 2009 16:08:00 -0600
+
+libkdcraw-trinity (0.1.4-0ubuntu2) intrepid; urgency=low
+
+ * Moved KDE3 to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 05 March 2009 01:11:00 -0600
+
+libkdcraw-trinity (0.1.4-0ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 17 Dec 2008 15:41:00 -0600
+
+libkdcraw (0.1.4-2ubuntu1) intrepid; urgency=low
+
+ * Rename libkdcraw-dev to libkdcraw3-dev (new libkdcraw-dev is
+ KDE 4 version).
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 11 Sep 2008 13:38:38 +0100
+
+libkdcraw (0.1.4-2) unstable; urgency=low
+
+ [ Achim Bohnet ]
+ * Don't install translation and icon. Their path or filename should
+ include API major version. We working with upstream on solution
+ for the next release.
+ * debian/copyright: replace the last 'Copyright (C)' with (C).
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sun, 16 Mar 2008 15:24:00 +0100
+
+libkdcraw (0.1.4-1) unstable; urgency=low
+
+ * New upstream release:
+ + new API breaks backward compatibility
+ + updates dcraw to 8.83
+
+ [ Achim Bohnet ]
+ * Adapt for API major 2 -> 3: debian/control debian/libkdcraw3.install
+ * Update debian/copyright
+ * Bump standards version 3.7.2 -> 3.7.3: No changes necessary
+
+ [ Fathi Boudra ]
+ * Add myself in Uploaders
+ * Switch to quilt patch system
+ * Install kdcraw icons and libkdcraw translations
+ * Clean up debian/rules:
+ * Drop autotools.mk include
+ * Drop -fpermissive flag
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sun, 16 Mar 2008 14:05:34 +0100
+
+libkdcraw (0.1.3-1) unstable; urgency=low
+
+ * New upstream release
+
+ [ Achim Bohnet ]
+ * debian/copyright:
+ + new, again DSFG compliant, dcwraw license.
+ + upstream authors.
+ * debian/control:
+ + use Vcs-* instead of XS-Vcs-* as Vcs-* are now official.
+ + add the new Homepage header field. Remove homepage URL from long
+ the description.
+ * debian/rules: use LDFLAGS="-Wl,--no-undefined -Wl,--as-needed" to
+ reference only to libs that are really needed. Dependency count
+ drops from 25 to 6.
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sat, 29 Dec 2007 23:31:02 +0100
+
+libkdcraw (0.1.2-1) unstable; urgency=low
+
+ * New upstream release
+ * Bump soname to package libkdcraw2
+
+ -- Mark Purcell <msp@debian.org> Fri, 28 Sep 2007 17:47:35 +0100
+
+
+libkdcraw (0.1.1-2) unstable; urgency=low
+
+ [ Achim Bohnet ]
+ * relibtoolize libkdcraw: Depends now on 7 packages instead of 25.
+ Add simple-patchsys.mk to debian/rules to apply the patches:
+ patches/03_libtool_update.diff
+ patches/04_am_maintainer_mode.diff
+ patches/05_pedantic-errors.diff
+ patches/98_buildprep.diff
+ patches/98_configure.diff: makes $LIB_QT only -lqt-mt and LIB_KDECORE
+ only -lkdecore
+ * Add utils.mk to debian/rules to have list-missing target
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Tue, 26 Jun 2007 07:31:15 +0100
+
+libkdcraw (0.1.1-1) experimental; urgency=low
+
+ * New upstream release
+ * new ABI major version - bump soname libkdcraw1
+
+ [ Achim Bohnet ]
+ * remove libkdcraw-runtime pkgs. The library helper application
+ kdcraw is now in a libary private dir, as required by
+ http://www.pathname.com/fhs/pub/fhs-2.3.html#USRLIBLIBRARIESFORPROGRAMMINGANDPA
+ * adapt debian packaging files for ABI major version change from 0 -> 1
+ * Build depends: add pkg-config. Used in tests of configure.
+
+ [ Mark Purcell ]
+ * Lintian cleanup: substvar-source-version-is-deprecated
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Thu, 14 Jun 2007 18:03:36 +0100
+
+libkdcraw (0.1.0-2) unstable; urgency=low
+
+ [ Mark Purcell ]
+ * Add libkdcraw-runtime to package kdcraw runtime binary
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sun, 20 May 2007 18:31:43 +0100
+
+libkdcraw (0.1.0-1) unstable; urgency=low
+
+ * Initial release. (Closes: #411783: ITP: libkdcraw -- Raw picture
+ decoding C++ library - Debian Bug report logs)
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Wed, 09 May 2007 21:14:12 +0100
diff --git a/debian/squeeze/libraries/libkdcraw/debian/compat b/debian/squeeze/libraries/libkdcraw/debian/compat
new file mode 100644
index 000000000..7ed6ff82d
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/squeeze/libraries/libkdcraw/debian/control b/debian/squeeze/libraries/libkdcraw/debian/control
new file mode 100644
index 000000000..f85f131da
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/control
@@ -0,0 +1,35 @@
+Source: libkdcraw-trinity
+Section: libs
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
+Uploaders: Mark Purcell <msp@debian.org>, Achim Bohnet <ach@mpe.mpg.de>, Fathi Boudra <fabo@debian.org>
+Build-Depends: cdbs, debhelper (>= 5), quilt, kdelibs4-trinity-dev,
+ liblcms1-dev, libjpeg62-dev, pkg-config,
+ automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+Homepage: http://www.kipi-plugins.org/
+
+Package: libkdcraw3-trinity-dev
+Section: libdevel
+Architecture: any
+Depends: libkdcraw3-trinity (= ${binary:Version}), pkg-config
+Conflicts: libkdcraw-dev
+Description: RAW picture decoding C++ library (development) [Trinity]
+ Libkdcraw is a C++ interface around dcraw binary program used to
+ decode Raw picture files.
+ .
+ libkdcraw-dev contains development files and documentation. The
+ library documentation is available on kdcraw.h header file.
+
+Package: libkdcraw3-trinity
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Raw picture decoding C++ library (runtime) [Trinity]
+ C++ interface around dcraw binary program used to decode RAW
+ picture files.
+ .
+ This library is used by kipi-plugins, digiKam and others kipi host programs.
+ .
+ libkdcraw3 contains the library of libkdcraw.
diff --git a/debian/squeeze/libraries/libkdcraw/debian/control.in b/debian/squeeze/libraries/libkdcraw/debian/control.in
new file mode 100644
index 000000000..a28c0245d
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/control.in
@@ -0,0 +1,35 @@
+Source: libkdcraw-trinity
+Section: libs
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+XSBC-Original-Maintainer: @@@MAINTAINER@@@
+Uploaders: @@@UPLOADERS@@@
+Build-Depends: cdbs, debhelper (>= 5), quilt, kdelibs4-trinity-dev,
+ liblcms1-dev, libjpeg62-dev, pkg-config,
+ automake1.11-trinity, autoconf2.63, libtool, libltdl-dev
+Standards-Version: 3.8.3
+Homepage: http://www.kipi-plugins.org/
+
+Package: libkdcraw3-trinity-dev
+Section: libdevel
+Architecture: any
+Depends: libkdcraw3-trinity (= ${binary:Version}), pkg-config
+Conflicts: libkdcraw-dev
+Description: RAW picture decoding C++ library (development) [Trinity]
+ Libkdcraw is a C++ interface around dcraw binary program used to
+ decode Raw picture files.
+ .
+ libkdcraw-dev contains development files and documentation. The
+ library documentation is available on kdcraw.h header file.
+
+Package: libkdcraw3-trinity
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: Raw picture decoding C++ library (runtime) [Trinity]
+ C++ interface around dcraw binary program used to decode RAW
+ picture files.
+ .
+ This library is used by kipi-plugins, digiKam and others kipi host programs.
+ .
+ libkdcraw3 contains the library of libkdcraw.
diff --git a/debian/squeeze/libraries/libkdcraw/debian/copyright b/debian/squeeze/libraries/libkdcraw/debian/copyright
new file mode 100644
index 000000000..05b67ad60
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/copyright
@@ -0,0 +1,72 @@
+This package was debianized by Achim Bohnet <ach@mpe.mpg.de>
+on Tue, 20-Feb-2007.
+
+It was downloaded from https://sourceforge.net/projects/kipi
+
+Upstream authors (from AUTHORS file):
+
+ Library wrapper:
+ Caulier Gilles <caulier.gilles@gmail.com>
+ Marcel Wiesweg <marcel.wiesweg@gmx.de>
+
+ CONTRIBUTORS:
+
+ Angelo Naselli <anaselli@linux.it>
+ Gerhard Kulzer <gerhard@kulzer.net>
+ Achim Bohnet <ach@mpe.mpg.de>
+ Guillaume Castagnino <casta@xwing.info>
+
+ (k)dcraw source and manpage
+ Dave Coffin <dcoffin@cybercom.net>
+
+AUTHORS AND MAINTAINERS :
+
+Copyright:
+
+ © 2005-2008 Gilles Caulier <caulier.gilles@gmail.com>
+ © 2006-2008 Marcel Wiesweg <marcel.wiesweg@gmx.de>
+ © 2007-2008 Guillaume Castagnino <casta@xwing.info>
+ © 2005 Laurent Montel <montel@kde.org>
+ © 1997-2008 Dave Coffin <dcoffin@cybercom.net>
+
+License:
+
+ This program is free software; you can redistribute it
+ and/or modify it under the terms of the GNU General
+ Public License as published by the Free Software Foundation;
+ either version 2, or (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+The Debian packaging is
+ © 2007 Mark Purcell <msp@debian.org>,
+ © 2007,2008 Achim Bohnet <ach@mpe.mpg.de>
+and is licensed under the GPL, see above.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+libkdcraw/dcraw/ contains a copy of dcraw code. dcraw Copyright:
+
+ dcraw.c -- Dave Coffin's raw photo decoder
+ Copyright 1997-2008 by Dave Coffin, dcoffin a cybercom o net
+
+ This is a command-line ANSI C program to convert raw photos from
+ any digital camera on any computer running any operating system.
+
+ No license is required to download and use dcraw.c. However,
+ to lawfully redistribute dcraw, you must either (a) offer, at
+ no extra charge, full source code* for all executable files
+ containing RESTRICTED functions, (b) distribute this code under
+ the GPL Version 2 or later, (c) remove all RESTRICTED functions,
+ re-implement them, or copy them from an earlier, unrestricted
+ Revision of dcraw.c, or (d) purchase a license from the author.
+
+ The functions that process Foveon images have been RESTRICTED
+ since Revision 1.237. All other code remains free for all uses.
+
+ *If you have not modified dcraw.c in any way, a link to my
+ homepage qualifies as "full source code".
diff --git a/debian/squeeze/libraries/libkdcraw/debian/docs b/debian/squeeze/libraries/libkdcraw/debian/docs
new file mode 100644
index 000000000..50bd824bb
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/docs
@@ -0,0 +1,2 @@
+NEWS
+README
diff --git a/debian/squeeze/libraries/libkdcraw/debian/libkdcraw3-trinity-dev.install b/debian/squeeze/libraries/libkdcraw/debian/libkdcraw3-trinity-dev.install
new file mode 100644
index 000000000..c07b71b2d
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/libkdcraw3-trinity-dev.install
@@ -0,0 +1,4 @@
+/opt/trinity/include/*
+opt/trinity/lib/lib*.so
+opt/trinity/lib/pkgconfig/*
+opt/trinity/lib/*.la
diff --git a/debian/squeeze/libraries/libkdcraw/debian/libkdcraw3-trinity.install b/debian/squeeze/libraries/libkdcraw/debian/libkdcraw3-trinity.install
new file mode 100644
index 000000000..cdef643e7
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/libkdcraw3-trinity.install
@@ -0,0 +1 @@
+opt/trinity/lib/lib*.so.*
diff --git a/debian/squeeze/libraries/libkdcraw/debian/rules b/debian/squeeze/libraries/libkdcraw/debian/rules
new file mode 100755
index 000000000..0606b98a9
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-qt-kde.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/kde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_SCRIPT_ENV += LDFLAGS="-Wl,--no-undefined -Wl,--as-needed"
+DEB_DH_INSTALL_ARGS := --sourcedir=debian/tmp
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
diff --git a/debian/squeeze/libraries/libkdcraw/debian/watch b/debian/squeeze/libraries/libkdcraw/debian/watch
new file mode 100644
index 000000000..ba648e43d
--- /dev/null
+++ b/debian/squeeze/libraries/libkdcraw/debian/watch
@@ -0,0 +1,3 @@
+version=3
+http://sf.net/kipi/libkdcraw-(.*)\.tar\.bz2 debian svn-upgrade
+