summaryrefslogtreecommitdiffstats
path: root/debian/squeeze/libraries
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-09-10 00:32:33 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-09-10 00:32:33 +0200
commit0cfa01db4de5bfcf6e8c05937ca8774594bf1af3 (patch)
treea81f7a12a14853958896d24fa33aeabd5cd7149c /debian/squeeze/libraries
parentbebae6d706c1484b05ae4c77ee6f14a10b4dac73 (diff)
downloadtde-packaging-0cfa01db4de5bfcf6e8c05937ca8774594bf1af3.tar.gz
tde-packaging-0cfa01db4de5bfcf6e8c05937ca8774594bf1af3.zip
Use dh_python as fallback in python-trinity on Debian and Ubuntu
This fix tde-guidance FTBFS on Ubuntu Lucid
Diffstat (limited to 'debian/squeeze/libraries')
-rw-r--r--debian/squeeze/libraries/python-trinity/debian/control6
-rw-r--r--debian/squeeze/libraries/python-trinity/debian/pycompat1
-rwxr-xr-xdebian/squeeze/libraries/python-trinity/debian/rules10
3 files changed, 5 insertions, 12 deletions
diff --git a/debian/squeeze/libraries/python-trinity/debian/control b/debian/squeeze/libraries/python-trinity/debian/control
index ef0d3115a..c69bdc5ea 100644
--- a/debian/squeeze/libraries/python-trinity/debian/control
+++ b/debian/squeeze/libraries/python-trinity/debian/control
@@ -4,17 +4,15 @@ Priority: optional
Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
XSBC-Original-Maintainer: Ricardo Javier Cardenes Medina <rcardenes@debian.org>
Uploaders: Torsten Marek <shlomme@debian.org>, Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
-Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-support (>= 0.6) | python-dev (>= 2.6.6-3~), dpatch, python-sip4, python-sip4-dbg, python-sip4-dev
+Build-Depends: debhelper (>= 5.0.38), libtqtinterface-dev, python, python-all-dev, python-all-dbg, sip4 (>= 4.10), python-sip4-dev (>= 4.10), python-tqt-dev, tdelibs14-trinity-dev, python-sip4, python-sip4-dbg, python-sip4-dev
Standards-Version: 3.8.4
Homepage: http://www.riverbankcomputing.co.uk/pytde/index.php
-XS-Python-Version: all
Package: python-trinity-trinity
Architecture: any
Depends: ${shlibs:Depends}, ${python:Depends}, python-tqt
Replaces: python-trinity-trinity (<< 4:14.0.0)
Breaks: python-trinity-trinity (<< 4:14.0.0)
-XB-Python-Version: ${python:Versions}
Provides: ${python:Provides}
Conflicts: python-trinity-trinity
Description: Trinity bindings for Python [Trinity]
@@ -28,7 +26,6 @@ Architecture: any
Replaces: python-trinity-trinity-dbg (<< 4:14.0.0)
Breaks: python-trinity-trinity-dbg (<< 4:14.0.0)
Depends: python-trinity-trinity (= ${binary:Version}), python-dbg, python-tqt-dbg, ${shlibs:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python (debug extensions) [Trinity]
Python binding module that provides wide access to the Trinity API,
also known as PyKDE. Using this, you'll get (for example) classes
@@ -42,7 +39,6 @@ Architecture: all
Replaces: python-trinity-trinity-dev (<< 4:14.0.0)
Breaks: python-trinity-trinity-dev (<< 4:14.0.0)
Depends: pytqt-tools, ${python:Depends}
-XB-Python-Version: ${python:Versions}
Description: Trinity bindings for Python - Development files and scripts [Trinity]
Development .sip files with definitions of PyKDE classes. They
are needed to build PyKDE, but also as building blocks of other
diff --git a/debian/squeeze/libraries/python-trinity/debian/pycompat b/debian/squeeze/libraries/python-trinity/debian/pycompat
deleted file mode 100644
index 0cfbf0888..000000000
--- a/debian/squeeze/libraries/python-trinity/debian/pycompat
+++ /dev/null
@@ -1 +0,0 @@
-2
diff --git a/debian/squeeze/libraries/python-trinity/debian/rules b/debian/squeeze/libraries/python-trinity/debian/rules
index d4dac70f3..473caac7d 100755
--- a/debian/squeeze/libraries/python-trinity/debian/rules
+++ b/debian/squeeze/libraries/python-trinity/debian/rules
@@ -14,7 +14,6 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-include /usr/share/dpatch/dpatch.make
# This has to be exported to make some magic below work.
export DH_OPTIONS
export QTDIR=/usr/share/qt3
@@ -31,8 +30,7 @@ endif
PYTHONS := $(shell pyversions -vr debian/control)
DBG_PYTHONS := $(shell pyversions -vd)
-DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
-DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_python)
GCCVER := $(shell gcc --version | sed -n '/^gcc (GCC)/s/.*(GCC) \(...\).*/\1/p')
ifneq (,$(filter $(GCCVER),4.2 4.3))
@@ -45,7 +43,7 @@ endif
configure: $(PYTHONS:%=build-%/configure-stamp) $(DBG_PYTHONS:%=dbg-build-%/configure-stamp)
-build-%/configure-stamp: patch-stamp
+build-%/configure-stamp:
dh_testdir
mkdir -p build-$*
cd build-$* && python$* ../configure.py \
@@ -53,7 +51,7 @@ build-%/configure-stamp: patch-stamp
-v /opt/trinity/share/sip/trinity -j $(SPLIT)
touch $@
-dbg-build-%/configure-stamp: patch-stamp
+dbg-build-%/configure-stamp:
dh_testdir
mkdir -p dbg-build-$*
cd dbg-build-$* && python$*-dbg ../configure.py \
@@ -73,7 +71,7 @@ dbg-build-%/build-stamp: dbg-build-%/configure-stamp
$(MAKE) -C dbg-build-$*
touch $@
-clean: unpatch
+clean:
dh_testdir
dh_testroot
rm -f *-stamp