summaryrefslogtreecommitdiffstats
path: root/debian/wheezy/applications/desktop-effects-tde/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2013-08-27 04:57:39 +0200
committerSlávek Banko <slavek.banko@axis.cz>2013-08-27 05:00:17 +0200
commit2d0d0ba99b507cab093962cb910ddc7dd4755c94 (patch)
tree25732cac7c5450d1df2efe47d153253bec8a83be /debian/wheezy/applications/desktop-effects-tde/debian/rules
parente59f9132f600c669c73885b0b58a715e6bfd03a6 (diff)
downloadtde-packaging-2d0d0ba99b507cab093962cb910ddc7dd4755c94.tar.gz
tde-packaging-2d0d0ba99b507cab093962cb910ddc7dd4755c94.zip
Switch to dh_python2 (or dh_pysupport as fallback) on Debian and Ubuntu
Diffstat (limited to 'debian/wheezy/applications/desktop-effects-tde/debian/rules')
-rwxr-xr-xdebian/wheezy/applications/desktop-effects-tde/debian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/wheezy/applications/desktop-effects-tde/debian/rules b/debian/wheezy/applications/desktop-effects-tde/debian/rules
index d494616db..41ad63be2 100755
--- a/debian/wheezy/applications/desktop-effects-tde/debian/rules
+++ b/debian/wheezy/applications/desktop-effects-tde/debian/rules
@@ -1,5 +1,8 @@
#!/usr/bin/make -f
+DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
+DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
+
include /usr/share/cdbs/1/rules/debhelper.mk
DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
@@ -13,4 +16,4 @@ DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
binary-install/desktop-effects-tde-trinity::
- dh_pycentral -pdesktop-effects-tde-trinity
+ ${DH_PYTHON2} -pdesktop-effects-tde-trinity