summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-10-13 10:23:00 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-10-13 10:23:00 +0200
commitb739baf7230a8b83f8b9e48d551e5fc8fb4bff4b (patch)
tree0a45d6a3c4dccf163be3953c785cbbfabd47d6e4 /debian
parent62d9e5b6085bc57bd47a4e8645e5e723067c9e7e (diff)
downloadtde-packaging-b739baf7230a8b83f8b9e48d551e5fc8fb4bff4b.tar.gz
tde-packaging-b739baf7230a8b83f8b9e48d551e5fc8fb4bff4b.zip
DEB libcaldav: Add definitions for multi-arch.
CMAKE_INSTALL_LIBDIR is set independently of GNUInstallDirs. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian')
-rw-r--r--debian/_base/dependencies/libcaldav/debian/control2
-rwxr-xr-xdebian/_base/dependencies/libcaldav/debian/rules7
2 files changed, 9 insertions, 0 deletions
diff --git a/debian/_base/dependencies/libcaldav/debian/control b/debian/_base/dependencies/libcaldav/debian/control
index d3b1e2080..7d8dc70a8 100644
--- a/debian/_base/dependencies/libcaldav/debian/control
+++ b/debian/_base/dependencies/libcaldav/debian/control
@@ -7,6 +7,7 @@ Standards-Version: 3.8.3
Package: libcaldav
Architecture: any
+Multi-Arch: same
Section: libs
Depends: ${shlibs:Depends}
Description:
@@ -14,6 +15,7 @@ Description:
Package: libcaldav-dev
Architecture: any
+Multi-Arch: foreign
Section: libdevel
Depends: libcaldav (= ${binary:Version})
Description:
diff --git a/debian/_base/dependencies/libcaldav/debian/rules b/debian/_base/dependencies/libcaldav/debian/rules
index 56e8f5415..c75240154 100755
--- a/debian/_base/dependencies/libcaldav/debian/rules
+++ b/debian/_base/dependencies/libcaldav/debian/rules
@@ -7,9 +7,16 @@ include debian/cdbs/debian-tde.mk
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
+
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_SKIP_RPATH="OFF" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
-DWITH_ALL_OPTIONS="ON" \
-DBUILD_ALL="ON"