summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-05-25 19:41:40 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-05-26 12:15:00 +0200
commitd79b34324d6a74604fb196616fa814f16208f9a2 (patch)
treef8fe9e385e833d37ebdbca10a5f1d876281e78fc /debian
parente1bd49c4ecd968cf1642c35e7318fb311b04e2e2 (diff)
downloadtde-packaging-d79b34324d6a74604fb196616fa814f16208f9a2.tar.gz
tde-packaging-d79b34324d6a74604fb196616fa814f16208f9a2.zip
DEB tde-i18n: Use top-level CMake rules to build package.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/_base/core/tde-i18n/debian/rules29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/_base/core/tde-i18n/debian/rules b/debian/_base/core/tde-i18n/debian/rules
index 3a352bb27..31b7b28fc 100755
--- a/debian/_base/core/tde-i18n/debian/rules
+++ b/debian/_base/core/tde-i18n/debian/rules
@@ -10,6 +10,7 @@ I18N_DIRS := $(wildcard $(I18N_DIR_PREFIX)-*)
# Stamps and support variables
cur_lang = $(word 2,$(subst __, ,$@))
+cur_lang_target = $(subst @,_,$(cur_lang))
cur_lang_dir = $(patsubst %,$(I18N_DIR_PREFIX)-%,$(cur_lang))
cur_pkg_lang = $(subst _,,$(subst @,,$(subst @latn,latin,$(shell echo $(cur_lang) | tr '[:upper:]' '[:lower:]'))))
cur_pkg = $(I18N_DEST_PREFIX)-$(cur_pkg_lang)-trinity
@@ -56,6 +57,20 @@ build::
dh_testdir
dh_prep
+ifneq "$(wildcard /usr/bin/ninja)" ""
+
+build:: debian/stamp__build
+
+debian/stamp__build:
+ [ -d build ] || \
+ mkdir build
+ cd build && \
+ cmake .. $(DEB_CMAKE_NORMAL_ARGS) $(DEB_CMAKE_EXTRA_FLAGS) && \
+ $(MAKE) $(DEB_MAKE_PARALLEL)
+ touch $@
+
+else
+
build:: $(STAMP_BUILD)
$(STAMP_BUILD):
@@ -69,6 +84,7 @@ $(STAMP_BUILD):
$(MAKE) $(DEB_MAKE_PARALLEL)
touch $@
+endif
install::
dh_testdir
@@ -77,9 +93,19 @@ install::
install:: $(I18N_INSTALL)
$(I18N_INSTALL): build
+ifneq "$(wildcard /usr/bin/ninja)" ""
+ [ ! -e $(cur_lang_dir)/CMakeLists.txt ] || \
+ DESTDIR=$(CURDIR)/debian/$(cur_pkg) $(MAKE) -C build install-$(cur_lang_target)
+else
cd $(cur_lang_dir)/build && \
DESTDIR=$(CURDIR)/debian/$(cur_pkg) $(MAKE) install $(DEB_MAKE_PARALLEL)
+endif
+
+ifneq "$(wildcard /usr/bin/ninja)" ""
+
+clean: debian-clean
+else
clean: $(I18N_CLEAN) debian-clean
@@ -87,8 +113,11 @@ $(I18N_CLEAN):
dh_testdir
rm -rf $(cur_lang_dir)/build
+endif
+
debian-clean:
dh_testdir
+ rm -rf build
rm -rf debian/$(I18N_DEST_PREFIX)-*
rm -f debian/stamp__*
dh_clean