summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/ksplashml/ksplashml-3.5.13.2.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/ksplashml/ksplashml-3.5.13.2.ebuild
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/ksplashml/ksplashml-3.5.13.2.ebuild')
-rw-r--r--gentoo/trinity-base/ksplashml/ksplashml-3.5.13.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/gentoo/trinity-base/ksplashml/ksplashml-3.5.13.2.ebuild b/gentoo/trinity-base/ksplashml/ksplashml-3.5.13.2.ebuild
new file mode 100644
index 000000000..edabaa78e
--- /dev/null
+++ b/gentoo/trinity-base/ksplashml/ksplashml-3.5.13.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="kdebase"
+
+inherit trinity-meta
+
+DESCRIPTION="Trinity splashscreen framework (of Trinity itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libXcursor
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with xinerama XINERAMA)
+ )
+
+ trinity-meta_src_configure
+}