summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'gentoo/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild')
-rw-r--r--gentoo/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gentoo/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild b/gentoo/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
new file mode 100644
index 000000000..4c205c94f
--- /dev/null
+++ b/gentoo/trinity-base/tdebase-tdeioslaves/tdebase-tdeioslaves-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdebase"
+
+inherit trinity-meta
+
+TSM_EXTRACT="tdeioslave"
+
+DESCRIPTION="Generic Trinity KIOslaves"
+KEYWORDS=
+IUSE="samba ldap sasl openexr -hal +tdehw"
+REQUIRED_USE="tdehw? ( !hal )"
+
+DEPEND="
+ x11-libs/libXcursor
+ openexr? ( >=media-libs/openexr-1.2.2-r2 )
+ samba? ( net-fs/samba )
+ ldap? ( net-nds/openldap )
+ sasl? ( dev-libs/cyrus-sasl )
+ hal? ( dev-libs/dbus-tqt
+ =sys-apps/hal-0.5* )"
+
+RDEPEND="${DEPEND}"
+# CHECKME: optional dependencies
+#DEPEND="
+# >=dev-libs/cyrus-sasl-2
+# hal? ( dev-libs/dbus-qt3-old =sys-apps/hal-0.5* )"
+# x11-apps/xhost
+RDEPEND="${DEPEND}
+ virtual/ssh
+ trinity-base/tdeeject:${SLOT}"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_XCURSOR=ON
+ $(cmake-utils_use_with samba SAMBA)
+ $(cmake-utils_use_with ldap LDAP)
+ $(cmake-utils_use_with sasl SASL)
+ $(cmake-utils_use_with openexr OPENEXR)
+ $(cmake-utils_use_with hal HAL)
+ $(cmake-utils_use_with tdehw TDEHWLIB)
+ )
+
+ trinity-meta_src_configure
+}