summaryrefslogtreecommitdiffstats
path: root/redhat/applications/gtk3-tqt-engine/gtk3-tqt-engine-14.0.0.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2017-08-02 17:19:39 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2017-08-02 17:19:39 +0200
commitdf20fa92cb84771b6c0a3a0f3fa79af383f80d4d (patch)
treede5c9c98c8da31f46872604da5497bc1871c64bd /redhat/applications/gtk3-tqt-engine/gtk3-tqt-engine-14.0.0.spec
parentfafb41251ffab1087bd69f1a8a4232c0651075b0 (diff)
downloadtde-packaging-df20fa92cb84771b6c0a3a0f3fa79af383f80d4d.tar.gz
tde-packaging-df20fa92cb84771b6c0a3a0f3fa79af383f80d4d.zip
RPM: update build scripts for PCLinuxOS 2017
Diffstat (limited to 'redhat/applications/gtk3-tqt-engine/gtk3-tqt-engine-14.0.0.spec')
-rw-r--r--redhat/applications/gtk3-tqt-engine/gtk3-tqt-engine-14.0.0.spec17
1 files changed, 16 insertions, 1 deletions
diff --git a/redhat/applications/gtk3-tqt-engine/gtk3-tqt-engine-14.0.0.spec b/redhat/applications/gtk3-tqt-engine/gtk3-tqt-engine-14.0.0.spec
index c28db02e8..be57d2f0e 100644
--- a/redhat/applications/gtk3-tqt-engine/gtk3-tqt-engine-14.0.0.spec
+++ b/redhat/applications/gtk3-tqt-engine/gtk3-tqt-engine-14.0.0.spec
@@ -109,6 +109,19 @@ GTK3 style engine which uses the active TDE style to draw its widgets
unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
+if [ -d "/usr/include/atk-1.0" ]; then
+ extra_includes="%{_includedir}/atk-1.0:${extra_includes}"
+fi
+if [ -d "/usr/include/gdk-pixbuf-2.0" ]; then
+ extra_includes="%{_includedir}/gdk-pixbuf-2.0:${extra_includes}"
+fi
+if [ -d "/usr/include/gtk-3.0" ]; then
+ extra_includes="%{_includedir}/gtk-3.0:${extra_includes}"
+fi
+if [ -d "/usr/include/pango-1.0" ]; then
+ extra_includes="%{_includedir}/pango-1.0:${extra_includes}"
+fi
+
%configure \
--prefix=%{tde_prefix} \
--exec-prefix=%{tde_prefix} \
@@ -124,7 +137,9 @@ export PATH="%{tde_bindir}:${PATH}"
--enable-final \
--enable-closure \
--enable-rpath \
- --disable-gcc-hidden-visibility
+ --disable-gcc-hidden-visibility \
+ \
+ --with-extra-includes=${extra_includes}
%__make %{?_smp_mflags}