summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kdbg/kdbg-14.0.0.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2013-07-19 20:47:36 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2013-07-19 20:47:36 +0200
commit81cfe3de65065da2e9693971b05ee35cca6bf483 (patch)
treefa557dc984def90bd9bcbc44e8c98c65923ecd94 /redhat/applications/kdbg/kdbg-14.0.0.spec
parent04dea0b400cc28566c4a09214a332a2360f8ed3b (diff)
downloadtde-packaging-81cfe3de65065da2e9693971b05ee35cca6bf483.tar.gz
tde-packaging-81cfe3de65065da2e9693971b05ee35cca6bf483.zip
RPM Packaging: more updates
Diffstat (limited to 'redhat/applications/kdbg/kdbg-14.0.0.spec')
-rw-r--r--redhat/applications/kdbg/kdbg-14.0.0.spec152
1 files changed, 152 insertions, 0 deletions
diff --git a/redhat/applications/kdbg/kdbg-14.0.0.spec b/redhat/applications/kdbg/kdbg-14.0.0.spec
new file mode 100644
index 000000000..a3553ff45
--- /dev/null
+++ b/redhat/applications/kdbg/kdbg-14.0.0.spec
@@ -0,0 +1,152 @@
+# Default version for this component
+%define tde_pkg kdbg
+%define tde_version 14.0.0
+
+# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
+%if "%{?tde_prefix}" != "/usr"
+%define _variant .opt
+%endif
+
+# TDE specific building variables
+%define tde_bindir %{tde_prefix}/bin
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+
+%define tde_tdeappdir %{tde_datadir}/applications/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+%define _docdir %{tde_docdir}
+
+
+Name: trinity-%{tde_pkg}
+Summary: graphical debugger interface [Trinity]
+Version: 2.2.2
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+
+License: GPLv2+
+Group: Applications/Utilities
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+URL: http://www.trinitydesktop.org/
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+#Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+Source0: kdbg-master.tar.gz
+Source1: admin-master.tar.gz
+
+BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+BuildRequires: gettext
+
+
+%description
+KDbg is a graphical user interface to gdb, the GNU debugger. It provides
+an intuitive interface for setting breakpoints, inspecting variables,
+stepping through code and much more. KDbg requires TDE but you can of
+course debug any program.
+
+KDbg can also debug XSLT (XML stylesheet translation) scripts by
+interfacing with xsldbg. For this the package kxsldbg must be installed.
+
+Features include the following:
+* Inspection of variable values in a tree structure.
+* Direct member: For certain compound data types the most important
+ member values are displayed next to the variable name, so that it is
+ not necessary to expand the subtree of that variable in order to see
+ the member value. KDbg can also display Qt's QString values, which
+ are Unicode strings.
+* Debugger at your finger tips: The basic debugger functions (step,
+ next, run, finish, until, set/clear/enable/disable breakpoint) are
+ bound to function keys F5 through F10. Quick and easy.
+* View source code, search text, set program arguments and environment
+ variables, display arbitrary expressions.
+* Debugging of core dumps, attaching to running processes is possible.
+* Conditional breakpoints.
+
+%if 0%{?suse_version} || 0%{?pclinuxos}
+%debug_package
+%endif
+
+##########
+
+%prep
+#setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+%setup -q -a 1 -n kdbg-master
+rmdir admin
+mv admin-master admin
+
+%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
+%__cp -f "/usr/share/libtool/config/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
+%__make -f "admin/Makefile.common"
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+export LDFLAGS="-L%{tde_libdir} -I%{tde_includedir}"
+
+%configure \
+ --prefix=%{tde_prefix} \
+ --exec-prefix=%{tde_prefix} \
+ --bindir=%{tde_bindir} \
+ --datadir=%{tde_datadir} \
+ --includedir=%{tde_tdeincludedir} \
+ --docdir=%{tde_tdedocdir} \
+ --libdir=%{tde_libdir} \
+ --disable-rpath
+
+%__make %{?_smp_mflags}
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot}
+
+%find_lang %{tde_pkg}
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%post
+update-desktop-database %{tde_appdir} > /dev/null
+touch --no-create %{tde_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{tde_datadir}/icons/locolor || :
+
+
+%postun
+update-desktop-database %{tde_appdir} > /dev/null
+touch --no-create %{tde_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{tde_datadir}/icons/hicolor || :
+gtk-update-icon-cache --quiet %{tde_datadir}/icons/locolor || :
+
+
+%files -f %{tde_pkg}.lang
+%defattr(-,root,root,-)
+%{tde_bindir}/kdbg
+%{tde_tdeappdir}/kdbg.desktop
+%{tde_datadir}/apps/kdbg/
+%{tde_datadir}/config/kdbgrc
+%lang(de) %{tde_tdedocdir}/HTML/de/kdbg/
+%lang(en) %{tde_tdedocdir}/HTML/en/kdbg/
+%lang(ru) %{tde_tdedocdir}/HTML/ru/kdbg/
+%{tde_datadir}/icons/hicolor/*/apps/kdbg.png
+%{tde_datadir}/icons/locolor/*/apps/kdbg.png
+
+
+%changelog
+* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2.2.2-1
+- Initial release for TDE 14.0.0