summaryrefslogtreecommitdiffstats
path: root/redhat/applications/krusader/krusader-14.0.0.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2015-04-21 21:19:30 +0200
committerFrançois Andriot <albator78@libertysurf.fr>2015-04-21 21:19:30 +0200
commit4af4e847e3abd6f935e298f799b4b99c49600409 (patch)
treed052a9bc01378e6aa90142c3b353c678dd034192 /redhat/applications/krusader/krusader-14.0.0.spec
parent07d8f15f3a8cf671ea485cecd1da5d51d23be84e (diff)
downloadtde-packaging-4af4e847e3abd6f935e298f799b4b99c49600409.tar.gz
tde-packaging-4af4e847e3abd6f935e298f799b4b99c49600409.zip
RPM Packaging: update krusader, kscope, ksensors, kshowmail, kshutdown
Diffstat (limited to 'redhat/applications/krusader/krusader-14.0.0.spec')
-rw-r--r--redhat/applications/krusader/krusader-14.0.0.spec100
1 files changed, 68 insertions, 32 deletions
diff --git a/redhat/applications/krusader/krusader-14.0.0.spec b/redhat/applications/krusader/krusader-14.0.0.spec
index b62b79384..0882e5163 100644
--- a/redhat/applications/krusader/krusader-14.0.0.spec
+++ b/redhat/applications/krusader/krusader-14.0.0.spec
@@ -1,54 +1,79 @@
-# Default version for this component
-%define tde_pkg krusader
+#
+# spec file for package krusader (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
-# TDE specific building variables
+%define tde_pkg krusader
+%define tde_prefix /opt/trinity
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
-Name: trinity-%{tde_pkg}
-Summary: twin-panel (commander-style) file manager for TDE (and other desktops)
-Version: 1.90.0
-Release: %{?!preversion:6}%{?preversion:5_%{preversion}}%{?dist}%{?_variant}
+Name: trinity-%{tde_pkg}
+Epoch: %{tde_epoch}
+Version: 1.90.0
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Summary: Twin-panel (commander-style) file manager for TDE (and other desktops)
+Group: Applications/Utilities
+URL: http://www.trinitydesktop.org/
-License: GPLv2+
-Group: Applications/Utilities
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
-URL: http://www.trinitydesktop.org/
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
-Prefix: %{tde_prefix}
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Prefix: %{tde_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-
BuildRequires: trinity-tdebindings-devel >= %{tde_version}
+BuildRequires: autoconf automake libtool m4
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: fdupes
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
%description
Krusader is a simple, easy, powerful, twin-panel (commander-style) file
@@ -70,10 +95,14 @@ Almost completely customizable, Krusader is very user friendly, fast and looks
great on your desktop.
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
@@ -115,20 +144,27 @@ export PATH="%{tde_bindir}:${PATH}"
%find_lang %{tde_pkg}
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+echo "OnlyShowIn=TDE;" >>"%{?buildroot}%{tde_tdeappdir}/%{tde_pkg}.desktop"
+%suse_update_desktop_file krusader System FileManager
+%suse_update_desktop_file krusader_root-mode System FileManager
+%endif
+
%clean
%__rm -rf %{buildroot}
%post
-update-desktop-database %{tde_appdir} > /dev/null
+update-desktop-database %{tde_tdeappdir} > /dev/null
for f in crystalsvg locolor ; do
touch --no-create %{tde_datadir}/icons/${f} || :
gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
done
%postun
-update-desktop-database %{tde_appdir} > /dev/null
+update-desktop-database %{tde_tdeappdir} > /dev/null
for f in crystalsvg locolor ; do
touch --no-create %{tde_datadir}/icons/${f} || :
gtk-update-icon-cache --quiet %{tde_datadir}/icons/${f} || :
@@ -158,5 +194,5 @@ done
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 1.90.0-6
+* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2:1.90.0-1
- Initial release for TDE 14.0.0