summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kxmleditor/kxmleditor.spec
diff options
context:
space:
mode:
authorFrançois Andriot <albator78@libertysurf.fr>2021-01-30 14:34:02 +0100
committerFrançois Andriot <albator78@libertysurf.fr>2021-01-30 22:29:41 +0100
commit6581dc50b83f203d65eac61c00a159ab2a6ddb5d (patch)
tree85c02d38ca9dcedc28798ee41c4b16ec7260e9bc /redhat/applications/kxmleditor/kxmleditor.spec
parent87e57a1a070839a44db16a0410ef57902db2df3e (diff)
downloadtde-packaging-6581dc50b83f203d65eac61c00a159ab2a6ddb5d.tar.gz
tde-packaging-6581dc50b83f203d65eac61c00a159ab2a6ddb5d.zip
RPM: massive update and cleanup
Diffstat (limited to 'redhat/applications/kxmleditor/kxmleditor.spec')
-rw-r--r--redhat/applications/kxmleditor/kxmleditor.spec59
1 files changed, 28 insertions, 31 deletions
diff --git a/redhat/applications/kxmleditor/kxmleditor.spec b/redhat/applications/kxmleditor/kxmleditor.spec
index cf0447a98..846645b56 100644
--- a/redhat/applications/kxmleditor/kxmleditor.spec
+++ b/redhat/applications/kxmleditor/kxmleditor.spec
@@ -18,7 +18,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.0.0
+%define tde_version 14.1.0
%endif
%define tde_pkg kxmleditor
%define tde_prefix /opt/trinity
@@ -61,7 +61,7 @@ BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
-BuildRequires: autoconf automake libtool m4
+BuildRequires: cmake
BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool
@@ -98,40 +98,36 @@ contents.
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-%__cp "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f "admin/Makefile.common"
-
%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig:${PKG_CONFIG_PATH}"
-
-%configure \
- --prefix=%{tde_prefix} \
- --exec-prefix=%{tde_prefix} \
- --bindir=%{tde_bindir} \
- --datadir=%{tde_datadir} \
- --includedir=%{tde_tdeincludedir} \
- --libdir=%{tde_libdir} \
- --mandir=%{tde_mandir} \
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
\
- --disable-dependency-tracking \
- --disable-debug \
- --enable-new-ldflags \
- --enable-final \
- --enable-closure \
- --enable-rpath \
- --disable-gcc-hidden-visibility
+ -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
+ -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
+ -DDATA_INSTALL_DIR=%{tde_datadir}/apps \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DBUILD_ALL=ON \
+ ..
-%__make %{?_smp_mflags} || %__make
+%__make %{?_smp_mflags}
%install
export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
-%__make install DESTDIR=%{buildroot}
+%__make install DESTDIR=%{buildroot} -C build
%find_lang %{tde_pkg}
@@ -152,16 +148,17 @@ export PATH="%{tde_bindir}:${PATH}"
%files -f %{tde_pkg}.lang
%defattr(-,root,root,-)
%{tde_bindir}/kxmleditor
-%{tde_tdelibdir}/libkxmleditorpart.la
-%{tde_tdelibdir}/libkxmleditorpart.so
-%{tde_tdelibdir}/libkxmleditorpart.so.1
-%{tde_tdelibdir}/libkxmleditorpart.so.1.0.0
+%{tde_libdir}/libkxmleditorpart.la
+%{tde_libdir}/libkxmleditorpart.so
+%{tde_libdir}/libkxmleditorpart.so.1
+%{tde_libdir}/libkxmleditorpart.so.1.0.0
%{tde_tdeappdir}/kxmleditor.desktop
%{tde_datadir}/apps/kxmleditor/
%{tde_tdedocdir}/HTML/en/kxmleditor/
%{tde_datadir}/icons/hicolor/*/apps/kxmleditor.png
%{tde_datadir}/icons/locolor/*/apps/kxmleditor.png
%{tde_datadir}/services/kxmleditorpart.desktop
+%{tde_mandir}/man1/kxmleditor.1*
%post