summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/internet/ktorrent/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
commitbd72eef4a4458f8d2e52609d7b6cf3efe12a0177 (patch)
treeb797d29ee85d482247cfecda13d1fb572e4c4d62 /ubuntu/_base/applications/internet/ktorrent/debian/rules
parent5051f08d847e70346920d72e34da55558b89145c (diff)
downloadtde-packaging-bd72eef4.tar.gz
tde-packaging-bd72eef4.zip
Rearranged applications folder into sub categories.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/internet/ktorrent/debian/rules')
-rwxr-xr-xubuntu/_base/applications/internet/ktorrent/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/internet/ktorrent/debian/rules b/ubuntu/_base/applications/internet/ktorrent/debian/rules
new file mode 100755
index 000000000..a90794996
--- /dev/null
+++ b/ubuntu/_base/applications/internet/ktorrent/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_INSTALL_MANPAGES_ktorrent = ktorrent.1
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
+
+build/ktorrent-trinity::
+ docbook2x-man debian/ktorrent.1.docbook
+
+clean::
+ rm -f ktorrent.1