summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kerry/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2019-04-03 22:56:40 +0900
commit11394aecd1f906fee2ebd2b90412aeba4651fbff (patch)
treebcf750380e6d9fc7dbe524e16bbe2afde25dcfa0 /ubuntu/_base/applications/kerry/debian/rules
parentd24bd898174453b586ac90f2ef7a60165fa26fde (diff)
downloadtde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.tar.gz
tde-packaging-11394aecd1f906fee2ebd2b90412aeba4651fbff.zip
DEB: use _base folder for a distro instead of specific distros (squeeze
and maverick). Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/kerry/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kerry/debian/rules35
1 files changed, 35 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/kerry/debian/rules b/ubuntu/_base/applications/kerry/debian/rules
new file mode 100755
index 000000000..7e44d25e2
--- /dev/null
+++ b/ubuntu/_base/applications/kerry/debian/rules
@@ -0,0 +1,35 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+# include /usr/share/cdbs/1/class/kde.mk
+include debian/cdbs/debian-qt-kde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
+
+DEB_INSTALL_MANPAGES_kerry-trinity = kerry.1
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+build/kerry-trinity::
+ docbook2x-man debian/kerry.1.docbook
+
+clean::
+ rm -f kerry.1
+
+binary-post-install/kerry-trinity::
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/libtdeinit_kerry.so
+ chrpath -d debian/kerry-trinity/opt/trinity/bin/kerry
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/trinity/kerry.so
+ chrpath -d debian/kerry-trinity/opt/trinity/lib/trinity/kcm_beagle.so
+ mkdir -p debian/kerry-trinity/opt/trinity/share/man/man1/
+ mv debian/kerry-trinity/usr/share/man/man1/kerry.1 debian/kerry-trinity/opt/trinity/share/man/man1/kerry.1
+ rm -rf debian/kerry-trinity/usr/share/man