summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kopete-otr/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-06-24 20:49:59 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-06-24 20:49:59 +0200
commit47df847e18c5ee625ec664a238072969b17802bc (patch)
tree9944abb8d7914de8d27268f821820ded682c3a15 /ubuntu/_base/applications/kopete-otr/debian/rules
parent034ca550a5bc0b1ffd3e9c85d89a3f590a3ea314 (diff)
downloadtde-packaging-47df847e18c5ee625ec664a238072969b17802bc.tar.gz
tde-packaging-47df847e18c5ee625ec664a238072969b17802bc.zip
DEB kopete-otr: Switch to cmake.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/kopete-otr/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kopete-otr/debian/rules37
1 files changed, 12 insertions, 25 deletions
diff --git a/ubuntu/_base/applications/kopete-otr/debian/rules b/ubuntu/_base/applications/kopete-otr/debian/rules
index 205e98266..a6797f19a 100755
--- a/ubuntu/_base/applications/kopete-otr/debian/rules
+++ b/ubuntu/_base/applications/kopete-otr/debian/rules
@@ -1,30 +1,17 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"