summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/ksquirrel/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-04-04 03:02:11 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-04-04 15:53:01 +0200
commit3d0fe45a7b0b586d096644a3581df8307787eb3a (patch)
treef6e05af72fa60089c8db1e9999d982d47be07bc8 /ubuntu/_base/applications/ksquirrel/debian/rules
parent5d067f8a1c69ffd2585cd3a46f0601cc552e40d2 (diff)
downloadtde-packaging-3d0fe45a7b0b586d096644a3581df8307787eb3a.tar.gz
tde-packaging-3d0fe45a7b0b586d096644a3581df8307787eb3a.zip
DEB: Move DEB_DH_BUILDDEB_ARGS to common cdbs rules.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/ksquirrel/debian/rules')
-rwxr-xr-xubuntu/_base/applications/ksquirrel/debian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/ksquirrel/debian/rules b/ubuntu/_base/applications/ksquirrel/debian/rules
index 328283c93..813fff66f 100755
--- a/ubuntu/_base/applications/ksquirrel/debian/rules
+++ b/ubuntu/_base/applications/ksquirrel/debian/rules
@@ -16,8 +16,15 @@ DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
# These are used for cross-compiling and for saving the configure script
# from having to guess our platform (since we know it already)