summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/ktechlab/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:33:55 +0800
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-11-14 11:41:37 +0800
commit62b2ab9301211a2dab70e2eeda385fd15371ea3d (patch)
tree48300792b4f5249dad2004673c7726b7a0729a75 /ubuntu/_base/applications/ktechlab/debian/rules
parentbaec12614b7081162900650cfd5e017de5ca21dd (diff)
downloadtde-packaging-62b2ab9301211a2dab70e2eeda385fd15371ea3d.tar.gz
tde-packaging-62b2ab9301211a2dab70e2eeda385fd15371ea3d.zip
DEB ktechlab: switch to cmake under Ubuntu too. Switch to common TDE cdbs rules. The man page has been moved to the main tree.
This is the same as commit 1117ce79 but applied to Ubuntu. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> (cherry picked from commit 2064c92d78e53c5753ccc22a2b83abfe120fa8cb)
Diffstat (limited to 'ubuntu/_base/applications/ktechlab/debian/rules')
-rwxr-xr-xubuntu/_base/applications/ktechlab/debian/rules113
1 files changed, 18 insertions, 95 deletions
diff --git a/ubuntu/_base/applications/ktechlab/debian/rules b/ubuntu/_base/applications/ktechlab/debian/rules
index 103f921f7..7855de455 100755
--- a/ubuntu/_base/applications/ktechlab/debian/rules
+++ b/ubuntu/_base/applications/ktechlab/debian/rules
@@ -1,107 +1,30 @@
#!/usr/bin/make -f
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
--include debian/debiandirs
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
-CFLAGS = -Wall -g
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-#debian/debiandirs: admin/debianrules
-# perl -w admin/debianrules echodirs > debian/debiandirs
-
debian/ktechlab.xpm: icons/hi32-app-ktechlab.png
convert $< $@
-config.status:
+post-patches:: debian/ktechlab.xpm
dh_testdir
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
+clean::
+ifneq "$(wildcard debian/ktechlab.xpm)" ""
+ rm -f debian/ktechlab.xpm
endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/misc/config.sub)" ""
- cp -f /usr/share/misc/config.sub admin/config.sub
-endif
-ifneq "$(wildcard /usr/share/misc/config.guess)" ""
- cp -f /usr/share/misc/config.guess admin/config.guess
-endif
-
- make -f admin/Makefile.common cvs
- touch debian/stamp-bootstrap
-
- PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/tde CFLAGS="$(CFLAGS) -Wl,-z,defs" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) $(configkde) --prefix=/opt/trinity
-
-build: build-stamp debian/ktechlab.xpm
-
-build-stamp: config.status
- dh_testdir
- env PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/tde $(MAKE)
- touch build-stamp
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- [ ! -f po/Makefile ] || $(MAKE) -C po clean
- [ ! -f Makefile ] || $(MAKE) distclean
- rm -f config.log debian/ktechlab.xpm config.sub config.guess
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- env PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/tde $(MAKE) install DESTDIR=$(CURDIR)/debian/ktechlab-trinity
- env PATH=/opt/trinity/bin:$(PATH) CMAKE_LIBRARY_PATH=/opt/trinity/lib CMAKE_INCLUDE_PATH=/opt/trinity/include/tde $(MAKE) -C po install DESTDIR=$(CURDIR)/debian/ktechlab-trinity
- install -D -m 644 debian/ktechlab.xpm debian/ktechlab-trinity/opt/trinity/share/pixmaps/ktechlab.xpm
- chrpath -d $(CURDIR)/debian/ktechlab-trinity/opt/trinity/bin/ktechlab
- chrpath -d $(CURDIR)/debian/ktechlab-trinity/opt/trinity/bin/microbe
-
-
-binary-indep: build install
-
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs ChangeLog
- dh_installdocs
- dh_installexamples
- dh_installmenu
- dh_installman
- mv debian/ktechlab-trinity/usr/share/man debian/ktechlab-trinity/opt/trinity/share/
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb $(DEB_DH_BUILDDEB_ARGS)
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install unpatch