summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/kvirc/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2021-07-04 21:06:02 +0900
commitbd72eef4a4458f8d2e52609d7b6cf3efe12a0177 (patch)
treeb797d29ee85d482247cfecda13d1fb572e4c4d62 /ubuntu/_base/applications/kvirc/debian/rules
parent5051f08d847e70346920d72e34da55558b89145c (diff)
downloadtde-packaging-bd72eef4a4458f8d2e52609d7b6cf3efe12a0177.tar.gz
tde-packaging-bd72eef4a4458f8d2e52609d7b6cf3efe12a0177.zip
Rearranged applications folder into sub categories.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/kvirc/debian/rules')
-rwxr-xr-xubuntu/_base/applications/kvirc/debian/rules101
1 files changed, 0 insertions, 101 deletions
diff --git a/ubuntu/_base/applications/kvirc/debian/rules b/ubuntu/_base/applications/kvirc/debian/rules
deleted file mode 100755
index 6fc9dffe2..000000000
--- a/ubuntu/_base/applications/kvirc/debian/rules
+++ /dev/null
@@ -1,101 +0,0 @@
-#! /usr/bin/make -f
-#
-# Build script for the KVIrc 3 debian package.
-# Using Common Debian Build System (CDBS).
-#
-
- #
- # Update Makefiles
- #
- # This is done outside of debian/rules now, so that Debian autobuilders
- # will all be building the same source, with no deviation because they
- # might have an outdated autotools-dev version.
-common-configure-impl::
-# ./autogen.sh
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/autotools.mk
-#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
-
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
- #
- # Specify extra configure options:
- #
-DEB_CONFIGURE_EXTRA_FLAGS := --with-fno-rtti --with-aa-fonts --with-big-channels
-DEB_CONFIGURE_EXTRA_FLAGS += --enable-perl --with-pic --enable-wall --mandir=$(DEB_CONFIGURE_MANDIR)
-DEB_CONFIGURE_EXTRA_FLAGS += --disable-rpath --prefix=/opt/trinity
-
- #
- # If debug is specified, turn it on
- #
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- DEB_CONFIGURE_EXTRA_FLAGS += --enable-debug --with-memory-profile --with-memory-checks
-else
- #DEB_CONFIGURE_EXTRA_FLAGS += --enable-optimisation=3
- ifneq (,$(findstring 86,$(DEB_BUILD_GNU_CPU)))
- # DEB_CONFIGURE_EXTRA_FLAGS += --enable-pipes --enable-objprelink
- DEB_CONFIGURE_EXTRA_FLAGS +=--with-ix86-asm
- endif
-endif
-
- #
- # Don't compress these files
- #
-DEB_COMPRESS_EXCLUDE := .kvs
-
-# The default gzip compressor has been changed in dpkg >= 1.17.0.
-deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
- sed -e "s|.*version ||" -e "s| .*||" | \
- xargs -r dpkg --compare-versions 1.17.0 lt \
- && echo xz || echo gzip)
-ifeq ($(deb_default_compress),gzip)
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-endif
-
- #
- # Run dh_shlibdeps with the correct options
- #
-DEB_SHLIBDEPS_INCLUDE_kvirc-trinity := debian/kvirc-trinity$(DEB_CONFIGURE_PREFIX)/lib
-DEB_SHLIBDEPS_LIBRARY_kvirc-trinity := kvirc-trinity
-
- #
- # Documentation to include for each package
- #
-DEB_INSTALL_DOCS_kvirc-trinity := FAQ README TODO
-DEB_INSTALL_DOCS_kvirc-trinity-dev := doc/scriptexamples
-DEB_INSTALL_DOCS_ALL := -XCVS -X.cvsignore
-
-common-install-indep::
- #
- # Change the name of the COPYING file to appease lintian
- #
- mv $(CURDIR)/debian/tmp/$(DEB_CONFIGURE_PREFIX)/share/kvirc/3.4/license/COPYING \
- $(CURDIR)/debian/tmp/$(DEB_CONFIGURE_PREFIX)/share/kvirc/3.4/license/EULA
-
-post-patches:: debian/stamp-bootstrap
-
-debian/stamp-bootstrap:
-ifneq "$(wildcard /usr/share/libtool/ltmain.sh)" ""
- cp -f /usr/share/libtool/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -f /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -f /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- cp -f /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-
- ./autogen.sh
- touch debian/stamp-bootstrap
-
-binary-install/kvirc-data-trinity::
- mkdir -p debian/$(cdbs_curpkg)/opt/trinity/share/kvirc/3.4/services
- mv debian/tmp/opt/trinity/share/services/* debian/$(cdbs_curpkg)/opt/trinity/share/kvirc/3.4/services/