summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/misc/kcmldapcontroller/debian/cdbs/debian-tde.mk
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2023-12-19 02:49:06 +0100
committerSlávek Banko <slavek.banko@axis.cz>2023-12-19 03:05:04 +0100
commit34145f8176dbda8170684ae8fcdea0787a904f66 (patch)
tree2433ae5b037017b35b7a1f3a3eb41e13816923fe /ubuntu/_base/applications/misc/kcmldapcontroller/debian/cdbs/debian-tde.mk
parentb73cc9eb4f7845482b7354719edb4e716f5d90c7 (diff)
downloadtde-packaging-34145f8176dbda8170684ae8fcdea0787a904f66.tar.gz
tde-packaging-34145f8176dbda8170684ae8fcdea0787a904f66.zip
DEB: Automatically add ldconfig trigger if the package contains plugins.
As a result, it is no longer necessary to enforce ldconfig in postinst and postrm scripts and this solves the problem with packages where the ldconfig was not called after installation, but it was needed. This resolves issue TDE/tdemultimedia#29. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/misc/kcmldapcontroller/debian/cdbs/debian-tde.mk')
-rw-r--r--ubuntu/_base/applications/misc/kcmldapcontroller/debian/cdbs/debian-tde.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/misc/kcmldapcontroller/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/misc/kcmldapcontroller/debian/cdbs/debian-tde.mk
index b031e6981..aba508624 100644
--- a/ubuntu/_base/applications/misc/kcmldapcontroller/debian/cdbs/debian-tde.mk
+++ b/ubuntu/_base/applications/misc/kcmldapcontroller/debian/cdbs/debian-tde.mk
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \