summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/tde-style-domino/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-09 00:44:23 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-09 00:44:23 +0200
commitf32a7656befd65120102e9ecad9a3a383e4cd275 (patch)
tree9e262e9fa939329a926c45fb17ffa21ae01f2671 /ubuntu/_base/applications/tde-style-domino/debian/rules
parent22ae00882c8afd963e53d67a35eb697c5f0c79f2 (diff)
downloadtde-packaging-f32a7656befd65120102e9ecad9a3a383e4cd275.tar.gz
tde-packaging-f32a7656befd65120102e9ecad9a3a383e4cd275.zip
DEB tde-style-domino: Switch to cmake.
Add intltool to build-deps. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/applications/tde-style-domino/debian/rules')
-rwxr-xr-xubuntu/_base/applications/tde-style-domino/debian/rules17
1 files changed, 12 insertions, 5 deletions
diff --git a/ubuntu/_base/applications/tde-style-domino/debian/rules b/ubuntu/_base/applications/tde-style-domino/debian/rules
index 2aebaac7b..18aa16b96 100755
--- a/ubuntu/_base/applications/tde-style-domino/debian/rules
+++ b/ubuntu/_base/applications/tde-style-domino/debian/rules
@@ -1,12 +1,19 @@
#!/usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"