summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/applications/themes/twin-style-fahrenheit/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2023-11-01 09:26:48 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2023-11-01 09:26:48 +0900
commit408b01083be36d3813cb3d7a1c6f26b5d5fd923d (patch)
tree02434f9d1ca3c6701c5f62757d7f988cb32080e1 /ubuntu/_base/applications/themes/twin-style-fahrenheit/debian/rules
parent351dae2355700b2ab624e7cd698b00ed83101674 (diff)
downloadtde-packaging-408b01083be36d3813cb3d7a1c6f26b5d5fd923d.tar.gz
tde-packaging-408b01083be36d3813cb3d7a1c6f26b5d5fd923d.zip
DEB: add twin-style-fahrenheit packaging files
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'ubuntu/_base/applications/themes/twin-style-fahrenheit/debian/rules')
-rwxr-xr-xubuntu/_base/applications/themes/twin-style-fahrenheit/debian/rules17
1 files changed, 17 insertions, 0 deletions
diff --git a/ubuntu/_base/applications/themes/twin-style-fahrenheit/debian/rules b/ubuntu/_base/applications/themes/twin-style-fahrenheit/debian/rules
new file mode 100755
index 000000000..a6797f19a
--- /dev/null
+++ b/ubuntu/_base/applications/themes/twin-style-fahrenheit/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"