summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/core/tdeaddons/debian/rules
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2023-01-14 16:37:07 +0900
committerSlávek Banko <slavek.banko@axis.cz>2023-01-16 01:50:08 +0100
commit34de7371f00209152fbd0934c256528eee992a96 (patch)
treeaacce98d2a49046245964e38410494220cf2e176 /ubuntu/_base/core/tdeaddons/debian/rules
parent5043679baaff8cb129115058779d4889faa69c21 (diff)
downloadtde-packaging-34de7371.tar.gz
tde-packaging-34de7371.zip
DEB tdeaddons: drop python2 support.
Use dh_python3 to ensure Python dependencies and rewrite shebang in installed scripts. Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it> Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/core/tdeaddons/debian/rules')
-rwxr-xr-xubuntu/_base/core/tdeaddons/debian/rules12
1 files changed, 8 insertions, 4 deletions
diff --git a/ubuntu/_base/core/tdeaddons/debian/rules b/ubuntu/_base/core/tdeaddons/debian/rules
index 76d43dd46..dceaa1982 100755
--- a/ubuntu/_base/core/tdeaddons/debian/rules
+++ b/ubuntu/_base/core/tdeaddons/debian/rules
@@ -22,11 +22,15 @@ DOC_HTML_PRUNE := konq-plugins-trinity/smbmounter
binary-install/tdeaddons-tdefile-plugins-trinity::
install -p -D -m644 renamedlgplugins/README \
- debian/tdeaddons-tdefile-plugins-trinity/opt/trinity/share/doc/tdeaddons-tdefile-plugins/README.renamedlgplugins
+ debian/$(cdbs_curpkg)/opt/trinity/share/doc/tdeaddons-tdefile-plugins/README.renamedlgplugins
binary-install/knewsticker-scripts-trinity::
- chmod 755 debian/knewsticker-scripts-trinity/opt/trinity/share/apps/knewsticker/scripts/*.pl
- chmod 755 debian/knewsticker-scripts-trinity/opt/trinity/share/apps/knewsticker/scripts/*.py
+ chmod 755 debian/$(cdbs_curpkg)/opt/trinity/share/apps/knewsticker/scripts/*.pl
+ chmod 755 debian/$(cdbs_curpkg)/opt/trinity/share/apps/knewsticker/scripts/*.py
+ dh_python3 -p $(cdbs_curpkg) --shebang=/usr/bin/python3 /opt/trinity/share/apps/knewsticker/scripts
binary-install/kate-plugins-trinity::
- chmod 755 debian/kate-plugins-trinity/opt/trinity/share/apps/kate/scripts/html-tidy.sh
+ chmod 755 debian/$(cdbs_curpkg)/opt/trinity/share/apps/kate/scripts/html-tidy.sh
+
+binary-install/konq-plugins-trinity::
+ dh_python3 -p $(cdbs_curpkg) --shebang=/usr/bin/python3 /opt/trinity/share/apps/imagerotation