summaryrefslogtreecommitdiffstats
path: root/ubuntu/_base/dependencies/tqca/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-01-11 16:54:54 +0100
committerSlávek Banko <slavek.banko@axis.cz>2020-01-11 16:54:54 +0100
commit9a2614f8965f0157618dfc9a89f14f7cab278c51 (patch)
tree8992895f95d1d0bca6ef8bc92e2e0c8b7896c375 /ubuntu/_base/dependencies/tqca/debian/rules
parentf03fe2f1447badd293be7bf028a1839eeaf8dd5f (diff)
downloadtde-packaging-9a2614f8965f0157618dfc9a89f14f7cab278c51.tar.gz
tde-packaging-9a2614f8965f0157618dfc9a89f14f7cab278c51.zip
DEB tqca: Add packaging files as a standalone libtqca shared library.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'ubuntu/_base/dependencies/tqca/debian/rules')
-rwxr-xr-xubuntu/_base/dependencies/tqca/debian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/ubuntu/_base/dependencies/tqca/debian/rules b/ubuntu/_base/dependencies/tqca/debian/rules
new file mode 100755
index 000000000..5d7f84feb
--- /dev/null
+++ b/ubuntu/_base/dependencies/tqca/debian/rules
@@ -0,0 +1,21 @@
+#! /usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
+ -DWITH_ALL_OPTIONS="ON"