summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kerry/debian/patches
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-10 16:17:43 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2011-07-10 16:17:43 -0500
commit9b2075d9b89fc628c447fbb98f43ef72e4a9c81d (patch)
tree2de9e866f064b1c7d36df24de1df305474f949fe /ubuntu/maverick/applications/kerry/debian/patches
downloadtde-packaging-9b2075d9b89fc628c447fbb98f43ef72e4a9c81d.tar.gz
tde-packaging-9b2075d9b89fc628c447fbb98f43ef72e4a9c81d.zip
Initial import from old SVN repository
Note that only the Debian and Ubuntu folders were preserved
Diffstat (limited to 'ubuntu/maverick/applications/kerry/debian/patches')
-rw-r--r--ubuntu/maverick/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch12
-rw-r--r--ubuntu/maverick/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch19
-rw-r--r--ubuntu/maverick/applications/kerry/debian/patches/kubuntu_05_shortkey.patch13
3 files changed, 44 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch
new file mode 100644
index 000000000..cbd096957
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_03_no_beagle_autostart.patch
@@ -0,0 +1,12 @@
+diff -Nur kerry-0.2.1/kerry/src/Makefile.am kerry-0.2.1.new/kerry/src/Makefile.am
+--- kerry-0.2.1/kerry/src/Makefile.am 2006-12-05 18:28:31.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/Makefile.am 2006-12-05 18:28:53.000000000 +0100
+@@ -31,7 +31,7 @@
+ kerry_la_LIBADD = -lkio -lkonq $(LIB_KDEUI) $(LIBBEAGLE_LIBADD) $(GLIB_LIBADD) $(LIB_KABC)
+
+ autostartdir = $(datadir)/autostart
+-autostart_DATA = kerry.autostart.desktop beagled.desktop
++autostart_DATA = kerry.autostart.desktop
+
+ shutdowndir = $(prefix)/bin
+ shutdown_SCRIPTS = beagled-shutdown.sh
diff --git a/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch
new file mode 100644
index 000000000..bc560f754
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_04_no_core_kmenu_entry.desktop.patch
@@ -0,0 +1,19 @@
+diff -Nur -x '*.orig' -x '*~' kerry-0.2.1/kerry/src/kerry.desktop kerry-0.2.1.new/kerry/src/kerry.desktop
+--- kerry-0.2.1/kerry/src/kerry.desktop 2006-12-04 14:35:38.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/kerry.desktop 2008-04-08 22:55:31.000000000 +0200
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ X-SuSE-translate=true
+-Encoding=UTF-8
+ Name=Kerry Beagle
+ GenericName=Desktop Search
+ GenericName[ar]=بحث على سطح المكتب
+@@ -25,7 +24,7 @@
+ Exec=kerry --show-searchdialog
+ Icon=kerry
+ Type=Application
+-Categories=Qt;KDE;Application;Core;Utility;Filesystem;
++Categories=Qt;KDE;Application;Utility;Filesystem;
+ Terminal=false
+ X-DCOP-ServiceType=Unique
+ X-KDE-StartupNotify=false
diff --git a/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_05_shortkey.patch b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_05_shortkey.patch
new file mode 100644
index 000000000..6478949f6
--- /dev/null
+++ b/ubuntu/maverick/applications/kerry/debian/patches/kubuntu_05_shortkey.patch
@@ -0,0 +1,13 @@
+diff -Nur kerry-0.2.1/kerry/src/kerryapp.cpp kerry-0.2.1.new/kerry/src/kerryapp.cpp
+--- kerry-0.2.1/kerry/src/kerryapp.cpp 2006-12-04 14:35:38.000000000 +0100
++++ kerry-0.2.1.new/kerry/src/kerryapp.cpp 2006-12-05 18:30:44.000000000 +0100
+@@ -122,8 +122,7 @@
+ globalKeys = new KGlobalAccel(this);
+ globalKeys->insert( "Program:kerry", i18n("Kerry Beagle Search") );
+
+- KShortcut showDialogShortcut = KShortcut(ALT+Key_Space);
+- showDialogShortcut.append( KKey( Key_F12 ) );
++ KShortcut showDialogShortcut = KShortcut(CTRL+SHIFT+Key_Space);
+ globalKeys->insert( "Show Kerry Dialog", i18n("Show Search Dialog"), QString::null, showDialogShortcut, showDialogShortcut, hitListWindow, SLOT(showSearchDialog()) );
+ globalKeys->insert( "Search Primary Selection with Kerry", i18n("Search Primary Selection"), QString::null, CTRL+ALT+Key_Space, CTRL+ALT+Key_Space, this, SLOT(searchPrimarySelection()) );
+ configChanged();