summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/applications/kiosktool/debian/cdbs/uploaders.mk
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-13 19:00:51 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2012-09-13 19:00:51 -0500
commit3a16f4cd9deaef0c80cb6027dc2e75ae30a46d9e (patch)
tree0192de76dddec19e38e220e79f169769b9adc1c3 /ubuntu/maverick/applications/kiosktool/debian/cdbs/uploaders.mk
parent01e69eb4c2d9d64ba96fdc45be76fb1d14a6f1be (diff)
parentfb1176fa5dd2120d92cbc41ecb077046102d0908 (diff)
downloadtde-packaging-3a16f4cd9deaef0c80cb6027dc2e75ae30a46d9e.tar.gz
tde-packaging-3a16f4cd9deaef0c80cb6027dc2e75ae30a46d9e.zip
Merge branch 'master' of http://scm.trinitydesktop.org/scm/git/tde-packaging
Diffstat (limited to 'ubuntu/maverick/applications/kiosktool/debian/cdbs/uploaders.mk')
-rw-r--r--ubuntu/maverick/applications/kiosktool/debian/cdbs/uploaders.mk29
1 files changed, 29 insertions, 0 deletions
diff --git a/ubuntu/maverick/applications/kiosktool/debian/cdbs/uploaders.mk b/ubuntu/maverick/applications/kiosktool/debian/cdbs/uploaders.mk
new file mode 100644
index 000000000..31adfe31e
--- /dev/null
+++ b/ubuntu/maverick/applications/kiosktool/debian/cdbs/uploaders.mk
@@ -0,0 +1,29 @@
+
+MAINTAINER=Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
+UPLOADERS=$(shell grep -e +++ -e "^ -- " debian/changelog | grep -v "debian-qt-kde@lists.debian.org" | head -13 | /bin/sed 's/^\s*//;s/\s*$$//;s/^+++\? Changes by //;s/^+++\? //;s/-- //;s/:$$//;s/ <.*//' | sort -u | while read line ; do grep "$$line" debian/cdbs/team-members ; done | tr "\n" ", " | sed 's/,/, /g;s/, $$//')
+
+
+debian/control.tmp:
+ @if [ ! -e debian/control.in ] ; then \
+ echo "this package is not yet prepared for using automatic update of uploaders"; \
+ echo "Please do so."; \
+ exit 1; \
+ fi
+ @sed 's/@@@UPLOADERS@@@/$(UPLOADERS)/;s#@@@MAINTAINER@@@#$(MAINTAINER)#' debian/control.in > debian/control.tmp
+
+check-uploaders: debian/control.tmp
+ @if ! diff -q debian/control debian/control.tmp ; then \
+ echo "WARNING:: Control file differs from manually generated one" ; \
+ echo "WARNING:: Please update it manually and check it afterwards" ; \
+ echo "WARNING:: Uploaders are updated by debian/rules update-uploaders" ;\
+ echo "WARNING:: If this is a binNMU, NMU or security upload, just ignore" ;\
+ fi
+
+
+clean::
+ rm -f debian/control.tmp
+
+update-uploaders: debian/control.tmp
+ @mv -f debian/control.tmp debian/control
+
+makebuilddir:: check-uploaders