summaryrefslogtreecommitdiffstats
path: root/ubuntu/maverick/tdetoys/debian/rules
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2012-12-02 18:50:07 +0100
committerSlávek Banko <slavek.banko@axis.cz>2012-12-02 18:50:07 +0100
commit68a05487a2737b6cb4bcd6fe60d16db7886f56e3 (patch)
treed5f679acbf8d5b6d1b8526797dc3de76f6f4d713 /ubuntu/maverick/tdetoys/debian/rules
parentf8aa81ddfb34e247d0a4ce4ce41052b059ef78fc (diff)
downloadtde-packaging-68a05487a2737b6cb4bcd6fe60d16db7886f56e3.tar.gz
tde-packaging-68a05487a2737b6cb4bcd6fe60d16db7886f56e3.zip
Switch tdetoys to cmake on Debian and Ubuntu
Diffstat (limited to 'ubuntu/maverick/tdetoys/debian/rules')
-rwxr-xr-xubuntu/maverick/tdetoys/debian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/ubuntu/maverick/tdetoys/debian/rules b/ubuntu/maverick/tdetoys/debian/rules
index 60a5a9cf4..b9707dd97 100755
--- a/ubuntu/maverick/tdetoys/debian/rules
+++ b/ubuntu/maverick/tdetoys/debian/rules
@@ -1,6 +1,7 @@
#! /usr/bin/make -f
include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-qt-kde.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
include /usr/share/cdbs/1/rules/utils.mk
@@ -14,6 +15,16 @@ cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xine
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --includedir="/opt/trinity/include" --mandir="/opt/trinity/share/man" --infodir="/opt/trinity/share/info"
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON"
+
DEB_DH_STRIP_ARGS := --dbg-package=tdetoys-trinity-dbg
DEB_INSTALL_CHANGELOGS_kodo-trinity := kodo/ChangeLog