summaryrefslogtreecommitdiffstats
path: root/ubuntu/raring/defaultsettings/desktop-base/debian/rules
diff options
context:
space:
mode:
authorTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-06-01 02:04:45 -0500
committerTimothy Pearson <kb9vqf@pearsoncomputing.net>2013-06-01 02:04:45 -0500
commit6f8b29e1fa4d7c4f8676dbded0b9fde3e9acd207 (patch)
tree4613d1f6dd2471c02d32d72193426a4659432d0c /ubuntu/raring/defaultsettings/desktop-base/debian/rules
parenta6d46f81f053a75f8584f8e0b04e48f93dfc1532 (diff)
downloadtde-packaging-6f8b29e1fa4d7c4f8676dbded0b9fde3e9acd207.tar.gz
tde-packaging-6f8b29e1fa4d7c4f8676dbded0b9fde3e9acd207.zip
Add initial copy of the old Debian desktop-base package to the Debian and Ubuntu packaging files
Diffstat (limited to 'ubuntu/raring/defaultsettings/desktop-base/debian/rules')
-rwxr-xr-xubuntu/raring/defaultsettings/desktop-base/debian/rules14
1 files changed, 14 insertions, 0 deletions
diff --git a/ubuntu/raring/defaultsettings/desktop-base/debian/rules b/ubuntu/raring/defaultsettings/desktop-base/debian/rules
new file mode 100755
index 000000000..cb03b05ad
--- /dev/null
+++ b/ubuntu/raring/defaultsettings/desktop-base/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/buildcore.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/makefile.mk
+
+# needed for usplash
+CFLAGS += -fPIC
+
+DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/desktop-base-trinity/
+
+binary-fixup/desktop-base::
+ dh_gconf --priority=15
+