summaryrefslogtreecommitdiffstats
path: root/arch/tde-core/tde-libart-lgpl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'arch/tde-core/tde-libart-lgpl/PKGBUILD')
-rw-r--r--arch/tde-core/tde-libart-lgpl/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/arch/tde-core/tde-libart-lgpl/PKGBUILD b/arch/tde-core/tde-libart-lgpl/PKGBUILD
new file mode 100644
index 000000000..a629b72fb
--- /dev/null
+++ b/arch/tde-core/tde-libart-lgpl/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Michael Manley <mmanley@nasutek.com>
+# Contributor: David C. Rankin <drankinatty at gmail dot com>
+
+pkgname=tde-libart-lgpl
+pkgver=14.0.5
+pkgrel=1
+pkgdesc="Trinity Desktop LGPL'd Component"
+arch=('i686' 'x86_64')
+url="http://scm.trinitydesktop.org/scm/git/libart-lgpl"
+license=('LGPL')
+groups=('tde-core')
+depends=('tde-tqtinterface')
+makedepends=()
+optdepends=()
+provides=('libart-lgpl')
+conflicts=()
+replaces=()
+options=('staticlibs' 'libtool' '!strip')
+install=
+source=("http://mirror.ppa.trinitydesktop.org/trinity/releases/R${pkgver}/dependencies/libart-lgpl-R${pkgver}.tar.bz2")
+md5sums=('89ee9f3901fdd8622b24e789638818e6')
+
+build() {
+ cd $srcdir/dependencies/${pkgname#*-}
+ ./configure --prefix=${TDEDIR}
+ make
+}
+
+package() {
+ cd $srcdir/dependencies/${pkgname#*-}
+ make -j1 DESTDIR=$pkgdir install
+}