summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/internet/kbiff
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/internet/kbiff')
-rw-r--r--debian/_base/applications/internet/kbiff/debian/cdbs/debian-tde.mk251
-rw-r--r--debian/_base/applications/internet/kbiff/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/internet/kbiff/debian/changelog90
-rw-r--r--debian/_base/applications/internet/kbiff/debian/compat1
-rw-r--r--debian/_base/applications/internet/kbiff/debian/control16
-rw-r--r--debian/_base/applications/internet/kbiff/debian/copyright45
-rw-r--r--debian/_base/applications/internet/kbiff/debian/dirs1
-rw-r--r--debian/_base/applications/internet/kbiff/debian/docs2
-rw-r--r--debian/_base/applications/internet/kbiff/debian/menu6
-rwxr-xr-xdebian/_base/applications/internet/kbiff/debian/rules17
-rw-r--r--debian/_base/applications/internet/kbiff/debian/source/format1
-rw-r--r--debian/_base/applications/internet/kbiff/debian/source/options6
12 files changed, 455 insertions, 0 deletions
diff --git a/debian/_base/applications/internet/kbiff/debian/cdbs/debian-tde.mk b/debian/_base/applications/internet/kbiff/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..aba508624
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/cdbs/debian-tde.mk
@@ -0,0 +1,251 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/internet/kbiff/debian/cdbs/versions.pl b/debian/_base/applications/internet/kbiff/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/internet/kbiff/debian/changelog b/debian/_base/applications/internet/kbiff/debian/changelog
new file mode 100644
index 000000000..bf7871f3b
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/changelog
@@ -0,0 +1,90 @@
+kbiff-trinity (3.9-1) squeeze; urgency=low
+
+ * Initial Release for TDE
+
+ -- Slávek Banko <slavek.banko@axis.cz> Tue, 02 Jul 2013 18:39:16 +0200
+
+kbiff (3.9-1) unstable; urgency=low
+
+ * QA upload.
+
+ [ Lisandro Damián Nicanor Pérez Meyer ]
+ * Set Maintainer to Debian QA Group (Closes: #540212).
+ * Drop Debian revision in package dependence on kdelibs4-dev.
+ * Bumped standars version from 3.7.3 to 3.9.1, no changes needed.
+ * Switch to source version 3.0 (quilt).
+ * Disable compilation with rpath.
+ * Fixed utime-preservation code is off by one hour (Closes: #498404).
+ * Fixed wrong code for Nynorsk translation (Closes: #365185).
+ * Compiling with gcc 4.4.4, I can't see "gcc warnings: extra tokens at end
+ of #... directive.", so I'm closing this bug. (Closes: #455381).
+
+ [ Ana Beatriz Guerrero Lopez ]
+ * Add libqt3-compat-headers to the build depends.
+
+ -- Ana Beatriz Guerrero Lopez <ana@debian.org> Fri, 13 Aug 2010 00:03:57 +0200
+
+kbiff (3.8-1.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Build without libqt3-compat-headers. (Closes: #464473).
+ * Add build-dep on autotools-dev for config.* madness.
+ * Remove po/*.gmo files on clean. (Closes: #442610).
+ * Make clean not ignore errors.
+ * Add watch file.
+ * Build/install library file in /usr/lib/kbiff.
+ * Update FSF addresses in debian/copyright.
+ * Remove full text of GFDL and add pointer to GFDL license.
+ * Update link to appropriate license: GPL-2.
+ * Bump debhelper build-dep and compat to 5.
+ * Bump Standards Version to 3.7.3.
+ + Lib shouldn't be in /usr/lib without library package.
+
+ -- Barry deFreese <bddebian@comcast.net> Wed, 06 Feb 2008 20:59:12 -0500
+
+kbiff (3.8-1) unstable; urgency=low
+
+ * New upstream release.
+ (closes: #343187, #297302, #312381).
+ * Update the German PO file.
+ (closes: #314015)
+
+ -- Jean-Michel Kelbert <kelbert@debian.org> Sat, 21 Jan 2006 10:30:17 +0100
+
+kbiff (3.7.1-4) unstable; urgency=low
+
+ * Add kdelibs4-dev (>= 4:3.4.2-1) in Build-Depends to build with a
+ transitioned C++ version.
+ (closes: #327533, #328021)
+
+ -- Jean-Michel Kelbert <kelbert@debian.org> Tue, 27 Sep 2005 21:57:01 +0200
+
+kbiff (3.7.1-3.1) unstable; urgency=low
+
+ * NMU
+ * Added complete GFDL license to debian copyright and correct license
+ location to man/kbiff.sgml (Closes: #292234)
+ * Regenerated man/kbiff.1 with docbook-to-man
+
+ -- Paul Brossier <piem@altern.org> Fri, 4 Feb 2005 18:16:48 +0000
+
+kbiff (3.7.1-3) unstable; urgency=low
+
+ * Do not gzip index.docbook files.
+ (Closes: #248984)
+
+ -- Jean-Michel Kelbert <kelbert@debian.org> Fri, 26 Nov 2004 15:26:02 +0100
+
+kbiff (3.7.1-2) unstable; urgency=low
+
+ * Correct a typo in the description.
+
+ -- Jean-Michel Kelbert <kelbert@debian.org> Mon, 26 Apr 2004 14:42:52 +0000
+
+kbiff (3.7.1-1) unstable; urgency=low
+
+ * Initial Release.
+ (Closes: #143914)
+
+ -- Jean-Michel Kelbert <kelbert@debian.org> Sun, 11 Apr 2004 23:19:15 +0200
+
diff --git a/debian/_base/applications/internet/kbiff/debian/compat b/debian/_base/applications/internet/kbiff/debian/compat
new file mode 100644
index 000000000..f599e28b8
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/_base/applications/internet/kbiff/debian/control b/debian/_base/applications/internet/kbiff/debian/control
new file mode 100644
index 000000000..6615dd019
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/control
@@ -0,0 +1,16 @@
+Source: kbiff-trinity
+Section: tde
+Priority: optional
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, tdelibs14-trinity-dev (>= 4:3.4.2)
+Standards-Version: 3.9.1
+
+Package: kbiff-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: TDE mail notification utility
+ Kbiff is a "xbiff"-like mail notification utility. It has multiple pixmaps,
+ session management, and GUI configuration. It can "dock" into the TDE panel.
+ It can display animated gifs, play system sounds, or run arbitrary shell
+ command when new mail arrives. It supports mbox, maildir, mh, POP3, IMAP4, and
+ NNTP mailboxes.
diff --git a/debian/_base/applications/internet/kbiff/debian/copyright b/debian/_base/applications/internet/kbiff/debian/copyright
new file mode 100644
index 000000000..f2ff3daec
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/copyright
@@ -0,0 +1,45 @@
+This package was debianized by Jean-Michel Kelbert <kelbert@debian.org> on
+Sun, 11 Apr 2004 23:19:15 +0200.
+
+It was downloaded from http://www.granroth.org/kbiff/
+
+Upstream Author: Kurt Granroth <granroth@kde.org>
+
+Copyright:
+
+ This package is free software; you can redistribute it and/or modify it under
+ the terms of the GNU General Public License as published by the Free Software
+ Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful, but WITHOUT
+ ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+ FOR A PARTICULAR PURPOSE. See the GNU General Public License for more
+ details.
+
+ You should have received a copy of the GNU General Public License along with
+ this package; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02111-1301, USA.
+
+On Debian GNU/Linux systems, the complete text of the GNU General Public
+License can be found in `/usr/share/common-licenses/GPL-2'.
+
+========================================================================
+
+The kbiff manpage is distributed under the terms of the
+GNU Free Documentation License, with not Front-Covers Texts and no
+Back-Covers Texts. The full text of the license follows.
+
+________________________________________________________________________
+
+ GNU Free Documentation License
+ Version 1.2, November 2002
+
+
+ Copyright (C) 2000,2001,2002 Free Software Foundation, Inc.
+ 51 Franklin Street, Fifth Floor, Boston, MA 02111-1301 USA
+ Everyone is permitted to copy and distribute verbatim copies
+ of this license document, but changing it is not allowed.
+
+
+On Debian GNU/Linux systems, the complete text of the GNU General Public
+License can be found in `/usr/share/common-licenses/GFDL-1.2'.
diff --git a/debian/_base/applications/internet/kbiff/debian/dirs b/debian/_base/applications/internet/kbiff/debian/dirs
new file mode 100644
index 000000000..f583045fe
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/dirs
@@ -0,0 +1 @@
+opt/trinity/bin
diff --git a/debian/_base/applications/internet/kbiff/debian/docs b/debian/_base/applications/internet/kbiff/debian/docs
new file mode 100644
index 000000000..0b6e0f321
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/docs
@@ -0,0 +1,2 @@
+AUTHORS
+README.md
diff --git a/debian/_base/applications/internet/kbiff/debian/menu b/debian/_base/applications/internet/kbiff/debian/menu
new file mode 100644
index 000000000..fdfa26c26
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/menu
@@ -0,0 +1,6 @@
+?package(kbiff-trinity):\
+ needs=X11\
+ section="Apps/Net"\
+ title="Kbiff"\
+ command="/opt/trinity/bin/kbiff"\
+ kderemove="y"
diff --git a/debian/_base/applications/internet/kbiff/debian/rules b/debian/_base/applications/internet/kbiff/debian/rules
new file mode 100755
index 000000000..a6797f19a
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/internet/kbiff/debian/source/format b/debian/_base/applications/internet/kbiff/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/internet/kbiff/debian/source/options b/debian/_base/applications/internet/kbiff/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/internet/kbiff/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*