summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/internet/ktorrent/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/internet/ktorrent/debian')
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/README.Debian26
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/cdbs/debian-tde.mk251
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/changelog371
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/compat1
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/control22
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/copyright74
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/internet/ktorrent/debian/rules15
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/source/format1
-rw-r--r--debian/_base/applications/internet/ktorrent/debian/source/options6
11 files changed, 786 insertions, 0 deletions
diff --git a/debian/_base/applications/internet/ktorrent/debian/README.Debian b/debian/_base/applications/internet/ktorrent/debian/README.Debian
new file mode 100644
index 000000000..0d4e3f758
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/README.Debian
@@ -0,0 +1,26 @@
+Due to licensing restrictions, the source and binary packages of ktorrent do
+not include a GeoIP database. The binary package *is* built to support it
+however (the API is GPL, but data used from ARIN to generate the data files
+is *not* DFSG compliant). If you wish to use the GeoIP support, there are free
+databases made available at the following URL:
+
+http://www.maxmind.com/app/geoip_country
+
+Place the uncompressed database file in /usr/share/apps/ktorrent/geoip/ and
+the country information will be displayed in the peers tab. The commercial
+version offered *should* also work, but I have no means to confirm or deny
+this.
+
+The flag images are also not distributed with this package. Although the
+original author seems to wish the grant free use, the verbage used in
+granting it restricts their use to websites. I've tried, and will continue
+to try to contact him and find a resolution.
+
+----
+
+The upstream source was modified in the following ways:
+ removed ./plugins/infowidget/geoip/geoip.dat
+ removed ./plugins/infowidget/geoip/*.png
+ removed ./plugins/infowidget/geoip/FLAGS_LICENSE
+ modified ./plugins/infowidget/Makefile.{am,in} to not depend on above
+ appended "+dfsg" to base directory name
diff --git a/debian/_base/applications/internet/ktorrent/debian/cdbs/debian-tde.mk b/debian/_base/applications/internet/ktorrent/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..aba508624
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/cdbs/debian-tde.mk
@@ -0,0 +1,251 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/internet/ktorrent/debian/cdbs/versions.pl b/debian/_base/applications/internet/ktorrent/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/internet/ktorrent/debian/changelog b/debian/_base/applications/internet/ktorrent/debian/changelog
new file mode 100644
index 000000000..9050d084e
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/changelog
@@ -0,0 +1,371 @@
+ktorrent-trinity (2.2.6-0ubuntu1) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+ktorrent-trinity (2.2.5-0ubuntu3) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Fri, 06 March 2009 01:35:00 -0600
+
+ktorrent-trinity (2.2.5-0ubuntu2) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 31 Dec 2008 15:45:00 -0600
+
+ktorrent (2.2.5-0ubuntu1) hardy; urgency=low
+
+ * New upstream release
+ - Numerous bugfixes, notably to DHT and webui
+ * Added a watchfile to track 2.x.x series
+
+ -- John Dong <jdong@ubuntu.com> Sun, 27 Jan 2008 17:26:13 -0500
+
+ktorrent (2.2.4-0ubuntu1) hardy; urgency=low
+
+ * New upstream release
+ * Drop kubuntu_04_revert_threaded_filelist, included upstream
+
+ -- John Dong <jdong@ubuntu.com> Wed, 21 Nov 2007 14:28:35 -0500
+
+ktorrent (2.2.3-0ubuntu3) hardy; urgency=low
+
+ * Adopt better approach from upstream for filelist (LP: #163426)
+ - kubuntu_04_revert_threaded_filelist.patch: Switch to fix
+ in r738262 using more responsive QTimers approach
+
+ -- John Dong <jdong@ubuntu.com> Sun, 18 Nov 2007 12:19:26 -0500
+
+ktorrent (2.2.3-0ubuntu2) hardy; urgency=low
+
+ * kubuntu_04_revert_threaded_filelist.patch: Revert svn revno 728567
+ due to crashes. (LP: #163426)
+
+ -- John Dong <jdong@ubuntu.com> Sat, 17 Nov 2007 16:46:47 -0500
+
+ktorrent (2.2.3-0ubuntu1) hardy; urgency=low
+
+ * New upstream release
+ * kubuntu_03_remove_nasty_search_engines.patch: rebase against 2.2.3
+ * Add tdebase-kio-plugins to Recommends, needed for IP Filters plugin
+ (LP: #150062)
+
+ -- John Dong <jdong@ubuntu.com> Fri, 16 Nov 2007 02:11:41 -0500
+
+ktorrent (2.2.2-0ubuntu2) hardy; urgency=low
+
+ * Reuploaded as the buildd seems to be fixed
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 12 Nov 2007 14:16:59 +0100
+
+ktorrent (2.2.2-0ubuntu1) hardy; urgency=low
+
+ * New upstream release
+ * Removed upstream_01_fix_exit_crash.patch, merged upstream
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Sat, 10 Nov 2007 11:22:05 +0100
+
+ktorrent (2.2.1-0ubuntu3) gutsy; urgency=low
+
+ * Fix debdiff spacing that I screwed up.
+ - Fixes LP: #130300
+
+ -- John Dong <jdong@ubuntu.com> Sat, 11 Aug 2007 14:59:17 -0400
+
+ktorrent (2.2.1-0ubuntu2) gutsy; urgency=low
+
+ * Backport SVN rev 692284
+ - Fixes LP: #130300
+
+ -- John Dong <jdong@ubuntu.com> Fri, 10 Aug 2007 11:27:51 -0400
+
+ktorrent (2.2.1-0ubuntu1) gutsy; urgency=low
+
+ * New upstream release
+ - Fixes LP: #128341
+
+ -- Ryan Kavanagh <ryanakca@kubuntu.org> Wed, 25 Jul 2007 15:37:41 -0400
+
+ktorrent (2.2-0ubuntu2) gutsy; urgency=low
+
+ * Fixed homepage in debian/control. Fixes LP: #113972
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Wed, 18 Jul 2007 23:29:16 +0200
+
+ktorrent (2.2-0ubuntu1) gutsy; urgency=low
+
+ * New upstream release
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Wed, 04 Jul 2007 14:43:57 +0200
+
+ktorrent (2.2~rc1-0ubuntu1) gutsy; urgency=low
+
+ * New upstream release
+
+ -- jdong <jdong@ubuntu.com> Wed, 13 Jun 2007 23:05:16 -0400
+
+ktorrent (2.2~beta1-0ubuntu1) gutsy; urgency=low
+
+ * New upstream release
+
+ -- John Dong <jdong@ubuntu.com> Sat, 26 May 2007 15:22:14 -0400
+
+ktorrent (2.1.4-0ubuntu1) gutsy; urgency=low
+
+ * New upstream release
+
+ -- John Dong <jdong@ubuntu.com> Tue, 24 Apr 2007 14:47:01 -0400
+
+ktorrent (2.1.3-0ubuntu1) feisty; urgency=low
+
+ * New upstream release
+ * fixes crasher in 2.1.2 series
+
+ -- John Dong <jdong@ubuntu.com> Sat, 7 Apr 2007 22:04:38 -0400
+
+ktorrent (2.1.2-0ubuntu1) feisty; urgency=low
+
+ * New Upstream Release
+
+ -- Richard A. Johnson <nixternal@ubuntu.com> Fri, 9 Mar 2007 13:09:09 -0600
+
+ktorrent (2.1.1-0ubuntu1) feisty; urgency=low
+
+ * New Upstream Release
+
+ -- Richard A. Johnson <nixternal@ubuntu.com> Mon, 5 Mar 2007 13:05:13 -0600
+
+ktorrent (2.1-0ubuntu1) feisty; urgency=low
+
+ * New upstream release
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 5 Feb 2007 20:52:18 +0100
+
+ktorrent (2.1~rc1-0ubuntu3) feisty; urgency=low
+
+ * debian/patches/kubuntu_03_remove_nasty_search_engines.patch:
+ - isohunt is just back online.
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 22 Jan 2007 16:51:45 +0100
+
+ktorrent (2.1~rc1-0ubuntu1) feisty; urgency=low
+
+ * New upstream release
+ * uTorrent-compatible Peer Exchange
+ * Zeroconf LAN peer finder
+ * Misc bugfixes
+ * dropped debian/patches/kubuntu_01_autoconf2.60.patch, included upstream
+ * dropped debian/patches/kubuntu_02_kdepot.patch, no longer needed
+
+ -- John Dong <jdong@ubuntu.com> Wed, 3 Jan 2007 15:21:56 -0500
+
+ktorrent (2.1~beta1-0ubuntu2) feisty; urgency=low
+
+ * Corrected builddeps (docbook2x instead of docbook)
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 18 Dec 2006 16:09:09 +0100
+
+ktorrent (2.1~beta1-0ubuntu1) feisty; urgency=low
+
+ * New upstream release
+ * Cleaned packaging, switching to cdbs
+ * Removed obsolete kubuntu_03_powerpc_compile_fix.diff
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 05 Dec 2006 18:14:05 +0100
+
+ktorrent (2.0.3+dfsg1-0ubuntu2) feisty; urgency=low
+
+ * Add kubuntu_03_remove_nasty_search_engines.diff to remove
+ nasty search engines
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 11 Nov 2006 15:56:19 -0800
+
+ktorrent (2.0.3+dfsg1-0ubuntu1) edgy; urgency=low
+
+ * built with GeoIP support enabled, but removed the database file
+ and country flags due to licensing restrictions (see README.Debian)
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Fri, 20 Oct 2006 12:56:19 +0100
+
+ktorrent (2.0.3-0ubuntu4) edgy; urgency=low
+
+ * Add kubuntu_00_autoconf2.60.diff to allow relibtoolise with autoconf 2.6
+ * Add kubuntu_02_powerpc_compile_fix.diff to fix fail to build on powerpc,
+ Closes https://launchpad.net/malone/66169
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sun, 15 Oct 2006 22:41:14 +0100
+
+ktorrent (2.0.3-0ubuntu3) edgy; urgency=low
+
+ * Removed kubuntu_04_ktshell_bash.patch, included
+ upstream
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Thu, 11 Oct 2006 16:30:01 +0200
+
+ktorrent (2.0.3-0ubuntu2) edgy; urgency=low
+
+ * Removed kubuntu_02_r586445_choke.patch and
+ kubuntu_03_r588047_faster_download.patch adopted upstream
+
+ -- Brandon Holtsclaw <imbrandon@kubuntu.org> Tue, 10 Oct 2006 17:46:01 -0500
+
+ktorrent (2.0.3-0ubuntu1) edgy; urgency=low
+
+ * New Upstream Version ( uvfe approved by mdz )
+ * Closes Malone: #65066
+
+ -- Brandon Holtsclaw <imbrandon@kubuntu.org> Tue, 10 Oct 2006 17:46:01 -0500
+
+ktorrent (2.0.2-0ubuntu3) edgy; urgency=low
+
+ * Added kubuntu_04_ktshell_bash.patch, closes Malone
+ #61324
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Mon, 02 Oct 2006 21:01:07 +0200
+
+ktorrent (2.0.2-0ubuntu2) edgy; urgency=low
+
+ * Backport SVN revisions 586445 and 588047, fixes download speed oscillation
+ and instances where all peers are choked/snubbed.
+
+ -- John Dong <jdong@ubuntu.com> Wed, 27 Sep 2006 02:07:07 -0400
+
+ktorrent (2.0.2-0ubuntu1) edgy; urgency=low
+
+ * New Upstream Release
+ * UVFe approved by Colin Watson ( https://launchpad.net/bugs/58139 )
+
+ -- Brandon Holtsclaw <imbrandon@kubuntu.org> Mon, 18 Sep 2006 13:28:37 -0500
+
+ktorrent (2.0.1-0ubuntu1) edgy; urgency=low
+
+ * New Upstream Version approved by mdz at https://launchpad.net/bugs/57219
+
+ -- Brandon Holtsclaw <imbrandon@kubuntu.org> Tue, 22 Aug 2006 09:51:44 -0500
+
+ktorrent (2.0-0ubuntu2) edgy; urgency=low
+
+ * Fixed install issue by removing debian/ktorrent/usr/share/applnk and
+ debian/ktorrent/usr/share/mimelnk in debian/rules already provided by tdelibs-data
+ * Closes Malone Bug #55969
+
+ -- Brandon Holtsclaw <imbrandon@kubuntu.org> Wed, 09 Aug 2006 09:51:44 -0500
+
+ktorrent (2.0-0ubuntu1) edgy; urgency=low
+
+ * New Upstream Version
+ * Updated admin/ directory so .pot would generate correctly
+ * commented debian/patches/kubuntu_01_kdepot.patch from debian/rules , not needed
+ * added libgmp3-dev to build depends as required to build 2.0
+
+ -- Brandon Holtsclaw <imbrandon@kubuntu.org> Wed, 09 Aug 2006 09:51:44 -0500
+
+ktorrent (1.2-1ubuntu3) edgy; urgency=low
+
+ * debian/rules: moved the fix from clean to install rule, to fix the ftbfs,
+ really
+
+ -- Stephan Hermann <sh@sourcecode.de> Thu, 13 Jul 2006 09:51:44 +0200
+
+ktorrent (1.2-1ubuntu2) edgy; urgency=low
+
+ * debian/rules: Removed translations/nb/messages/ktorrent.po to be friendly
+ to our buildds
+
+ -- Stephan Hermann <sh@sourcecode.de> Wed, 12 Jul 2006 18:37:00 +0200
+
+ktorrent (1.2-1ubuntu1) edgy; urgency=low
+
+ * Merge from debian unstable.
+
+ -- Stephan Hermann <sh@sourcecode.de> Thu, 6 Jul 2006 13:53:48 +0200
+
+ktorrent (1.2-1) unstable; urgency=low
+
+ * Acknowledge NMU (Closes: 349983)
+ Actually removed debian libtoolization temporarily due to
+ package inclusion of a library in upstream. Soon to be reapplied
+ with proper support for avoiding redundant dependencies.
+ * New upstream release (Closes: 348605)
+ + Doesn't freeze/lock anymore (Closes: 340766)
+ + Properly builds with G++ 4.1 (Closes: 357096)
+ * add shlib support and post{inst,rm} via debhelper for new shared library
+ * Set --enable-final as configure directive
+ * Update copyright file to reflect additional files and changed dir layout
+ * patch upstream Makefile.in to include translations directory
+ * Update upstream homepage URL in control
+
+ -- Joel Johnson <mrjoel@lixil.net> Tue, 6 Jun 2006 22:07:58 -0700
+
+ktorrent (1.2-0ubuntu5) dapper; urgency=low
+
+ * added debian/patches/kubuntu_01_kdepot.patch
+ * debian/rules: added generation of po/ktorrent.pot
+
+ -- Bastian Holst <bastianholst@gmx.de> Tue, 23 May 2006 17:37:34 +0200
+
+ktorrent (1.2-0ubuntu4) dapper; urgency=low
+
+ * debian/rules: Remove ./translations/nb/messages/ktorrent.po since it's
+ empty (and thus invalid).
+
+ -- Martin Pitt <martin.pitt@ubuntu.com> Tue, 23 May 2006 12:25:14 +0200
+
+ktorrent (1.2-0ubuntu3) dapper; urgency=low
+
+ * Added dh_iconcache
+
+ -- Brandon Holtsclaw <brandon@imbrandon.com> Tue, 23 May 2006 17:05:49 +0100
+
+ktorrent (1.2-0ubuntu2) dapper; urgency=low
+
+ * Make debian/rules relibtoolise, installs .po translation files
+ closes Malone #45791
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Mon, 22 May 2006 17:05:49 +0100
+
+ktorrent (1.2-0ubuntu1) dapper; urgency=low
+
+ * New Upstream Version
+ * Sponsored upload for Sarah Hobbs <hobbsee@gmail.com>
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Fri, 10 Feb 2006 12:02:16 +1100
+
+ktorrent (1.1-2.1) unstable; urgency=low
+
+ * Non-maintainer upload by sponsor due to no maintainer reaction.
+ * Relibtoolize _after_ setting AM_MAINTAINER_MODE (Closes: #349983)
+
+ -- Florian Ernst <florian@debian.org> Tue, 7 Feb 2006 13:15:30 +0100
+
+ktorrent (1.1-2) unstable; urgency=low
+
+ * Limit build dependencies to what we directly depend on
+ and set AM_MAINTAINER_MODE in configure.in.in
+ * Change section from net to kde
+ * Remove sponsor as Uploader as requested
+
+ -- Joel Johnson <mrjoel@lixil.net> Thu, 1 Dec 2005 13:11:22 -0800
+
+ktorrent (1.1-1build1) dapper; urgency=low
+
+ * Rebulid for libstdc++ transition
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Sat, 17 Dec 2005 15:20:35 +0000
+
+ktorrent (1.1-1) unstable; urgency=low
+
+ * Initial Debian Upload (Closes: #313659)
+ * Update copyright file with new FSF address
+ * Incorporate changes to a previous package version
+ - disable rpath in ./configure
+ - add lintian override (missing manpage)
+ Thanks to Jonathan Riddell <jriddell@ubuntu.com>
+ * Add linda override (missing manpage)
+
+ -- Joel Johnson <mrjoel@lixil.net> Thu, 24 Oct 2005 08:47:09 -0700
+
diff --git a/debian/_base/applications/internet/ktorrent/debian/compat b/debian/_base/applications/internet/ktorrent/debian/compat
new file mode 100644
index 000000000..f599e28b8
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/_base/applications/internet/ktorrent/debian/control b/debian/_base/applications/internet/ktorrent/debian/control
new file mode 100644
index 000000000..3b335272c
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/control
@@ -0,0 +1,22 @@
+Source: ktorrent-trinity
+Section: tde
+Priority: optional
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+Build-Depends: debhelper (>= 10~), quilt, cdbs, tdelibs14-trinity-dev, libpcre3-dev, libx11-dev, libgmp3-dev, libavahi-tqt-dev, libgeoip-dev, automake, autoconf, libtool, libltdl-dev
+Standards-Version: 3.8.4
+
+Package: ktorrent-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Replaces: ktorrent-trinity (<< 4:14.0.0~)
+Breaks: ktorrent-trinity (<< 4:14.0.0~)
+Suggests: php-cli | php5-cli
+Recommends: tdebase-tdeio-plugins-trinity
+Description: BitTorrent client for Trinity
+ KTorrent is a BitTorrent program for Trinity. Its features include speed capping
+ (both down and up), integrated searching, UDP tracker support, preview of
+ certain file types (video and audio) and integration into the TDE Panel
+ enabling background downloading.
+ .
+ Homepage: http://ktorrent.org
+
diff --git a/debian/_base/applications/internet/ktorrent/debian/copyright b/debian/_base/applications/internet/ktorrent/debian/copyright
new file mode 100644
index 000000000..9b8756613
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/copyright
@@ -0,0 +1,74 @@
+This package was debianized by Joel Johnson <mrjoel@lixil.net> on
+Tue, 21 Jun 2005 11:19:46 -0700.
+
+The original source was downloaded from
+http://ktorrent.org/downloads/1.2/ktorrent-1.2.tar.gz
+
+Copyright 2005 Joris Guisson <joris.guisson@gmail.com> unless otherwise indicated below
+
+Copyright (C) 2005 by
+Joris Guisson <joris.guisson@gmail.com>
+Ivan Vasic <ivasic@gmail.com>
+
+ apps/ktorrent/ktorrent.cpp
+ apps/ktorrent/ktorrentcore.cpp
+ apps/ktorrent/pastedialog.h
+ apps/ktorrent/pastedialog.cpp
+ apps/ktorrent/ktorrentview.h
+ apps/ktorrent/ktorrentview.cpp
+ apps/ktorrent/trayicon.h
+ apps/ktorrent/trayicon.cpp
+ libktorrent/interfaces/ipblockinginterface.h
+ libktorrent/interfaces/ipblockinginterface.cpp
+ libktorrent/torrent/ipblocklist.h
+ libktorrent/torrent/ipblocklist.cpp
+ libktorrent/torrent/torrentfile.h
+ libktorrent/torrent/torrentfile.cpp
+ libktorrent/torrent/torrent.h
+ libktorrent/torrent/torrent.cpp
+ libktorrent/torrent/chunkmanager.cpp
+ libktorrent/torrent/torrentcontrol.h
+ libktorrent/torrent/torrentcontrol.cpp
+ libktorrent/torrent/queuemanager.h
+ libktorrent/torrent/queuemanager.cpp
+ plugins/infowidget/infowidget.h
+ plugins/infowidget/infowidget.cpp
+ plugins/ipfilter/ipblockingprefpage.h
+ plugins/ipfilter/ipblockingprefpage.cpp
+ plugins/ipfilter/ipfilterplugin.h
+ plugins/ipfilter/ipfilterplugin.cpp
+ plugins/ipfilter/antip2p.h
+ plugins/ipfilter/antip2p.cpp
+
+Copyright (C) 2005 by Ivan Vasic <ivasic@gmail.com>
+ apps/ktorrent/queuedialog.h
+ apps/ktorrent/queuedialog.cpp
+
+Copyright (C) 2005 by
+Joris Guisson <joris.guisson@gmail.com>
+Vincent Wagelaar <vincent@ricardis.tudelft.nl>
+ plugins/infowidget/chunkbar.h
+ plugins/infowidget/chunkbar.cpp
+
+Copyright (C) 2005 by Adam Treat <treat@kde.org>
+ apps/ktorrent/ktorrentapp.h
+ apps/ktorrent/ktorrentapp.cpp
+
+License (for all components):
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/_base/applications/internet/ktorrent/debian/patches/series b/debian/_base/applications/internet/ktorrent/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/patches/series
diff --git a/debian/_base/applications/internet/ktorrent/debian/rules b/debian/_base/applications/internet/ktorrent/debian/rules
new file mode 100755
index 000000000..4ad6f5c28
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include/tde
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_INSTALL_MANPAGES_ktorrent = ktorrent.1
+
+DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
diff --git a/debian/_base/applications/internet/ktorrent/debian/source/format b/debian/_base/applications/internet/ktorrent/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/internet/ktorrent/debian/source/options b/debian/_base/applications/internet/ktorrent/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/internet/ktorrent/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*