summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/kbfx/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/kbfx/debian')
-rw-r--r--debian/_base/applications/kbfx/debian/README.Debian107
-rw-r--r--debian/_base/applications/kbfx/debian/cdbs/debian-qt-kde.mk119
-rw-r--r--debian/_base/applications/kbfx/debian/cdbs/kde.mk91
-rw-r--r--debian/_base/applications/kbfx/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/kbfx/debian/changelog84
-rw-r--r--debian/_base/applications/kbfx/debian/compat1
-rw-r--r--debian/_base/applications/kbfx/debian/control22
-rw-r--r--debian/_base/applications/kbfx/debian/copyright40
-rw-r--r--debian/_base/applications/kbfx/debian/docs2
-rw-r--r--debian/_base/applications/kbfx/debian/kbfx-trinity.lintian5
-rw-r--r--debian/_base/applications/kbfx/debian/patches/series0
-rw-r--r--debian/_base/applications/kbfx/debian/postinst25
-rwxr-xr-xdebian/_base/applications/kbfx/debian/rules23
-rw-r--r--debian/_base/applications/kbfx/debian/source/format1
-rw-r--r--debian/_base/applications/kbfx/debian/source/options6
-rw-r--r--debian/_base/applications/kbfx/debian/watch5
16 files changed, 550 insertions, 0 deletions
diff --git a/debian/_base/applications/kbfx/debian/README.Debian b/debian/_base/applications/kbfx/debian/README.Debian
new file mode 100644
index 000000000..b0302c211
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/README.Debian
@@ -0,0 +1,107 @@
+Debian kde-extras Team
+----------------------
+
+1. Contacts
+-----------
+
+General help requests
+ <debian-kde@lists.debian.org> mailing list
+ #debian-kde on irc
+
+Packaging queries
+ <debian-qt-kde@lists.debian.org> mailing list
+ #debian-qt-kde on irc
+
+Maintainers
+ <pkg-kde-extras@lists.alioth.debian.org> mailing list
+
+
+2. Subversion repository
+------------------------
+
+You can browse it only at:
+
+http://svn.debian.org/wsvn/pkg-kde/kde-extras/
+
+To "checkout" the repository use these commands:
+
+ $ svn co svn+ssh://${ALIOTH_USERNAME}@svn.debian.org/svn/pkg-kde/kde-extras
+
+Authorized SSH keys are controlled at https://alioth.debian.org/account/
+
+The repository layout is:
+
+- packagename/
+    - trunk/
+    - branches/
+    - tags/
+        - 0.7.2-1/
+        - 0.7.2-2/
+        - 0.7.2-2ubuntu1/
+        - 0.7.2-2ubuntu2/
+        - 0.7.2-2ubuntu3/
+        - 0.8.0/
+        ...
+
+If only one version of the package is available at the time, development must
+be made at trunk/ dir, copying the dir to tags/'pkg-version' each time a new
+release is made.
+
+When, at some point, the need to have two different versions at the same time
+arises (for example, if we need a version to be in unstable and a different one
+to be in experimental), experimental development will be made in trunk/ and
+if a new unstable package needs to be cooked, copying
+tag/'latest_version_in_sid' to tag/'latest_version_in_sid'+1 will make the
+trick.
+
+3. Using svn-buildpackage
+--------------------------
+
+Packages with an upstream tarball will require you to set the mergeWithUpstream
+property first (from the package root) so that svn-buildpackage will look for
+the .orig.tar.gz in the ../tarballs directory.
+
+ % svn propset mergeWithUpstream 1 debian
+
+Please note that this only works for packages which have only the debian/
+directory committed. Consequently, you must use CDBS's simple-patchsys.mk or
+dpatch to modify the upstream sources.
+
+After you have finished and committed your Debian patches via
+
+ % svn commit [PACKAGE]
+
+as well as copying the orig.tar.gz to ../tarballs/ if necessary, you may build
+your package with the following commands:
+
+ % svn-buildpackage --svn-ignore-new -rfakeroot
+
+Please, don't commit tarballs/ or build-area/ directories to SVN.
+
+4. Tarballs and Build-area directories
+------------------------------------
+
+During pkg development before uploaded to debian the tarballs can be found at:
+
+ http://pkg-kde.alioth.debian.org/kde-extra/orig.tar.gz/
+
+You need to place those dirs in the parent directory of the one from which you're
+running svn-buildpackage. Usually this means placing tarballs/ and build-area/ dirs
+in 'pkgname'/ dir, at the same level as trunk/
+
+If you want to compile inside one version in tags/ dir, you'll need to place those
+dirs inside that dir. Of course the easiest and cleanest way of doing it is
+by making a symlink of those dirs inside tags/ dir.
+
+5. Using svn-inject
+-------------------
+
+To inject a new package into the Debian KDE Extras svn archive you should use svn-inject(1)
+as follows:
+
+ svn-inject -o <package>.dsc svn+ssh://${ALIOTH_USERNAME}@svn.debian.org/svn/pkg-kde/kde-extras
+
+Type in your alioth password a few hundred times :-) and your package should be
+uploaded to the archive. Note you will also need to manually copy the
+package.orig.tar.gz to your tarballs directory. The -o option is important as
+this ensures that we 'Only keep modified files under SVN control'
diff --git a/debian/_base/applications/kbfx/debian/cdbs/debian-qt-kde.mk b/debian/_base/applications/kbfx/debian/cdbs/debian-qt-kde.mk
new file mode 100644
index 000000000..60310a01a
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/cdbs/debian-qt-kde.mk
@@ -0,0 +1,119 @@
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include debian/cdbs/kde.mk$(_cdbs_makefile_suffix)
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/kbfx/debian/cdbs/kde.mk b/debian/_base/applications/kbfx/debian/cdbs/kde.mk
new file mode 100644
index 000000000..80176d63e
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/cdbs/kde.mk
@@ -0,0 +1,91 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Description: A class for KDE packages; sets KDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+
+ifndef _cdbs_class_kde
+_cdbs_class_kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+ifeq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+cdbs_configure_flags += --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+common-build-arch common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-arch common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+clean::
+ rm -f debian/stamp-kde-apidox
+
+# This is a convenience target for calling manually. It's not part of
+# the build process.
+buildprep: clean apply-patches
+ $(MAKE) -f admin/Makefile.common dist
+ debian/rules clean
+
+endif
diff --git a/debian/_base/applications/kbfx/debian/cdbs/versions.pl b/debian/_base/applications/kbfx/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kbfx/debian/changelog b/debian/_base/applications/kbfx/debian/changelog
new file mode 100644
index 000000000..cbb743bf9
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/changelog
@@ -0,0 +1,84 @@
+kbfx-trinity (0.4.9.3.1-2) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+kbfx-trinity (0.4.9.3.1-1) intrepid; urgency=low
+
+ * Moved to /opt/trinity
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Sun, 29 Mar 2009 23:49:00 -0600
+
+kbfx (0.4.9.3.1-1) unstable; urgency=low
+
+ * New upstream release. (Closes: #414217, #421761)
+
+ [Fathi Boudra]
+ * Remove xdg appsdir patch. Merged upstream.
+
+ [Mark Purcell]
+ * Update debian/watch.
+ * Robust get-orig-source target.
+
+ -- Fathi Boudra <fboudra@free.fr> Thu, 17 May 2007 09:03:51 +0200
+
+kbfx (0.4.9.3~20070117-1) experimental; urgency=low
+
+ * New upstream release
+ * convert package to cmake
+ * Update 10_use_xdg_appsdir and 11_fix_desktop_categories patches.
+ * Add 2 patches to fix doc path and files to install.
+ * control: replace automake1.8 by cmake as depends
+ * docs: update to reflect new doc path
+ * Cleanup lintian overrides
+ * rules: for empty LIB_SUFFIX as kbfx doesn't detect it properly.
+
+ -- Fathi Boudra <fboudra@free.fr> Fri, 19 Jan 2007 01:44:58 +0100
+
+kbfx (0.4.9.2~rc4-1) unstable; urgency=low
+
+ * New upstream release (Closes: #385466)
+ * Add ./debian/rules get-orig-source for http://buildserver.net
+ * Remove rc3 patch
+
+ -- Fathi Boudra <fboudra@free.fr> Mon, 20 Nov 2006 11:10:47 +0100
+
+kbfx (0.4.9.2~rc3-2) unstable; urgency=low
+
+ * Add patch to sync properly with rc3 changes
+
+ -- Fathi Boudra <fboudra@free.fr> Thu, 9 Nov 2006 10:35:42 +0100
+
+kbfx (0.4.9.2~rc3-1) unstable; urgency=low
+
+ * New upstream release
+
+ -- Fathi Boudra <fboudra@free.fr> Wed, 18 Oct 2006 15:05:05 +0200
+
+kbfx (0.4.9.2~rc2-1) unstable; urgency=low
+
+ * Fix kbfxconfig.desktop categories (Closes: #384257)
+ * Remove autoconf 2.60 patch, merged upstream
+ * Add patch to install desktop file in xdg apps dir
+ * Remove source.lintian-overrides, CVS dir fixed
+
+ -- Fathi Boudra <fboudra@free.fr> Mon, 25 Sep 2006 16:00:59 +0200
+
+kbfx (0.4.9.1+20060611cvs-1) unstable; urgency=low
+
+ * New upstream release
+ * Fix autoconf2.60 detection (Closes: #380026)
+ * Clean up copyright file
+ * Clean up source.lintian-overrides
+ * Clean up rules
+
+ -- Fathi Boudra <fboudra@free.fr> Wed, 2 Aug 2006 08:10:12 +0200
+
+kbfx (0.4.9.1-1) unstable; urgency=low
+
+ * Initial release (Closes: #335238)
+ * lintian override: special comment about rpath problem
+
+ -- Fathi Boudra <fboudra@free.fr> Mon, 26 Jun 2006 16:23:48 +0200
+
diff --git a/debian/_base/applications/kbfx/debian/compat b/debian/_base/applications/kbfx/debian/compat
new file mode 100644
index 000000000..7f8f011eb
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/_base/applications/kbfx/debian/control b/debian/_base/applications/kbfx/debian/control
new file mode 100644
index 000000000..530ecee02
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/control
@@ -0,0 +1,22 @@
+Source: kbfx-trinity
+Section: tde
+Priority: optional
+Maintainer: Timothy Pearson <kb9vqf@pearsoncomputing.net>
+Uploaders: Fathi Boudra <fboudra@free.fr>, Mark Purcell <msp@debian.org>
+Build-Depends: cdbs, debhelper (>= 7.0.50~), quilt, cmake, tdelibs14-trinity-dev
+Standards-Version: 3.8.4
+
+Package: kbfx-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Replaces: kbfx-trinity (<< 4:14.0.0~)
+Breaks: kbfx-trinity (<< 4:14.0.0~)
+Description: an alternative to T-Menu for TDE [Trinity]
+ KBFX is an alternative to the classical T-Menu button and its menu.
+ It improves the user experience by enabling him to set a bigger (and thus more
+ visible) start button and by finally replacing the Win95-like T-Menu.
+ If you still want the old menu, because you're used to it, it is still
+ available as an option in kbfx. We recommend, however, that you give the Spinx
+ bar a try.
+ .
+ Homepage: http://www.kbfx.net
diff --git a/debian/_base/applications/kbfx/debian/copyright b/debian/_base/applications/kbfx/debian/copyright
new file mode 100644
index 000000000..ccc7bcf80
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/copyright
@@ -0,0 +1,40 @@
+This package was debianized by Fathi Boudra <fboudra@free.fr> on
+Mon, 26 Jun 2006 16:23:48 +0200.
+
+It was downloaded from http://www.kbfx.net
+
+Upstream Authors:
+ Siraj Razick <siraj@mail.kbfx.net>
+ Mensur Zahirovic <nookie@mail.kbfx.net>
+ Nathanael Gogniat <nathanael@mail.kbfx.net>
+
+Copyright: (C) 2005-2006 Siraj Razick <siraj@mail.kbfx.net>
+
+Copyright for kbfx kcontrol module:
+ (C) 2006 Siraj Razick <siraj@mail.kbfx.net>
+ (C) 2005 Akhmad Fathonih <toni@gamatechno.com>
+
+Copyright for OO Dom Image Rollover script:
+ (C) 2005 Adam Smith <ibulwark@hotmail.com>
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+The Debian packaging is (C) 2006, Fathi Boudra <fboudra@free.fr> and
+is licensed under the GPL, see above.
diff --git a/debian/_base/applications/kbfx/debian/docs b/debian/_base/applications/kbfx/debian/docs
new file mode 100644
index 000000000..4182e08ae
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/docs
@@ -0,0 +1,2 @@
+doc/README
+doc/TODO
diff --git a/debian/_base/applications/kbfx/debian/kbfx-trinity.lintian b/debian/_base/applications/kbfx/debian/kbfx-trinity.lintian
new file mode 100644
index 000000000..35c40e0a1
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/kbfx-trinity.lintian
@@ -0,0 +1,5 @@
+# It isn't a library or a development package
+# and no other packages uses libkbfxcommon and libkbfxdata
+kbfx-trinity: no-shlibs-control-file opt/trinity/lib/libkbfxdata.so
+kbfx-trinity: no-shlibs-control-file opt/trinity/lib/libkbfxcommon.so
+kbfx-trinity: package-name-doesnt-match-sonames libkbfxcommon libkbfxdata
diff --git a/debian/_base/applications/kbfx/debian/patches/series b/debian/_base/applications/kbfx/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/patches/series
diff --git a/debian/_base/applications/kbfx/debian/postinst b/debian/_base/applications/kbfx/debian/postinst
new file mode 100644
index 000000000..e95a6906b
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/postinst
@@ -0,0 +1,25 @@
+#!/bin/sh
+# postinst script for kbfx
+
+set -e
+
+case "$1" in
+ configure)
+ ldconfig
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/_base/applications/kbfx/debian/rules b/debian/_base/applications/kbfx/debian/rules
new file mode 100755
index 000000000..2f11c867e
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-qt-kde.mk
+#include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/utils.mk
+
+DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
+DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
+DEB_CONFIGURE_PREFIX := /opt/trinity
+DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
+
+DEB_CMAKE_EXTRA_FLAGS =\
+ -DLIB_SUFFIX="" \
+ -DCMAKE_LIBRARY_PATH="/opt/trinity/lib" \
+ -DCMAKE_INCLUDE_PATH="/opt/trinity/include" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity/" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DBUILD_ALL="ON"
+
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
diff --git a/debian/_base/applications/kbfx/debian/source/format b/debian/_base/applications/kbfx/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/kbfx/debian/source/options b/debian/_base/applications/kbfx/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/_base/applications/kbfx/debian/watch b/debian/_base/applications/kbfx/debian/watch
new file mode 100644
index 000000000..4052e514a
--- /dev/null
+++ b/debian/_base/applications/kbfx/debian/watch
@@ -0,0 +1,5 @@
+version=3
+opts=dversionmangle=s/~/-/ \
+ http://www.kbfx.net/release/0.4.9/sources/kbfx-([\d]\.[\d].*)\.tar\.bz2 debian svn-upgrade
+opts=dversionmangle=s/~/-/ \
+ http://www.kbfx.net/release/0.4.9/testing/kbfx-(.*)\.tar\.bz2 debian svn-upgrade