summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/krusader/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/krusader/debian')
-rw-r--r--debian/_base/applications/krusader/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/applications/krusader/debian/rules3
2 files changed, 10 insertions, 3 deletions
diff --git a/debian/_base/applications/krusader/debian/cdbs/debian-tde.mk b/debian/_base/applications/krusader/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/applications/krusader/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/krusader/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/applications/krusader/debian/rules b/debian/_base/applications/krusader/debian/rules
index 978b9c75a..cdbcf9176 100755
--- a/debian/_base/applications/krusader/debian/rules
+++ b/debian/_base/applications/krusader/debian/rules
@@ -15,9 +15,6 @@ DEB_DESTDIR = $(CURDIR)/debian/krusader-trinity/
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include/tde
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
install/krusader-trinity::
# install xpm files used by menu
install -D -p -m0644 pics/cr16-app-krusader_root.xpm \