summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/ktechlab
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/ktechlab')
-rw-r--r--debian/_base/applications/ktechlab/debian/cdbs/debian-tde.mk237
-rw-r--r--debian/_base/applications/ktechlab/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/ktechlab/debian/changelog102
-rw-r--r--debian/_base/applications/ktechlab/debian/compat1
-rw-r--r--debian/_base/applications/ktechlab/debian/control18
-rw-r--r--debian/_base/applications/ktechlab/debian/copyright49
-rw-r--r--debian/_base/applications/ktechlab/debian/docs2
-rw-r--r--debian/_base/applications/ktechlab/debian/install1
-rw-r--r--debian/_base/applications/ktechlab/debian/menu6
-rw-r--r--debian/_base/applications/ktechlab/debian/patches/.gitignore0
-rwxr-xr-xdebian/_base/applications/ktechlab/debian/rules28
-rw-r--r--debian/_base/applications/ktechlab/debian/source/format1
-rw-r--r--debian/_base/applications/ktechlab/debian/source/options6
13 files changed, 0 insertions, 470 deletions
diff --git a/debian/_base/applications/ktechlab/debian/cdbs/debian-tde.mk b/debian/_base/applications/ktechlab/debian/cdbs/debian-tde.mk
deleted file mode 100644
index 5b4e8bfd7..000000000
--- a/debian/_base/applications/ktechlab/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,237 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
- cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
- cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
- $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
- touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-# The default gzip compressor has been changed in dpkg >= 1.17.0.
-deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
- sed -e "s|.*version ||" -e "s| .*||" | \
- xargs -r dpkg --compare-versions 1.17.0 lt \
- && echo xz || echo gzip)
-ifeq ($(deb_default_compress),gzip)
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-endif
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
- ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
- cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
- else
- cdbs_kde_enable_final =
- endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_final =
- cdbs_kde_enable_debug = --enable-debug=yes
-else
- cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
- cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
- --with-qt-dir=/usr/share/qt3 \
- --disable-rpath \
- --with-xinerama \
- $(cdbs_kde_enable_final) \
- $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
- $(MAKE) -f admin/Makefile.common dist
-endif
- debian/rules clean
-
-.tdepkginfo:
- echo "# TDE package information" >.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
- dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
- date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
-
-post-patches:: .tdepkginfo
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
- if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
- for f in $$(find debian/man -name '*.sgml'); do \
- docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
- done
- for f in $$(find debian/man -name '*.man'); do \
- soelim -I debian/man $$f \
- > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
- done
- touch debian/stamp-man-pages
-
-common-binary-indep::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_INDEP_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
-
-common-binary-arch::
- ( set -e; \
- tmpf=`mktemp debian/versions.XXXXXX`; \
- perl debian/cdbs/versions.pl >$$tmpf; \
- for p in $(DEB_ARCH_PACKAGES); do \
- cat $$tmpf >>debian/$$p.substvars; \
- done; \
- rm -f $$tmpf )
- # update multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ -d $$a ] || [ -f $$a.arch ] || \
- ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
- sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
- done
-
-clean::
- rm -rf debian/man/out
- -rmdir debian/man
- rm -f debian/stamp-man-pages
- rm -rf debian/shlibs-check
- # revert multi-arch path in install files
- ls -d debian/* | \
- grep -E "(install|links)$$" | \
- while read a; do \
- [ ! -f $$a.arch ] || \
- mv $$a.arch $$a; \
- done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
- if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
- if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
- if test -e debian/$(cdbs_curpkg).lintian; then \
- install -p -D -m644 debian/$(cdbs_curpkg).lintian \
- debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
- fi
- if test -e debian/$(cdbs_curpkg).presubj; then \
- install -p -D -m644 debian/$(cdbs_curpkg).presubj \
- debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
- fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
- set -e; \
- for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
- pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
- echo Building $$pkg HTML docs...; \
- mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
- done
- for pkg in $(DOC_HTML_PRUNE) ; do \
- rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
- done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
- touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
- $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
-
-cleanbuilddir::
- -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
- if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
- cd $(DEB_SRCDIR); \
- find . -name Makefile.in -print | \
- xargs --no-run-if-empty rm -f; \
- rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
- configure configure.files configure.in stamp-h.in \
- subdirs; \
- fi
-endif
- rm -f .tdepkginfo
- rm -f debian/stamp-kde-apidox
- rm -f debian/stamp-cvs-make
-
-endif
diff --git a/debian/_base/applications/ktechlab/debian/cdbs/versions.pl b/debian/_base/applications/ktechlab/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/debian/_base/applications/ktechlab/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/ktechlab/debian/changelog b/debian/_base/applications/ktechlab/debian/changelog
deleted file mode 100644
index 757702a77..000000000
--- a/debian/_base/applications/ktechlab/debian/changelog
+++ /dev/null
@@ -1,102 +0,0 @@
-ktechlab-trinity (0.3-9~1ubuntu0) karmic; urgency=low
-
- * Karmic rebuild
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
-
-ktechlab-trinity (0.3-9~0ubuntu5) intrepid; urgency=low
-
- * Moved Trinity to /opt/trinity
- * Integrated properly with KDE4.2+
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Fri, 06 March 2009 01:35:00 -0600
-
-ktechlab-trinity (0.3-9~0ubuntu2) intrepid; urgency=low
-
- * Added -trinity suffix
-
- -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 19 Dec 2008 12:52:00 -0600
-
-ktechlab (0.3-9) unstable; urgency=low
-
- * adopted the package ktechlab, with the agreement of Steffen Joeris.
- * Made a new patch to make the package compilable with g++-4.3:
- src/electronics/simulation/matrix.cpp: simplified the invokation of
- new ETMap() to use the default parameters
- other places: cleaned the calls to std::abs which need either a
- float or a double, made a few modifications to include math.h,
- define the type uint when necessary.
- (Closes: #474842)
- * Made a true Homepage: entry in debian/control
- * Upgraded Standards-Version to 3.7.3
- * added a French translation, modified po/Makefile.in to deal with
- translations.
- * Raised the DH_COMPAT level to 6.
- * Added tdesdk-scripts to build-depends to get the extractrc command
-
- -- Georges Khaznadar <georgesk@ofset.org> Sat, 07 Jun 2008 05:38:09 +0200
-
-ktechlab (0.3-8) unstable; urgency=medium
-
- * Add libpopt-dev as build-depends to avoid FTBFS (Closes: #441480)
- * Remove two rpaths from the binaries and add chrpath to
- build-depends
- * Change Apps to Applications in menu file to follow new format
-
- -- Steffen Joeris <white@debian.org> Wed, 19 Sep 2007 22:29:06 +1000
-
-ktechlab (0.3-7) unstable; urgency=low
-
- * Upload to unstable
-
- -- Steffen Joeris <white@debian.org> Tue, 08 May 2007 18:02:15 +1000
-
-ktechlab (0.3-6) experimental; urgency=low
-
- * Expand 30-g++-4.2.dpatch to cover another compiler problem,
- thanks to Martin Michlmayer (Closes: #394173)
- * Change my maintainer address
-
- -- Steffen Joeris <white@debian.org> Tue, 9 Jan 2007 09:48:19 +0100
-
-ktechlab (0.3-5) unstable; urgency=low
-
- * Add gpsim-dev to build-depends to get pic support working
- (Closes: #357691)
- * Add libgtk2.0-dev and libreadline5-dev to build-depends
- * Upload sponsored by Petter Reinholdtsen.
-
- -- Steffen Joeris <steffen.joeris@skolelinux.de> Fri, 29 Sep 2006 17:25:55 +1000
-
-ktechlab (0.3-4) unstable; urgency=low
-
- * Now recommends gputils for other features
- * Add 30-g++.dpatch to prevent FTBFS with g++-4.2 (Closes: #362208)
- * Upload sponsored by Petter Reinholdtsen.
-
- -- Steffen Joeris <steffen.joeris@skolelinux.de> Sat, 24 Jun 2006 14:03:05 +0200
-
-ktechlab (0.3-3) unstable; urgency=low
-
- * Include patch to let ktechlab build with g++-4.1
- Thanks to Martin Michlmayr (Closes: #356611)
- * Upload sponsored by Petter Reinholdtsen.
-
- -- Steffen Joeris <steffen.joeris@skolelinux.de> Mon, 13 Mar 2006 00:57:32 +0100
-
-ktechlab (0.3-2) unstable; urgency=low
-
- * remove include sys/io.h to let the package build
- on other archs then i386 and amd64 (Closes: #349854)
- * add dpatch to build-depends
- * upload sponsored by Petter Reinholdtsen.
-
- -- Steffen Joeris <steffen.joeris@skolelinux.de> Thu, 26 Jan 2006 00:21:36 +0100
-
-ktechlab (0.3-1) unstable; urgency=low
-
- * Initial release (Closes: #308551)
- * Upload sponsored by Petter Reinholdtsen.
-
- -- Steffen Joeris <steffen.joeris@skolelinux.de> Thu, 12 Jan 2006 00:47:52 +0100
-
diff --git a/debian/_base/applications/ktechlab/debian/compat b/debian/_base/applications/ktechlab/debian/compat
deleted file mode 100644
index ec635144f..000000000
--- a/debian/_base/applications/ktechlab/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/_base/applications/ktechlab/debian/control b/debian/_base/applications/ktechlab/debian/control
deleted file mode 100644
index 0f90cc6c6..000000000
--- a/debian/_base/applications/ktechlab/debian/control
+++ /dev/null
@@ -1,18 +0,0 @@
-Source: ktechlab-trinity
-Section: tde
-Priority: optional
-Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
-Build-Depends: debhelper (>= 9~), cdbs, quilt, cmake, imagemagick, tdelibs14-trinity-dev, gpsim-dev (>= 0.21.11-2)
-Standards-Version: 3.8.4
-
-Package: ktechlab-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Replaces: ktechlab-trinity (<< 4:14.0.0~)
-Breaks: ktechlab-trinity (<< 4:14.0.0~)
-Recommends: gputils
-Description: circuit simulator for microcontrollers and electronics [Trinity]
- KTechlab is a circuit simulator with a nice, clickable and discoverable
- interface. It supports many discrete components, logic circuits as well
- as PIC programming in its own Basic dialect and some form of assembler.
-Homepage: http://ktechlab.org/
diff --git a/debian/_base/applications/ktechlab/debian/copyright b/debian/_base/applications/ktechlab/debian/copyright
deleted file mode 100644
index 5b1af8a2e..000000000
--- a/debian/_base/applications/ktechlab/debian/copyright
+++ /dev/null
@@ -1,49 +0,0 @@
-This package was debianized by Steffen Joeris <steffen.joeris@skolelinux.de> on
-Thu, 12 Jan 2006 00:47:52 +0100.
-
-It was downloaded from http://ktechlab.org/download/
-
-Copyright Holder: David Saxton <david@bluehaze.org>
- Daniel Clarke <daniel.jc@gmail.com>
- (Main Developers)
-
-Additional Copyright Holders:
- Copyright (C) 1997 Martin Jones (mjones@kde.org)
-Files: src/gui/colorcombo.h
-
- Copyright (C) 2005 by Fredy Yanardi
-Files: src/electronics/components/magnitudecomparator.h
- src/electronics/components/magnitudecomparator.cpp
-
- Copyright (C) 2005 by John Myers
-Files: src/electronics/components/rotoswitch.h
- src/electronics/components/rotoswitch.cpp
-
- Copyright (C) 2005 Christoph Cullmann <cullmann@kde.org>
-Files: src/katemdi.h
- src/katemdi.cpp
-
- Copyright (C) 2002, 2003 Joseph Wenninger <jowenn@kde.org>
-Files: src/katemdi.h
- src/katemdi.cpp
-
- Copyright (C) 2002 Simon Hausmann <hausmann@kde.org>
-Files: src/katemdi.cpp
-
- Copyright Anders Lund <anders.lund@lund.tdcadsl.dk>
-Files: src/view.cpp
-
-
-License:
-
-This program is free software; you can redistribute it and/or
-modify it under the terms of the GNU General Public License, version 2
-or higher as published by the Free Software Foundation.
-
-This program is distributed in the hope that it will be useful,
-but WITHOUT ANY WARRANTY; without even the implied warranty of
-MERCHANDABILITY of FITNESS FOR A PARTICULAR PURPOSE.
-See the GNU General Public License for details.
-
-On Debian GNU/Linux systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/_base/applications/ktechlab/debian/docs b/debian/_base/applications/ktechlab/debian/docs
deleted file mode 100644
index 724e08449..000000000
--- a/debian/_base/applications/ktechlab/debian/docs
+++ /dev/null
@@ -1,2 +0,0 @@
-README
-TODO
diff --git a/debian/_base/applications/ktechlab/debian/install b/debian/_base/applications/ktechlab/debian/install
deleted file mode 100644
index 27e314da2..000000000
--- a/debian/_base/applications/ktechlab/debian/install
+++ /dev/null
@@ -1 +0,0 @@
-debian/ktechlab.xpm opt/trinity/share/pixmaps
diff --git a/debian/_base/applications/ktechlab/debian/menu b/debian/_base/applications/ktechlab/debian/menu
deleted file mode 100644
index d3828adaf..000000000
--- a/debian/_base/applications/ktechlab/debian/menu
+++ /dev/null
@@ -1,6 +0,0 @@
-?package(ktechlab-trinity):needs="X11" \
- section="Applications/Programming" \
- hints="TDE" \
- title="KTechLab" \
- command="/opt/trinity/bin/ktechlab" \
- icon="/opt/trinity/share/pixmaps/ktechlab.xpm"
diff --git a/debian/_base/applications/ktechlab/debian/patches/.gitignore b/debian/_base/applications/ktechlab/debian/patches/.gitignore
deleted file mode 100644
index e69de29bb..000000000
--- a/debian/_base/applications/ktechlab/debian/patches/.gitignore
+++ /dev/null
diff --git a/debian/_base/applications/ktechlab/debian/rules b/debian/_base/applications/ktechlab/debian/rules
deleted file mode 100755
index 4b05dbd51..000000000
--- a/debian/_base/applications/ktechlab/debian/rules
+++ /dev/null
@@ -1,28 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
-
-debian/ktechlab.xpm: icons/hi32-app-ktechlab.png
- convert $< $@
-
-post-patches:: debian/ktechlab.xpm
- dh_testdir
-
-clean::
-ifneq "$(wildcard debian/ktechlab.xpm)" ""
- rm -f debian/ktechlab.xpm
-endif
diff --git a/debian/_base/applications/ktechlab/debian/source/format b/debian/_base/applications/ktechlab/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/debian/_base/applications/ktechlab/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/debian/_base/applications/ktechlab/debian/source/options b/debian/_base/applications/ktechlab/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/debian/_base/applications/ktechlab/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*