summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/multimedia/k9copy
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/multimedia/k9copy')
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/cdbs/debian-tde.mk251
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/changelog112
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/compat2
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/control19
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/copyright38
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/docs4
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/multimedia/k9copy/debian/rules17
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/source/format1
-rw-r--r--debian/_base/applications/multimedia/k9copy/debian/source/options6
11 files changed, 469 insertions, 0 deletions
diff --git a/debian/_base/applications/multimedia/k9copy/debian/cdbs/debian-tde.mk b/debian/_base/applications/multimedia/k9copy/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..aba508624
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/cdbs/debian-tde.mk
@@ -0,0 +1,251 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/multimedia/k9copy/debian/cdbs/versions.pl b/debian/_base/applications/multimedia/k9copy/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/multimedia/k9copy/debian/changelog b/debian/_base/applications/multimedia/k9copy/debian/changelog
new file mode 100644
index 000000000..5220703ba
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/changelog
@@ -0,0 +1,112 @@
+k9copy-trinity (1.2.3-0ubuntu2) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+k9copy-trinity (1.2.3-0ubuntu1) intrepid; urgency=low
+
+ * Added -trinity suffix
+ * Changed prefix to /opt/trinity
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 08 Apr 2000 10:46:00 -0600
+
+k9copy (1.2.3-0ubuntu1) hardy; urgency=low
+
+ * New upstream release.
+ * debian/patches/kubuntu_05_typo_fix.patch: dropped, included upstream
+
+ -- Luka Renko <lure@ubuntu.com> Sun, 20 Jan 2008 16:38:59 +0100
+
+k9copy (1.2.2-0ubuntu1) hardy; urgency=low
+
+ * New upstream release.
+ * Moved Homepage field to source stanza.
+ * Removed kubuntu_01_kdepot.diff - no longer need (upstream updated
+ admin).
+
+ -- Jonathan Patrick Davies <jpatrick@kubuntu.org> Mon, 31 Dec 2007 16:40:34 +0100
+
+k9copy (1.2.1-0ubuntu2) hardy; urgency=low
+
+ * debian/patches:
+ - Added kubuntu_05_typo_fix.patch to fix a typo error (LP: #177715)
+ * debian/control
+ - Bump Standards-Version to 3.7.3
+ - Added autotools-dev as Build-Depends to avoid the following lintian
+ error: outdated-autotools-helper-file admin/config.{guess,sub}
+
+ -- Miguel Ruiz <mruiz@ubuntu.com> Wed, 26 Dec 2007 12:32:26 -0300
+
+k9copy (1.2.1-0ubuntu1) hardy; urgency=low
+
+ * New upstream release
+ * debian/control:
+ * Build-Depends on libdvdread-dev (was libdvdread3-dev)
+ * Build-Depends on libavformat-dev & libavcodec-dev
+ * debian/patches/kubuntu_04_fix_header_files_inclusion.patch:
+ * Dropped, as it is resolved upstream
+ * debian/patches/kubuntu_04_fix_libGL_crash.patch:
+ * fix crash when libGL.so is not present, instead ask for
+ versioned name, libGL.so.1 (LP: #174752)
+
+ -- Luka Renko <lure@ubuntu.com> Sun, 16 Dec 2007 12:34:12 +0100
+
+k9copy (1.1.3-0ubuntu2) gutsy; urgency=low
+
+ * Update upstream web site address (LP: #139193)
+ * Change maintainer to MOTU
+
+ -- Scott Kitterman <scott@kitterman.com> Wed, 12 Sep 2007 15:22:36 -0400
+
+k9copy (1.1.3-0ubuntu1) gutsy; urgency=low
+
+ * New upstream release
+ * kubuntu_03_fix_Makefile_files_in_po_directory.patch: updated to apply
+
+ -- Luka Renko <lure@ubuntu.com> Thu, 16 Aug 2007 16:42:33 +0200
+
+k9copy (1.1.2-0ubuntu1) gutsy; urgency=low
+
+ * New upstream release
+ * debian/control: add Build-Depends on DBus and HAL
+ * kubuntu_02_fix_desktop_file.patch: drop, fixed upstream
+ * kubuntu_03_fix_Makefile_files_in_po_directory.patch: updated to apply
+ * kubuntu_04_fix_header_files_inclusion.patch: updated to apply
+
+ -- Luka Renko <lure@ubuntu.com> Sun, 12 Aug 2007 21:59:39 +0200
+
+k9copy (1.1.0~beta2-0ubuntu1) feisty; urgency=low
+
+ * New upstream release
+ * Bump Standards-Version
+
+ -- Adrien Cunin <adri2000@gmail.com> Wed, 29 Nov 2006 16:30:24 +0100
+
+k9copy (1.1.0~beta1-0ubuntu2) edgy; urgency=low
+
+ * Added dependency on libdvdnav and mencoder
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 17 Oct 2006 02:19:52 +0200
+
+k9copy (1.1.0~beta1-0ubuntu1) edgy; urgency=low
+
+ * New upstream release
+ * Added kubuntu_04_fix_header_files_inclusion.patch to fix progress.h file
+ inclusion in k9progress.h file
+
+ -- Anthony Mercatante <tonio@ubuntu.com> Tue, 11 Jul 2006 22:10:52 +0200
+
+k9copy (1.0.2-0ubuntu1) dapper; urgency=low
+
+ * Initial Release.
+ * Added kubuntu_01_kdepot for pot file inclusion in Rosetta.
+ * Added kubuntu_02_fix_desktop_file to add french and english GenericName,
+ and Categories to K9copy.desktop file.
+ * Added kubuntu_03_fix_Makefile_files_in_po_directory to fix po/Makefile.am
+ and po/Makefile.in. k9copy.pot entry needs to be removed for the
+ application to build.
+ * Tarball rebuild to correct permissions, too many files were executable.
+ * Sponsored upload for Anthony Mercatante <anthony.mercatante@laposte.net>
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Thu, 28 Dec 2005 13:46:20 +0200
diff --git a/debian/_base/applications/multimedia/k9copy/debian/compat b/debian/_base/applications/multimedia/k9copy/debian/compat
new file mode 100644
index 000000000..021ea30c0
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/compat
@@ -0,0 +1,2 @@
+10
+
diff --git a/debian/_base/applications/multimedia/k9copy/debian/control b/debian/_base/applications/multimedia/k9copy/debian/control
new file mode 100644
index 000000000..e94e97d8c
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/control
@@ -0,0 +1,19 @@
+Source: k9copy-trinity
+Section: tde
+Priority: optional
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+XSBC-Original-Maintainer: Anthony Mercatante <tonio@ubuntu.com>
+Build-Depends: debhelper (>= 10~), quilt, cdbs, tde-cmake, ninja-build, tdelibs14-trinity-dev,
+ libdvdread-dev, libk3b-trinity-dev, libavformat-dev, libswscale-dev
+Standards-Version: 3.8.4
+
+Package: k9copy-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, vamps, dvd+rw-tools, dvdauthor, mencoder, libdvdnav4
+Replaces: k9copy-trinity (<< 4:14.0.0~)
+Breaks: k9copy-trinity (<< 4:14.0.0~)
+Description: DVD backup tool for Trinity
+ k9copy is a tabbed tool that allows to copy of one or more titles from a DVD9
+ to a DVD5, in much the same way as DVDShrink for Microsoft Windows (R).
+ This is the Trinity version
+
diff --git a/debian/_base/applications/multimedia/k9copy/debian/copyright b/debian/_base/applications/multimedia/k9copy/debian/copyright
new file mode 100644
index 000000000..c08901dd0
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/copyright
@@ -0,0 +1,38 @@
+This package was debianized by Anthony Mercatante <anthony.mercatante@laposte.net> on
+Fri, 28 Dec 2005 13:18:00 +0200.
+
+It was downloaded from http://k9copy.free.fr
+
+Upstream Author:
+ Jean-Michel Petit <jm_petit@laposte.net>
+
+License:
+
+All the software and debian/k9copy.1.docbook:
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin St, Fifth Floor, Boston, N: MA 02110-1301, USA.
+
+ On Debian GNU/Linux systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL'.
+
+Copyright:
+
+All the software:
+
+ Copyright (C) 2005 by Jean-Michel Petit <jm_petit@laposte.net>
+
+debian/k9copy.1.docbook:
+
+ Copyright (C) 2005 by Anthony Mercatante <anthony.mercatante@laposte.net>
diff --git a/debian/_base/applications/multimedia/k9copy/debian/docs b/debian/_base/applications/multimedia/k9copy/debian/docs
new file mode 100644
index 000000000..c17f03764
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/docs
@@ -0,0 +1,4 @@
+AUTHORS
+NEWS
+README
+TODO
diff --git a/debian/_base/applications/multimedia/k9copy/debian/patches/series b/debian/_base/applications/multimedia/k9copy/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/patches/series
diff --git a/debian/_base/applications/multimedia/k9copy/debian/rules b/debian/_base/applications/multimedia/k9copy/debian/rules
new file mode 100755
index 000000000..a6797f19a
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/multimedia/k9copy/debian/source/format b/debian/_base/applications/multimedia/k9copy/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/multimedia/k9copy/debian/source/options b/debian/_base/applications/multimedia/k9copy/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/multimedia/k9copy/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*