summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/office/basket/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/office/basket/debian')
-rw-r--r--debian/_base/applications/office/basket/debian/basket-kontact-integration-trinity.install4
-rw-r--r--debian/_base/applications/office/basket/debian/basket-trinity.install26
-rw-r--r--debian/_base/applications/office/basket/debian/cdbs/debian-tde.mk251
-rw-r--r--debian/_base/applications/office/basket/debian/cdbs/versions.pl19
-rw-r--r--debian/_base/applications/office/basket/debian/changelog193
-rw-r--r--debian/_base/applications/office/basket/debian/compat1
-rw-r--r--debian/_base/applications/office/basket/debian/control40
-rw-r--r--debian/_base/applications/office/basket/debian/copyright37
-rw-r--r--debian/_base/applications/office/basket/debian/dirs1
-rw-r--r--debian/_base/applications/office/basket/debian/docs2
-rw-r--r--debian/_base/applications/office/basket/debian/menu2
-rw-r--r--debian/_base/applications/office/basket/debian/patches/series0
-rwxr-xr-xdebian/_base/applications/office/basket/debian/rules17
-rw-r--r--debian/_base/applications/office/basket/debian/source/format1
-rw-r--r--debian/_base/applications/office/basket/debian/source/options6
15 files changed, 600 insertions, 0 deletions
diff --git a/debian/_base/applications/office/basket/debian/basket-kontact-integration-trinity.install b/debian/_base/applications/office/basket/debian/basket-kontact-integration-trinity.install
new file mode 100644
index 000000000..846f111d3
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/basket-kontact-integration-trinity.install
@@ -0,0 +1,4 @@
+opt/trinity/share/apps/kontact/ksettingsdialog/kontact_basketplugin.setdlg
+opt/trinity/share/services/kontact/basket.desktop
+opt/trinity/lib/trinity/libkontact_basket.la
+opt/trinity/lib/trinity/libkontact_basket.so
diff --git a/debian/_base/applications/office/basket/debian/basket-trinity.install b/debian/_base/applications/office/basket/debian/basket-trinity.install
new file mode 100644
index 000000000..f968dddd3
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/basket-trinity.install
@@ -0,0 +1,26 @@
+etc/trinity/magic/basket.magic
+etc/trinity/magic/basket.magic.mgc
+opt/trinity/bin/basket
+opt/trinity/lib/libbasketcommon.la
+opt/trinity/lib/libbasketcommon.so
+opt/trinity/lib/trinity/basketthumbcreator.la
+opt/trinity/lib/trinity/basketthumbcreator.so
+opt/trinity/lib/trinity/kcm_basket.la
+opt/trinity/lib/trinity/kcm_basket.so
+opt/trinity/lib/trinity/libbasketpart.la
+opt/trinity/lib/trinity/libbasketpart.so
+opt/trinity/share/applications/tde/basket.desktop
+opt/trinity/share/apps/basket/*
+opt/trinity/share/doc/*
+opt/trinity/share/icons/*
+opt/trinity/share/locale/*
+opt/trinity/share/man/*
+opt/trinity/share/mimelnk/application/x-basket-archive.desktop
+opt/trinity/share/mimelnk/application/x-basket-template.desktop
+opt/trinity/share/services/basket_config_apps.desktop
+opt/trinity/share/services/basket_config_baskets.desktop
+opt/trinity/share/services/basket_config_general.desktop
+opt/trinity/share/services/basket_config_new_notes.desktop
+opt/trinity/share/services/basket_config_notes_appearance.desktop
+opt/trinity/share/services/basket_part.desktop
+opt/trinity/share/services/basketthumbcreator.desktop
diff --git a/debian/_base/applications/office/basket/debian/cdbs/debian-tde.mk b/debian/_base/applications/office/basket/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..aba508624
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/cdbs/debian-tde.mk
@@ -0,0 +1,251 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/office/basket/debian/cdbs/versions.pl b/debian/_base/applications/office/basket/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/office/basket/debian/changelog b/debian/_base/applications/office/basket/debian/changelog
new file mode 100644
index 000000000..10c6ce1f0
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/changelog
@@ -0,0 +1,193 @@
+basket-trinity (1.0.2-0ubuntu4) karmic; urgency=low
+
+ * Karmic rebuild
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 02 Jul 2009 16:08:00 -0600
+
+basket-trinity (1.0.2-0ubuntu3) intrepid; urgency=low
+
+ * Moved Trinity to /opt/trinity
+ * Integrated properly with KDE4.2+
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Wed, 04 March 2009 01:11:00 -0600
+
+basket-trinity (1.0.2-0ubuntu2) intrepid; urgency=low
+
+ * Added -trinity suffix
+
+ -- Timothy Pearson <kb9vqf@pearsoncomputing.net> Thu, 11 Dec 2008 16:36:00 -0600
+
+basket (1.0.2-2ubuntu1) hardy; urgency=low
+
+ * Fix integration into Kontact: wrong PluginVersion used in .desktop file
+ debian/patches/kubuntu_01_kontact_plugin.diff
+ (LP: #149321)
+ * debian/control: change Maintainer field.
+
+ -- Luka Renko <lure@ubuntu.com> Wed, 31 Oct 2007 21:00:29 +0100
+
+basket (1.0.2-2build2) gutsy; urgency=low
+
+ * Rebuilt with no source changes, for tdepim-enterprise again
+
+ -- Sarah Hobbs <hobbsee@ubuntu.com> Sat, 06 Oct 2007 22:23:24 +1000
+
+basket (1.0.2-2build1) gutsy; urgency=low
+
+ * Rebuilt with no source changes, for tdepim-enterprise, which has
+ temporarily broken Kontact ABI
+
+ -- Jonathan Riddell <jriddell@ubuntu.com> Tue, 28 Aug 2007 21:56:28 +0100
+
+basket (1.0.2-2) unstable; urgency=low
+
+ [ Ana Beatriz Guerrero Lopez ]
+ * Apply patch to fix FTBFS with GCC 4.3. Thanks to Martin Michlmayr.
+ (Closes: #421209)
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Tue, 29 May 2007 12:47:58 +0100
+
+basket (1.0.2-1) unstable; urgency=low
+
+ [ Sune Vuorela ]
+ * Add da.po as debian/patches/13_add_da.po.diff. Thanks to Martin Schlander.
+
+ [ Ana Beatriz Guerrero Lopez ]
+ * Add 14_update_es_po.diff updating spanish translation. Thanks to Enrique Matías.
+ * Buildprep.
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Tue, 24 Apr 2007 16:37:48 +0100
+
+basket (1.0.1-1) experimental; urgency=low
+
+ * New upstream release.
+ * Fix offset patch 12_desktop.diff
+
+ -- Ana Beatriz Guerrero Lopez <ana@debian.org> Thu, 29 Mar 2007 13:32:00 +0000
+
+basket (1.0-1) experimental; urgency=low
+
+ * New upstream version.
+ - final 1.0 version.
+ * The ana-please-pass-your-exam-this-is-your-miracle release.
+
+ -- Sune Vuorela <debian@pusling.com> Sun, 11 Feb 2007 12:35:24 +0100
+
+basket (1.0~rc2-1) experimental; urgency=low
+
+ * New upstream release:
+ - Removed 10_dont_spam_stderr and 11_match_trinity.5.6_kontact,
+ merged upstream.
+ - Fixed offset patch 12_desktop.diff.
+
+ -- Ana Beatriz Guerrero Lopez <ana@debian.org> Mon, 5 Feb 2007 05:05:50 +0100
+
+basket (1.0~beta3-1) experimental; urgency=low
+
+ * New upstream version. (Closes: #395900)
+ * Package now maintained by the Debian KDE Extras Team.
+
+ [ Ana Beatriz Guerrero Lopez ]
+ * Remove unnecessary file debian/Makefile.
+ * Update compat to 5.
+ * Bumped Standards-Version to 3.7.2, no changes required.
+ * Update dep on tdebase-dev to tdelibs4-dev.
+ * Add build-dep on tdepim-dev to get kontact integration.
+ * Add build-dep on libgpgme11-dev to support encryption.
+ * Package description:
+ - Change short description.
+ - Add basket's homepage.
+ * Not install empty file NEWS.
+ * Rewrite debian/rules file.
+ * Improve debian/copyright file.
+ * Versioned build-deps in tdelibs4-dev and tdepim-dev to build against 3.5.6
+ (so Sune's changes will work).
+ * Patched desktop file to include Categories and moved to right place.
+
+ [ Sune Vuorela ]
+ * Add quilt to build-dep - we better need a patch system. This also required
+ changes to rules.
+ * Add a 10_dont_spam_stderr patch to not be that verbose on stderr. It uses
+ kdDebug() now to report those.
+ * Add a 11_match_trinity.5.6_kontact patch to make the kontact plugin work with
+ kontact 3.5.6 - tdepim people have bumped their internal versionings.
+ * Write new and improved manpage (Derived from help2man). (Closes: #405569)
+ * Improve copyright file.
+ * Minor changes to rules file.
+ * Relibtoolization - and a need to fix parts of the build system.
+ (New libtool put in thru patch 02, patch 03 fixes build system relying on
+ broken libtool and the big buildprep as patch 98.
+
+ -- Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org> Sat, 03 Feb 2007 07:41:48 +0100
+
+basket (0.5.0-6) unstable; urgency=low
+
+ * Acknowledge NMU. Thanks!
+ Nothing more to be done (at least until upstream releases 0.6)
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Thu, 11 May 2006 1:08:16 +0200
+
+basket (0.5.0-5.1) unstable; urgency=low
+
+ * Non-maintainer upload.
+ * Added -Wl,--as-needed as ldflags (Closes: #349480)
+ * Trimmed build-depends to not include stuff from
+ tdebase dependency line
+
+ -- Sune Vuorela <debian@pusling.com> Fri, 21 Apr 2006 21:25:43 +0000
+
+basket (0.5.0-5) unstable; urgency=low
+
+ * Fix crash on cutting multiline item (Closes: #339874)
+
+ * Package sponsored by Roberto Lumbreras <rover@debian.org>
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Fri, 25 Nov 2005 19:57:15 +0100
+
+basket (0.5.0-4) unstable; urgency=low
+
+ * Fix FTBFS on 64-bit arches (Closes: #300176)
+
+ * Package sponsored by Roberto Lumbreras <rover@debian.org>
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Tue, 18 Oct 2005 21:53:01 +0200
+
+basket (0.5.0-3) unstable; urgency=low
+
+ * Force rebuild, due to C++ ABI transition (Closes: #327944)
+ - remove dependency on deprecated libjack0.80(Closes: #317184)
+
+ * Fix KDE htmldir; properly install doc (Closes: #322192)
+
+ * Package sponsored by Roberto Lumbreras <rover@debian.org>
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Wed, 14 Sep 2005 02:35:13 +0200
+
+basket (0.5.0-2) unstable; urgency=low
+
+ * Force relink -- dependency to removed lib (Closes: #317184)
+
+ * Localization: updated DE translation (Closes: #313671)
+
+ * Package sponsored by Roberto Lumbreras <rover@debian.org>
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Sat, 12 Mar 2005 20:30:13 +0100
+
+basket (0.5.0-1) unstable; urgency=low
+
+ * New upstream release. Major rewrite, tons of new features.
+
+ * Fix menu file (Closes: #283375)
+
+ * Package sponsored by Roberto Lumbreras <rover@debian.org>
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Sat, 12 Mar 2005 20:30:13 +0100
+
+basket (0.4.0d-1) unstable; urgency=low
+
+ * Initial Packaging. Fullfill ITP (Closes: #259180)
+
+ * Package sponsored by Roberto Lumbreras <rover@debian.org>
+
+ -- Jose Luis Tallon <jltallon@adv-solutions.net> Sat, 23 Oct 2004 02:21:16 +0200
+
diff --git a/debian/_base/applications/office/basket/debian/compat b/debian/_base/applications/office/basket/debian/compat
new file mode 100644
index 000000000..f599e28b8
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/_base/applications/office/basket/debian/control b/debian/_base/applications/office/basket/debian/control
new file mode 100644
index 000000000..38ad26000
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/control
@@ -0,0 +1,40 @@
+Source: basket-trinity
+Section: tde
+Priority: optional
+Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
+XSBC-Original-Maintainer: Debian KDE Extras Team <pkg-kde-extras@lists.alioth.debian.org>
+Uploaders: Ana Beatriz Guerrero Lopez <ana@debian.org>, Sune Vuorela <debian@pusling.com>
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build, tdelibs14-trinity-dev, tdepim-trinity-dev, libgpgme11-dev | libgpgme-dev (>= 1.0~)
+Standards-Version: 3.8.4
+
+Package: basket-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Replaces: basket-trinity (<< 4:14.0.0~)
+Breaks: basket-trinity (<< 4:14.0.0~)
+Recommends: basket-kontact-integration-trinity
+Description: a multi-purpose note-taking application for KDE [Trinity]
+ This application provides as many baskets (drawers) as you wish; Several
+ kinds of objects (texts, URLs, images,...) can be drag-n-drop'd into it.
+ .
+ Objects can be edited, copied, dragged... So, they can be arranged
+ according to users' taste. Moreover, Basket allows you to keep all objects
+ you want in one place, keep data on hand, take notes...
+ .
+ Homepage: http://basket.kde.org/
+
+Package: basket-kontact-integration-trinity
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Replaces: basket-kontact-integration-trinity (<< 4:14.0.0~)
+Breaks: basket-kontact-integration-trinity (<< 4:14.0.0~)
+Description: a multi-purpose note-taking appliction, Kontact integration [Trinity]
+ This application provides as many baskets (drawers) as you wish; Several
+ kinds of objects (texts, URLs, images,...) can be drag-n-drop'd into it.
+ .
+ Objects can be edited, copied, dragged... So, they can be arranged
+ according to users' taste. Moreover, Basket allows you to keep all objects
+ you want in one place, keep data on hand, take notes...
+ .
+ This package contains the kontact-trinity plugin
+ .
diff --git a/debian/_base/applications/office/basket/debian/copyright b/debian/_base/applications/office/basket/debian/copyright
new file mode 100644
index 000000000..32425ad0a
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/copyright
@@ -0,0 +1,37 @@
+This package was debianized by Jose Luis Tallon <jltallon@adv-solutions.net> on
+Sat, 23 Oct 2004 02:21:16 +0200.
+
+Maintenance was taken over by the Debian KDE Extras Team on Sat, 03 Feb 2007
+07:41:48 +0100
+
+It was downloaded from http://basket.kde.org/
+
+Copyright (c) 2004-2007 by Sebastien Laout <sebastien.laout@tuxfamily.org>
+
+Upstream Author: Sebastien Laout <sebastien.laout@tuxfamily.org>
+ Petri Damstén <damu@iki.fi>
+ Alex Gontmakher <gsasha@cs.technion.ac.il>
+ Marco Martin <m4rt@libero.it>
+ and other contributers
+
+Parts of basket are under GPL2 or later and other parts are only under GPL2
+
+License:
+
+ Basket is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 of the License.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston,
+ MA 02110-1301, USA.
+
+
+On Debian systems, the full text of GNU's GPL can be found in
+/usr/share/common-licenses/GPL-2
diff --git a/debian/_base/applications/office/basket/debian/dirs b/debian/_base/applications/office/basket/debian/dirs
new file mode 100644
index 000000000..f583045fe
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/dirs
@@ -0,0 +1 @@
+opt/trinity/bin
diff --git a/debian/_base/applications/office/basket/debian/docs b/debian/_base/applications/office/basket/debian/docs
new file mode 100644
index 000000000..0b6e0f321
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/docs
@@ -0,0 +1,2 @@
+AUTHORS
+README.md
diff --git a/debian/_base/applications/office/basket/debian/menu b/debian/_base/applications/office/basket/debian/menu
new file mode 100644
index 000000000..cca92cc0d
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/menu
@@ -0,0 +1,2 @@
+?package(basket-trinity):needs="X11" section="Apps/Tools" \
+ title="basket" command="/opt/trinity/bin/basket"
diff --git a/debian/_base/applications/office/basket/debian/patches/series b/debian/_base/applications/office/basket/debian/patches/series
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/patches/series
diff --git a/debian/_base/applications/office/basket/debian/rules b/debian/_base/applications/office/basket/debian/rules
new file mode 100755
index 000000000..a6797f19a
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/_base/applications/office/basket/debian/source/format b/debian/_base/applications/office/basket/debian/source/format
new file mode 100644
index 000000000..163aaf8d8
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/_base/applications/office/basket/debian/source/options b/debian/_base/applications/office/basket/debian/source/options
new file mode 100644
index 000000000..72f1f5450
--- /dev/null
+++ b/debian/_base/applications/office/basket/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*