summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/office/tellico
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/office/tellico')
-rw-r--r--debian/_base/applications/office/tellico/debian/cdbs/debian-tde.mk7
-rw-r--r--debian/_base/applications/office/tellico/debian/compat2
-rw-r--r--debian/_base/applications/office/tellico/debian/control11
-rwxr-xr-xdebian/_base/applications/office/tellico/debian/rules5
-rw-r--r--debian/_base/applications/office/tellico/debian/tellico-trinity.install4
-rw-r--r--debian/_base/applications/office/tellico/debian/tellico-trinity.manpages1
-rw-r--r--debian/_base/applications/office/tellico/debian/tellico.1x63
7 files changed, 19 insertions, 74 deletions
diff --git a/debian/_base/applications/office/tellico/debian/cdbs/debian-tde.mk b/debian/_base/applications/office/tellico/debian/cdbs/debian-tde.mk
index f36e3527c..aba508624 100644
--- a/debian/_base/applications/office/tellico/debian/cdbs/debian-tde.mk
+++ b/debian/_base/applications/office/tellico/debian/cdbs/debian-tde.mk
@@ -82,7 +82,7 @@ DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+DEB_COMPRESS_EXCLUDE_ALL += .dcl .docbook -license .tag .sty .el
# The default gzip compressor has been changed in dpkg >= 1.17.0.
deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
@@ -202,6 +202,11 @@ $(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
install -p -D -m644 debian/$(cdbs_curpkg).presubj \
debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
fi
+ if test -d debian/$(cdbs_curpkg)/opt/trinity/lib && \
+ test $$(find debian/$(cdbs_curpkg)/opt/trinity/lib -name "*.so" | wc -l) -gt 0; then \
+ echo "# Triggers added by cdbs/debian-tde.mk" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ echo "activate-noawait ldconfig" >> debian/.debhelper/generated/$(cdbs_curpkg)/triggers; \
+ fi
binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
set -e; \
diff --git a/debian/_base/applications/office/tellico/debian/compat b/debian/_base/applications/office/tellico/debian/compat
index ec635144f..f599e28b8 100644
--- a/debian/_base/applications/office/tellico/debian/compat
+++ b/debian/_base/applications/office/tellico/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/_base/applications/office/tellico/debian/control b/debian/_base/applications/office/tellico/debian/control
index d12783adc..f06a50506 100644
--- a/debian/_base/applications/office/tellico/debian/control
+++ b/debian/_base/applications/office/tellico/debian/control
@@ -3,10 +3,10 @@ Section: tde
Priority: optional
Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
XSBC-Original-Maintainer: Regis Boudin <regis@debian.org>
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake-trinity, ninja-build,
+Build-Depends: cdbs, debhelper (>= 10~), quilt, tde-cmake, ninja-build,
tdelibs14-trinity-dev, tdemultimedia-trinity-dev, libtdepim1-trinity-dev,
libxml2-dev, libxslt1-dev, libtag1-dev, libyaz-dev,
- libpoppler-tqt-dev, libexempi-dev, libbtparse-dev, libv4l-dev
+ libpoppler-tqt-dev, libexempi-dev, libbtparse-dev, libv4l-dev, dh-python
Standards-Version: 3.8.4
Homepage: http://periapsis.org/tellico/
@@ -31,11 +31,11 @@ Description: collection manager for books, videos, music [Trinity]
Package: tellico-data-trinity
Architecture: all
-Depends: tdelibs-data-trinity
+Depends: tdelibs-data-trinity, ${python3:Depends}
Replaces: tellico-data-trinity (<< 4:14.0.0~)
Breaks: tellico-data-trinity (<< 4:14.0.0~)
Recommends: tellico-trinity
-Suggests: python-all
+Suggests: python3-all
Description: collection manager for books, videos, music [data] [Trinity]
Tellico is a collection manager for TDE. It includes default collections for
books, bibliographies, comic books, videos, music, coins, stamps, trading
@@ -55,10 +55,11 @@ Description: collection manager for books, videos, music [data] [Trinity]
Package: tellico-scripts-trinity
Architecture: all
+Depends: ${python3:Depends}
Recommends: tellico-trinity
Replaces: tellico-scripts-trinity (<< 4:14.0.0~)
Breaks: tellico-scripts-trinity (<< 4:14.0.0~)
-Suggests: python-all, ruby
+Suggests: python3-all, ruby
Description: collection manager for books, videos, music [scripts] [Trinity]
Tellico is a collection manager for TDE. It includes default collections for
books, bibliographies, comic books, videos, music, coins, stamps, trading
diff --git a/debian/_base/applications/office/tellico/debian/rules b/debian/_base/applications/office/tellico/debian/rules
index 0c4cf46b6..ed4736e50 100755
--- a/debian/_base/applications/office/tellico/debian/rules
+++ b/debian/_base/applications/office/tellico/debian/rules
@@ -26,6 +26,7 @@ binary-install/tellico-data-trinity::
[ ! -d debian/tmp/opt/trinity/share/mime ] || \
mv debian/tmp/opt/trinity/share/mime debian/$(cdbs_curpkg)/usr/share/
mv debian/$(cdbs_curpkg)/usr/share/mime/packages/tellico.xml debian/$(cdbs_curpkg)/usr/share/mime/packages/tellico-trinity.xml
+ dh_python3 -p $(cdbs_curpkg) --shebang=/usr/bin/python3 /opt/trinity/share/apps/tellico
-binary-install/tellico-trinity::
- mv debian/$(cdbs_curpkg)/usr/share/man debian/$(cdbs_curpkg)/opt/trinity/share/
+binary-install/tellico-scripts-trinity::
+ dh_python3 -p $(cdbs_curpkg) --shebang=/usr/bin/python3 /opt/trinity/share/apps/tellico/data-sources
diff --git a/debian/_base/applications/office/tellico/debian/tellico-trinity.install b/debian/_base/applications/office/tellico/debian/tellico-trinity.install
index a45d88c99..c20347b59 100644
--- a/debian/_base/applications/office/tellico/debian/tellico-trinity.install
+++ b/debian/_base/applications/office/tellico/debian/tellico-trinity.install
@@ -1,3 +1,5 @@
debian/tmp/opt/trinity/bin/*
-debian/tellico.xpm /opt/trinity/share/pixmaps/
debian/tmp/opt/trinity/share/applications/*
+debian/tmp/opt/trinity/share/man/man1/tellico.1
+
+debian/tellico.xpm /opt/trinity/share/pixmaps/
diff --git a/debian/_base/applications/office/tellico/debian/tellico-trinity.manpages b/debian/_base/applications/office/tellico/debian/tellico-trinity.manpages
deleted file mode 100644
index 68831ac30..000000000
--- a/debian/_base/applications/office/tellico/debian/tellico-trinity.manpages
+++ /dev/null
@@ -1 +0,0 @@
-debian/tellico.1x
diff --git a/debian/_base/applications/office/tellico/debian/tellico.1x b/debian/_base/applications/office/tellico/debian/tellico.1x
deleted file mode 100644
index 29a569a0b..000000000
--- a/debian/_base/applications/office/tellico/debian/tellico.1x
+++ /dev/null
@@ -1,63 +0,0 @@
-.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.36.
-.TH TELLICO: "1x" "March 2008"
-.SH NAME
-Tellico \- a collection manager for TDE
-.SH SYNOPSIS
-.B tellico
-[\fIQt-options\fR] [\fITDE-options\fR] [\fIoptions\fR] [\fIfilename\fR]
-.SH DESCRIPTION
-Tellico \- a collection manager for TDE
-.SS "Generic options:"
-.TP
-\fB\-\-help\fR
-Show help about options
-.TP
-\fB\-\-help\-qt\fR
-Show Qt specific options
-.TP
-\fB\-\-help\-tde\fR
-Show TDE specific options
-.TP
-\fB\-\-help\-all\fR
-Show all options
-.TP
-\fB\-\-author\fR
-Show author information
-.TP
-\fB\-v\fR, \fB\-\-version\fR
-Show version information
-.TP
-\fB\-\-license\fR
-Show license information
-.TP
-\fB\-\-\fR
-End of options
-.SH OPTIONS
-.TP
-\fB\-\-nofile\fR
-Do not reopen the last open file
-.TP
-\fB\-\-bibtex\fR
-Import <filename> as a bibtex file
-.TP
-\fB\-\-mods\fR
-Import <filename> as a MODS file
-.TP
-\fB\-\-ris\fR
-Import <filename> as a RIS file
-.SS "Arguments:"
-.TP
-filename
-File to open
-.SH "SEE ALSO"
-The full documentation for
-.B Qt:
-is maintained as a Texinfo manual. If the
-.B info
-and
-.B Qt:
-programs are properly installed at your site, the command
-.IP
-.B info Qt:
-.PP
-should give you access to the complete manual.