summaryrefslogtreecommitdiffstats
path: root/debian/_base/applications/tdedocker/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/applications/tdedocker/debian/rules')
-rwxr-xr-xdebian/_base/applications/tdedocker/debian/rules9
1 files changed, 5 insertions, 4 deletions
diff --git a/debian/_base/applications/tdedocker/debian/rules b/debian/_base/applications/tdedocker/debian/rules
index eb2a2e4b5..18aa16b96 100755
--- a/debian/_base/applications/tdedocker/debian/rules
+++ b/debian/_base/applications/tdedocker/debian/rules
@@ -4,6 +4,9 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
-DCONFIG_INSTALL_DIR="/etc/trinity" \
@@ -12,7 +15,5 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON"
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"