summaryrefslogtreecommitdiffstats
path: root/debian/_base/core/tdeartwork/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/core/tdeartwork/debian')
-rw-r--r--debian/_base/core/tdeartwork/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/core/tdeartwork/debian/rules12
2 files changed, 10 insertions, 12 deletions
diff --git a/debian/_base/core/tdeartwork/debian/cdbs/debian-tde.mk b/debian/_base/core/tdeartwork/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/core/tdeartwork/debian/cdbs/debian-tde.mk
+++ b/debian/_base/core/tdeartwork/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/core/tdeartwork/debian/rules b/debian/_base/core/tdeartwork/debian/rules
index 753e97397..184b8d284 100755
--- a/debian/_base/core/tdeartwork/debian/rules
+++ b/debian/_base/core/tdeartwork/debian/rules
@@ -4,15 +4,6 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
-DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
-DEB_CONFIGURE_PREFIX := /opt/trinity
-DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
-
-cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
-
-DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib
-
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/opt/trinity" \
@@ -29,9 +20,6 @@ DEB_CMAKE_EXTRA_FLAGS := \
DEB_DH_STRIP_ARGS := --dbg-package=tdeartwork-trinity-dbg
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
clean::
rm -f IconThemes/kdeclassic/22x22/actions/kde/kde.png
rm -f IconThemes/kdeclassic/32x32/actions/kde/kde.png