summaryrefslogtreecommitdiffstats
path: root/debian/_base/dependencies/tqtinterface/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/dependencies/tqtinterface/debian/rules')
-rwxr-xr-xdebian/_base/dependencies/tqtinterface/debian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/_base/dependencies/tqtinterface/debian/rules b/debian/_base/dependencies/tqtinterface/debian/rules
index 530f77b52..1e56fa6e0 100755
--- a/debian/_base/dependencies/tqtinterface/debian/rules
+++ b/debian/_base/dependencies/tqtinterface/debian/rules
@@ -6,11 +6,17 @@ include debian/cdbs/debian-tde.mk
version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
-DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+ifdef DEB_HOST_MULTIARCH
+ CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
+else
+ CMAKE_INSTALL_LIBDIR = lib
+endif
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_LIBDIR=$(CMAKE_INSTALL_LIBDIR) \
-DWITH_QT3="ON"