summaryrefslogtreecommitdiffstats
path: root/debian/_base/dependencies/tqtinterface
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/dependencies/tqtinterface')
-rwxr-xr-xdebian/_base/dependencies/tqtinterface/debian/rules21
1 files changed, 14 insertions, 7 deletions
diff --git a/debian/_base/dependencies/tqtinterface/debian/rules b/debian/_base/dependencies/tqtinterface/debian/rules
index 17142c7f0..a6f418d04 100755
--- a/debian/_base/dependencies/tqtinterface/debian/rules
+++ b/debian/_base/dependencies/tqtinterface/debian/rules
@@ -11,18 +11,25 @@ DEB_KDE_APIDOX := yes
version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DWITH_QT3="ON"
-
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
# never build in parallel, regardless of DEB_BUILD_OPTIONS.
DEB_BUILD_PARALLEL ?= true
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DWITH_QT3="ON"