summaryrefslogtreecommitdiffstats
path: root/debian/_base/dependencies
diff options
context:
space:
mode:
Diffstat (limited to 'debian/_base/dependencies')
-rw-r--r--debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/dependencies/akode/debian/rules5
-rw-r--r--debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/dependencies/arts/debian/rules4
-rwxr-xr-xdebian/_base/dependencies/avahi-tqt/debian/rules13
-rw-r--r--debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/dependencies/dbus-1-tqt/debian/rules3
-rwxr-xr-xdebian/_base/dependencies/dbus-tqt/debian/rules7
-rwxr-xr-xdebian/_base/dependencies/libart-lgpl/debian/rules7
-rw-r--r--debian/_base/dependencies/libcaldav/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/dependencies/libcaldav/debian/rules3
-rw-r--r--debian/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/dependencies/libcarddav/debian/rules3
-rwxr-xr-xdebian/_base/dependencies/libr/debian/rules7
-rwxr-xr-xdebian/_base/dependencies/python-tqt/debian/rules7
-rwxr-xr-xdebian/_base/dependencies/sip4-tqt/debian/rules7
-rw-r--r--debian/_base/dependencies/tqca-tls/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/dependencies/tqca-tls/debian/rules3
-rw-r--r--debian/_base/dependencies/tqca/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdebian/_base/dependencies/tqca/debian/rules3
-rwxr-xr-xdebian/_base/dependencies/tqscintilla/debian/rules7
-rwxr-xr-xdebian/_base/dependencies/tqt3/debian/rules7
-rwxr-xr-xdebian/_base/dependencies/tqtinterface/debian/rules19
23 files changed, 142 insertions, 33 deletions
diff --git a/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/dependencies/akode/debian/rules b/debian/_base/dependencies/akode/debian/rules
index c912fbebf..d93e5d960 100755
--- a/debian/_base/dependencies/akode/debian/rules
+++ b/debian/_base/dependencies/akode/debian/rules
@@ -9,17 +9,12 @@ ifeq (linux,$(DEB_HOST_ARCH_OS))
DEB_DH_GENCONTROL_ARGS=-- -Valsa-dev=libasound2-dev
endif
-DEB_CONFIGURE_EXTRA_FLAGS := --without-libltdl --with-extra-includes=/usr/include/speex/
-
DEB_DH_STRIP_ARGS := --dbg-package=akode-dbg
PACKAGES_WITH_LIBS := libakode2
DEB_DH_MAKESHLIBS_ARGS_libakode2 := -V'libakode2 (>= 2-rc1-1)'
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
diff --git a/debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/arts/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/dependencies/arts/debian/rules b/debian/_base/dependencies/arts/debian/rules
index 708852525..cc4893ca9 100755
--- a/debian/_base/dependencies/arts/debian/rules
+++ b/debian/_base/dependencies/arts/debian/rules
@@ -30,9 +30,6 @@ DEB_CMAKE_EXTRA_FLAGS := \
DEB_DH_STRIP_ARGS := --dbg-package=arts-trinity-dbg
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
PACKAGES_WITH_LIBS := libarts1c2a-trinity libartsc0-trinity
DEB_DH_MAKESHLIBS_ARGS_ALL := -V
@@ -50,4 +47,3 @@ binary-predeb/libarts1-trinity-dev::
ifeq (linux,$(DEB_HOST_ARCH_OS))
echo "libasound2-dev=libasound2-dev" >> debian/libarts1-trinity-dev.substvars
endif
-
diff --git a/debian/_base/dependencies/avahi-tqt/debian/rules b/debian/_base/dependencies/avahi-tqt/debian/rules
index 89f073b9f..42b7e8ec6 100755
--- a/debian/_base/dependencies/avahi-tqt/debian/rules
+++ b/debian/_base/dependencies/avahi-tqt/debian/rules
@@ -7,6 +7,16 @@ include /usr/share/cdbs/1/class/cmake.mk
# symbols, and speed up loading.
export LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS) -Wl,-z,defs -Wl,-O1
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
@@ -14,6 +24,3 @@ DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_VERBOSE_MAKEFILE="ON" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DWITH_ALL_OPTIONS="ON"
-
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
diff --git a/debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/dbus-1-tqt/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/dependencies/dbus-1-tqt/debian/rules b/debian/_base/dependencies/dbus-1-tqt/debian/rules
index 00935ed3a..42417e634 100755
--- a/debian/_base/dependencies/dbus-1-tqt/debian/rules
+++ b/debian/_base/dependencies/dbus-1-tqt/debian/rules
@@ -6,9 +6,6 @@ include debian/cdbs/debian-tde.mk
DEB_KDE_APIDOX := yes
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
diff --git a/debian/_base/dependencies/dbus-tqt/debian/rules b/debian/_base/dependencies/dbus-tqt/debian/rules
index 71f625c30..ee5d0916d 100755
--- a/debian/_base/dependencies/dbus-tqt/debian/rules
+++ b/debian/_base/dependencies/dbus-tqt/debian/rules
@@ -11,5 +11,12 @@ include /usr/share/cdbs/1/class/cmake.mk
# Strict library versioning
DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
diff --git a/debian/_base/dependencies/libart-lgpl/debian/rules b/debian/_base/dependencies/libart-lgpl/debian/rules
index 86885792c..ab3beba75 100755
--- a/debian/_base/dependencies/libart-lgpl/debian/rules
+++ b/debian/_base/dependencies/libart-lgpl/debian/rules
@@ -7,8 +7,15 @@ libart-2.0-N := $(shell sed -rn 's/^Package:[[:space:]]*(libart-2\.0-[0-9]+)[[:s
DEB_DH_MAKESHLIBS_ARGS_$(libart-2.0-N) += -V '$(libart-2.0-N)(>= 2.3.18)'
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
diff --git a/debian/_base/dependencies/libcaldav/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/libcaldav/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/dependencies/libcaldav/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/libcaldav/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/dependencies/libcaldav/debian/rules b/debian/_base/dependencies/libcaldav/debian/rules
index bdcb3033c..e898aa6d2 100755
--- a/debian/_base/dependencies/libcaldav/debian/rules
+++ b/debian/_base/dependencies/libcaldav/debian/rules
@@ -4,9 +4,6 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
ifdef DEB_HOST_MULTIARCH
CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
else
diff --git a/debian/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/libcarddav/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/dependencies/libcarddav/debian/rules b/debian/_base/dependencies/libcarddav/debian/rules
index bdcb3033c..e898aa6d2 100755
--- a/debian/_base/dependencies/libcarddav/debian/rules
+++ b/debian/_base/dependencies/libcarddav/debian/rules
@@ -4,9 +4,6 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
ifdef DEB_HOST_MULTIARCH
CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
else
diff --git a/debian/_base/dependencies/libr/debian/rules b/debian/_base/dependencies/libr/debian/rules
index 808640608..2d7dda386 100755
--- a/debian/_base/dependencies/libr/debian/rules
+++ b/debian/_base/dependencies/libr/debian/rules
@@ -6,8 +6,15 @@ include /usr/share/cdbs/1/rules/utils.mk
DEB_BUILD_PARALLEL ?= true
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
# Build options
DEB_CMAKE_EXTRA_FLAGS := \
diff --git a/debian/_base/dependencies/python-tqt/debian/rules b/debian/_base/dependencies/python-tqt/debian/rules
index ba02eb70a..72a8d8dc0 100755
--- a/debian/_base/dependencies/python-tqt/debian/rules
+++ b/debian/_base/dependencies/python-tqt/debian/rules
@@ -3,8 +3,15 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
export DH_OPTIONS
diff --git a/debian/_base/dependencies/sip4-tqt/debian/rules b/debian/_base/dependencies/sip4-tqt/debian/rules
index 71965fa31..1feb9c154 100755
--- a/debian/_base/dependencies/sip4-tqt/debian/rules
+++ b/debian/_base/dependencies/sip4-tqt/debian/rules
@@ -2,8 +2,15 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
export DH_OPTIONS
diff --git a/debian/_base/dependencies/tqca-tls/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/tqca-tls/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/dependencies/tqca-tls/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/tqca-tls/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/dependencies/tqca-tls/debian/rules b/debian/_base/dependencies/tqca-tls/debian/rules
index 8c2dd70cc..d3e967902 100755
--- a/debian/_base/dependencies/tqca-tls/debian/rules
+++ b/debian/_base/dependencies/tqca-tls/debian/rules
@@ -4,9 +4,6 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
DEB_CMAKE_EXTRA_FLAGS := \
-DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
-DCMAKE_INSTALL_PREFIX="/usr" \
diff --git a/debian/_base/dependencies/tqca/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/tqca/debian/cdbs/debian-tde.mk
index 641c6c6cc..5b4e8bfd7 100644
--- a/debian/_base/dependencies/tqca/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/tqca/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/debian/_base/dependencies/tqca/debian/rules b/debian/_base/dependencies/tqca/debian/rules
index ec48d0a8d..21df58b4f 100755
--- a/debian/_base/dependencies/tqca/debian/rules
+++ b/debian/_base/dependencies/tqca/debian/rules
@@ -4,9 +4,6 @@ include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/cmake.mk
include debian/cdbs/debian-tde.mk
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
ifdef DEB_HOST_MULTIARCH
CMAKE_INSTALL_LIBDIR = lib/$(DEB_HOST_MULTIARCH)
else
diff --git a/debian/_base/dependencies/tqscintilla/debian/rules b/debian/_base/dependencies/tqscintilla/debian/rules
index 750a1294a..e87355584 100755
--- a/debian/_base/dependencies/tqscintilla/debian/rules
+++ b/debian/_base/dependencies/tqscintilla/debian/rules
@@ -5,8 +5,15 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
# This is the debhelper compatibility version to use.
export TQTDIR=/usr/share/tqt3
diff --git a/debian/_base/dependencies/tqt3/debian/rules b/debian/_base/dependencies/tqt3/debian/rules
index dafa13359..ddc008924 100755
--- a/debian/_base/dependencies/tqt3/debian/rules
+++ b/debian/_base/dependencies/tqt3/debian/rules
@@ -11,8 +11,15 @@ export LD_LIBRARY_PATH=$(QTDIR)/lib:$(OLD_LD_LIBRARY_PATH)
OLD_PATH := $(PATH)
export PATH=$(QTDIR)/bin:$(OLD_PATH)
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_ARCH_CPU ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
diff --git a/debian/_base/dependencies/tqtinterface/debian/rules b/debian/_base/dependencies/tqtinterface/debian/rules
index 0700e9a39..fe114f5e8 100755
--- a/debian/_base/dependencies/tqtinterface/debian/rules
+++ b/debian/_base/dependencies/tqtinterface/debian/rules
@@ -12,17 +12,24 @@ version=Debian Package $(DEB_VERSION)
DEB_OPT_FLAG += -DDEBIAN_VERSION=$(DEB_VERSION)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo
-
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
+endif
# Honour "parallel=N" option of DEB_BUILD_OPTIONS. Comment out to
# never build in parallel, regardless of DEB_BUILD_OPTIONS.
DEB_BUILD_PARALLEL ?= true
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo