summaryrefslogtreecommitdiffstats
path: root/dilos/core/tdebindings/debian
diff options
context:
space:
mode:
Diffstat (limited to 'dilos/core/tdebindings/debian')
-rw-r--r--dilos/core/tdebindings/debian/cdbs/debian-tde.mk10
-rwxr-xr-xdilos/core/tdebindings/debian/rules3
2 files changed, 10 insertions, 3 deletions
diff --git a/dilos/core/tdebindings/debian/cdbs/debian-tde.mk b/dilos/core/tdebindings/debian/cdbs/debian-tde.mk
index 29fca88e1..4dd4698a4 100644
--- a/dilos/core/tdebindings/debian/cdbs/debian-tde.mk
+++ b/dilos/core/tdebindings/debian/cdbs/debian-tde.mk
@@ -75,6 +75,16 @@ DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
diff --git a/dilos/core/tdebindings/debian/rules b/dilos/core/tdebindings/debian/rules
index 17017df93..a43bbff91 100755
--- a/dilos/core/tdebindings/debian/rules
+++ b/dilos/core/tdebindings/debian/rules
@@ -41,9 +41,6 @@ DEB_CONFIGURE_EXTRA_FLAGS = $(WITH_JAVA) --prefix=/usr \
DEB_COMPRESS_EXCLUDE += .java .ui .js .rb .map .wav .bmp .cpp .sk
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
- && echo xz || echo bzip2)
-
# These are not all the packages with libraries, but only those that
# need to be in DEB_SHLIBDEPS_INCLUDE...
PACKAGES_WITH_LIBS = libqt3-jni-trinity libsmoketqt1-trinity libsmoketde1-trinity libkjsembed1-trinity