summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/arts
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/arts')
-rw-r--r--gentoo/trinity-base/arts/Manifest2
-rw-r--r--gentoo/trinity-base/arts/arts-3.5.13.1.ebuild60
-rw-r--r--gentoo/trinity-base/arts/arts-3.5.13.2.ebuild60
-rw-r--r--gentoo/trinity-base/arts/arts-9999.ebuild60
-rw-r--r--gentoo/trinity-base/arts/metadata.xml12
5 files changed, 194 insertions, 0 deletions
diff --git a/gentoo/trinity-base/arts/Manifest b/gentoo/trinity-base/arts/Manifest
new file mode 100644
index 000000000..ab59b6c09
--- /dev/null
+++ b/gentoo/trinity-base/arts/Manifest
@@ -0,0 +1,2 @@
+DIST arts-3.5.13.1.tar.gz 907039 SHA256 ab0f66866d92f3b5f99cc7f96a99615f6873b2326aa0c81670cafb05d4c19b60 SHA512 287ced8a2251929cb9a47c1c158c11c48d8e1174fa9a41dbd32103e1aed64e51f38a641b6600b966c6ac147c913fe6a21db73e57287fdc7de85c535284f1e9e2 WHIRLPOOL de76330c608d31d99c5fe1d95e457d5b7ca286287e329f1d8adfa7cff0c4d7df0ad0235fa2152fee81b7e4aca193e1b960bb2db28e5a25890d8e819d5f8da4fb
+DIST arts-trinity-3.5.13.2.tar.xz 669044 SHA256 5498d299698b1a0148f31b9d1f807d486ee2d06a0119997eb143f27cab682a3b SHA512 2efd1ed900d909e49e8083bb223efa577968a5b4ed2f3bb5292adaedac20ed804fb177aa5206d62707a18a0198a443141f00b5dec1cdabd834f9abf7107e0548 WHIRLPOOL 02142a7fb8f0d1022178ca422590f57ea06bdf490d528ee1f6a396e9b16c55db226a053dcf7a8dcd09437eb2e9887cd9b89a0a93697b372b9657e9e3cc3cbcb8
diff --git a/gentoo/trinity-base/arts/arts-3.5.13.1.ebuild b/gentoo/trinity-base/arts/arts-3.5.13.1.ebuild
new file mode 100644
index 000000000..69f717f63
--- /dev/null
+++ b/gentoo/trinity-base/arts/arts-3.5.13.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="${PN}"
+
+inherit trinity-base
+
+set-trinityver
+
+DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 amd64"
+IUSE="alsa -artswrappersuid jack mp3 nas vorbis"
+SLOT="${TRINITY_VER}"
+
+DEPEND="dev-qt/tqtinterface
+ dev-libs/glib:2
+ media-libs/audiofile
+ mp3? ( media-libs/libmad )
+ nas? ( media-libs/nas )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90 )"
+RDEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DAUDIOFILE=ON
+ $(cmake-utils_use_with mp3 MAD)
+ $(cmake-utils_use_with nas NAS)
+ $(cmake-utils_use_with alsa ALSA)
+ $(cmake-utils_use_with vorbis VORBIS)
+ $(cmake-utils_use_with jack JACK)
+ # NOTE: WITH_ESD dropped due to remove of esound long ago
+ )
+
+ trinity-base_src_configure
+}
+
+src_install() {
+ trinity-base_src_install
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${PREFIX}/bin/artswrapper"
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ elog "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ elog "and so avoid possible skips in sound. However, on untrusted systems this"
+ elog "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "priority, and so is off by default. See bug #7883."
+ elog "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/gentoo/trinity-base/arts/arts-3.5.13.2.ebuild b/gentoo/trinity-base/arts/arts-3.5.13.2.ebuild
new file mode 100644
index 000000000..a788528e4
--- /dev/null
+++ b/gentoo/trinity-base/arts/arts-3.5.13.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="${PN}"
+
+inherit trinity-base
+
+set-trinityver
+
+DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa -artswrappersuid jack mp3 nas vorbis"
+SLOT="${TRINITY_VER}"
+
+DEPEND="dev-qt/tqtinterface
+ dev-libs/glib:2
+ media-libs/audiofile
+ mp3? ( media-libs/libmad )
+ nas? ( media-libs/nas )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90 )"
+RDEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DAUDIOFILE=ON
+ $(cmake-utils_use_with mp3 MAD)
+ $(cmake-utils_use_with nas NAS)
+ $(cmake-utils_use_with alsa ALSA)
+ $(cmake-utils_use_with vorbis VORBIS)
+ $(cmake-utils_use_with jack JACK)
+ # NOTE: WITH_ESD dropped due to remove of esound long ago
+ )
+
+ trinity-base_src_configure
+}
+
+src_install() {
+ trinity-base_src_install
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${PREFIX}/bin/artswrapper"
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ elog "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ elog "and so avoid possible skips in sound. However, on untrusted systems this"
+ elog "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "priority, and so is off by default. See bug #7883."
+ elog "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/gentoo/trinity-base/arts/arts-9999.ebuild b/gentoo/trinity-base/arts/arts-9999.ebuild
new file mode 100644
index 000000000..b205996d3
--- /dev/null
+++ b/gentoo/trinity-base/arts/arts-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="${PN}"
+
+inherit trinity-base
+
+set-trinityver
+
+DESCRIPTION="aRts, the Trinity sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS=
+IUSE="alsa -artswrappersuid jack mp3 nas vorbis"
+SLOT="$TRINITY_VER"
+
+DEPEND="dev-qt/tqtinterface
+ dev-libs/glib:2
+ media-libs/audiofile
+ mp3? ( media-libs/libmad )
+ nas? ( media-libs/nas )
+ alsa? ( media-libs/alsa-lib )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.90 )"
+RDEPEND="${RDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DAUDIOFILE=ON
+ $(cmake-utils_use_with mp3 MAD)
+ $(cmake-utils_use_with nas NAS)
+ $(cmake-utils_use_with alsa ALSA)
+ $(cmake-utils_use_with vorbis VORBIS)
+ $(cmake-utils_use_with jack JACK)
+ # NOTE: WITH_ESD dropped due to remove of esound long ago
+ )
+
+ trinity-base_src_configure
+}
+
+src_install() {
+ trinity-base_src_install
+
+ # used for realtime priority, but off by default as it is a security hazard
+ use artswrappersuid && chmod u+s "${D}/${PREFIX}/bin/artswrapper"
+}
+
+pkg_postinst() {
+ if ! use artswrappersuid ; then
+ elog "Run chmod u+s ${PREFIX}/bin/artswrapper to let artsd use realtime priority"
+ elog "and so avoid possible skips in sound. However, on untrusted systems this"
+ elog "creates the possibility of a DoS attack that'll use 100% cpu at realtime"
+ elog "priority, and so is off by default. See bug #7883."
+ elog "Or, you can set the local artswrappersuid USE flag to make the ebuild do this."
+ fi
+}
diff --git a/gentoo/trinity-base/arts/metadata.xml b/gentoo/trinity-base/arts/metadata.xml
new file mode 100644
index 000000000..c4cdfec98
--- /dev/null
+++ b/gentoo/trinity-base/arts/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>fatzer2@gmail.com</email>
+ <name>Alexander Golubev</name>
+ </maintainer>
+ <use>
+ <flag name="artswrappersuid">Set artswrapper suid for realtime playing, which is a security hazard</flag>
+ </use>
+
+</pkgmetadata>