summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/tdm
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/trinity-base/tdm')
m---------gentoo0
l---------gentoo/trinity-base/tdm/files/shared1
-rwxr-xr-xgentoo/trinity-base/tdm/files/tdm-9999-xsession.script66
-rw-r--r--gentoo/trinity-base/tdm/metadata.xml12
-rw-r--r--gentoo/trinity-base/tdm/tdm-9999.ebuild104
5 files changed, 0 insertions, 183 deletions
diff --git a/gentoo b/gentoo
new file mode 160000
+Subproject 644110a847c5911c2eb04eb53c93031740561ef
diff --git a/gentoo/trinity-base/tdm/files/shared b/gentoo/trinity-base/tdm/files/shared
deleted file mode 120000
index ffc286806..000000000
--- a/gentoo/trinity-base/tdm/files/shared
+++ /dev/null
@@ -1 +0,0 @@
-../../../eclass/trinity-shared-files \ No newline at end of file
diff --git a/gentoo/trinity-base/tdm/files/tdm-9999-xsession.script b/gentoo/trinity-base/tdm/files/tdm-9999-xsession.script
deleted file mode 100755
index a131c29c7..000000000
--- a/gentoo/trinity-base/tdm/files/tdm-9999-xsession.script
+++ /dev/null
@@ -1,66 +0,0 @@
-#! /bin/sh
-# Xsession - run as user
-
-session=$1
-
-# Note that the respective logout scripts are not sourced.
-case $SHELL in
- */bash)
- [ -z "$BASH" ] && exec $SHELL $0 "$@"
- set +o posix
- [ -f /etc/profile ] && . /etc/profile
- if [ -f $HOME/.bash_profile ]; then
- . $HOME/.bash_profile
- elif [ -f $HOME/.bash_login ]; then
- . $HOME/.bash_login
- elif [ -f $HOME/.profile ]; then
- . $HOME/.profile
- fi
- ;;
- */zsh)
- [ -z "$ZSH_NAME" ] && exec $SHELL $0 "$@"
- emulate -R zsh
- [ -d /etc/zsh ] && zdir=/etc/zsh || zdir=/etc
- zhome=${ZDOTDIR:-$HOME}
- # zshenv is always sourced automatically.
- [ -f $zdir/zprofile ] && . $zdir/zprofile
- [ -f $zhome/.zprofile ] && . $zhome/.zprofile
- [ -f $zdir/zlogin ] && . $zdir/zlogin
- [ -f $zhome/.zlogin ] && . $zhome/.zlogin
- setopt shwordsplit noextendedglob
- ;;
- */csh|*/tcsh)
- # [t]cshrc is always sourced automatically.
- # Note that sourcing csh.login after .cshrc is non-standard.
- xsess_tmp=`mktemp /tmp/xsess-env-XXXXXX`
- $SHELL -c "if (-f /etc/csh.login) source /etc/csh.login; if (-f ~/.login) source ~/.login; /bin/sh -c export -p >! $xsess_tmp"
- . $xsess_tmp
- rm -f $xsess_tmp
- ;;
- *) # Plain sh, ksh, and anything we don't know.
- [ -f /etc/profile ] && . /etc/profile
- [ -f $HOME/.profile ] && . $HOME/.profile
- ;;
-esac
-
-[ -f /etc/xprofile ] && . /etc/xprofile
-[ -f $HOME/.xprofile ] && . $HOME/.xprofile
-
-case $session in
- "")
- exec xmessage -center -buttons OK:0 -default OK "Sorry, $DESKTOP_SESSION is no valid session."
- ;;
- failsafe)
- exec xterm -geometry 80x24-0-0
- ;;
- custom)
- exec /bin/sh $HOME/.xsession
- ;;
- default)
- exec @TRINITY_INSTALL_PATH@/bin/starttde
- ;;
- *)
- eval exec "$session"
- ;;
-esac
-exec xmessage -center -buttons OK:0 -default OK "Sorry, cannot execute $session. Check $DESKTOP_SESSION.desktop."
diff --git a/gentoo/trinity-base/tdm/metadata.xml b/gentoo/trinity-base/tdm/metadata.xml
deleted file mode 100644
index 2a40b2145..000000000
--- a/gentoo/trinity-base/tdm/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>fatzer2@gmail.com</email>
- <name>Alexander Golubev</name>
- </maintainer>
- <use>
- <flag name="xdmcp">Support for <pkg>x11-libs/libXdmcp</pkg></flag>
- <flag name="sak">Adds SAK (Secure Attention Key) feature</flag>
- </use>
-</pkgmetadata>
diff --git a/gentoo/trinity-base/tdm/tdm-9999.ebuild b/gentoo/trinity-base/tdm/tdm-9999.ebuild
deleted file mode 100644
index 5d4d6160b..000000000
--- a/gentoo/trinity-base/tdm/tdm-9999.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
-TRINITY_MODULE_NAME="tdebase"
-
-inherit trinity-meta
-
-DESCRIPTION="Trinity login manager, similar to xdm and gdm"
-KEYWORDS=
-IUSE="pam xdmcp xcomposite sak +xrandr"
-
-DEPEND="pam? ( trinity-base/tdebase-pam )
- xdmcp? ( x11-libs/libXdmcp )
- xcomposite? ( x11-libs/libXcomposite )
- xrandr? ( x11-libs/libXrandr )
- >=trinity-base/tdelibs-${PV}:${SLOT}[xrandr?]
- sys-apps/dbus
- x11-libs/libXtst
- >=trinity-base/kcontrol-${PV}:${SLOT}
- dev-libs/dbus-tqt"
-
-RDEPEND="${DEPEND}
- >=trinity-base/tdepasswd-${PV}:${SLOT}
- x11-apps/xinit
- x11-apps/xmessage"
-
-pkg_setup() {
- trinity-meta_pkg_setup;
- use sak && TRINITY_SUBMODULE+=" tsak"
-}
-
-src_configure() {
- mycmakeargs=(
- -DWITH_XTEST=ON
- -DWITH_LIBART=ON
- -DWITH_SHADOW=ON
- $(cmake-utils_use_with xcomposite XCOMPOSITE )
- $(cmake-utils_use_with xdmcp XDMCP )
- $(cmake-utils_use_with xrandr XRANDR )
- $(cmake-utils_use_with pam PAM )
- )
-
- trinity-meta_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- # Customize the kdmrc configuration
- sed -i -e "s:#SessionsDirs=:SessionsDirs=/usr/share/xsessions\n#SessionsDirs=:" \
- "${D}/${TDEDIR}/share/config/tdm/tdmrc" || die "sed tdmrc failed"
-
- # install XSession upstream script seems to be debian-cpecific
- cp "${FILESDIR}/${P}-xsession.script" "${D}/${TDEDIR}/share/config/tdm/Xsession"
- sed -i -e "s!@TRINITY_INSTALL_PATH@!${TDEDIR}!" "${D}/${TDEDIR}/share/config/tdm/Xsession" \
- || die "sed tdmrc failed"
-}
-
-pkg_postinst() {
- # set the default kdm face icon if it's not already set by the system admin
- # because this is user-overrideable in that way, it's not in src_install
- if [ ! -e "${ROOT}${TDEDIR}/share/apps/tdm/faces/.default.face.icon" ]; then
- mkdir -p "${ROOT}${TDEDIR}/share/apps/tdm/faces"
- cp "${ROOT}${TDEDIR}/share/apps/tdm/pics/users/default1.png" \
- "${ROOT}${TDEDIR}/share/apps/tdm/faces/.default.face.icon"
- fi
- if [ ! -e "${ROOT}${TDEDIR}/share/apps/tdm/faces/root.face.icon" ]; then
- mkdir -p "${ROOT}${TDEDIR}/share/apps/tdm/faces"
- cp "${ROOT}${TDEDIR}/share/apps/tdm/pics/users/root1.png" \
- "${ROOT}${TDEDIR}/share/apps/tdm/faces/root.face.icon"
- fi
-
- if use sak; then
- sak_ok=yes
- if ! linux_config_exists; then
- ewarn "Can't check the linux kernel configuration."
- ewarn "You might have some incompatible options enabled."
- sak_ok=no
- else
- if ! linux_chkconfig_present INPUT_UINPUT; then
- eerror "You build tdm with sak feature enabled. "
- eerror "It requires the INPUT_UINPUT support enabled."
- eerror "Please enable it:"
- eerror " CONFIG_INPUT_UINPUT=y"
- eerror "in /usr/src/linux/.config or"
- eerror " Device Drivers --->"
- eerror " Input device support --->"
- eerror " [*] Miscellaneous devices --->"
- eerror " <*> User level driver support"
- sak_ok=no
- fi
- fi
- if [[ "$sak_ok" != yes ]]; then
- sed -i -e 's:#\?\s*UseSAK=\(true\|false\)\?:UseSak=false:' \
- "${D}${TDEDIR}/share/config/tdm/tdmrc" || die "sed tdmrc failed"
- ewarn "SAK feature is disabled. You can enable it yourself by setting UseSAK=true "
- ewarn "in ${TDEDIR}/share/config/tdm/tdmrc "
- else
- ewarn "SAK feature is enabled. You can disable it yourself by setting UseSAK=false"
- ewarn "in ${TDEDIR}/share/config/tdm/tdmrc "
- fi
- fi
-}