summaryrefslogtreecommitdiffstats
path: root/redhat/applications/amarok/amarok.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/amarok/amarok.spec')
-rw-r--r--redhat/applications/amarok/amarok.spec14
1 files changed, 13 insertions, 1 deletions
diff --git a/redhat/applications/amarok/amarok.spec b/redhat/applications/amarok/amarok.spec
index 593d1b57b..4cb14e778 100644
--- a/redhat/applications/amarok/amarok.spec
+++ b/redhat/applications/amarok/amarok.spec
@@ -251,6 +251,18 @@ BuildRequires: ruby-devel
BuildRequires: rubypick
%endif
+# PYTHON support
+%if 0%{?rhel} >= 8 || 0%{?fedora} >= 31 || 0%{?suse_version} >= 1550 || 0%{?mgaversion} >= 8
+%global python python2
+%global __python %__python2
+%global python_sitearch %{python2_sitearch}
+%else
+%global python python
+%endif
+%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+BuildRequires: %{python}
+BuildRequires: %{python}-devel
+
# To open the selected browser, works with Patch2
Requires: xdg-utils
Requires(post): xdg-utils
@@ -428,7 +440,7 @@ if ! ruby -rrbconfig -e "puts Config.expand( Config::MAKEFILE_CONFIG['MAJOR'] )"
-e "s|Config\.|RbConfig\.|g"
fi
-%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8 || 0%{?mgaversion} >= 8
%__sed -i "amarok/src/scripts/common/Publisher.py" \
"amarok/src/scripts/common/Zeroconf.py" \
"amarok/src/scripts/playlist2html/Playlist.py" \