summaryrefslogtreecommitdiffstats
path: root/redhat/applications/kbfx/kbfx-14.0.0.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/kbfx/kbfx-14.0.0.spec')
-rw-r--r--redhat/applications/kbfx/kbfx-14.0.0.spec110
1 files changed, 83 insertions, 27 deletions
diff --git a/redhat/applications/kbfx/kbfx-14.0.0.spec b/redhat/applications/kbfx/kbfx-14.0.0.spec
index 6721d1cc6..11c948ac8 100644
--- a/redhat/applications/kbfx/kbfx-14.0.0.spec
+++ b/redhat/applications/kbfx/kbfx-14.0.0.spec
@@ -1,53 +1,92 @@
-# Default version for this component
-%define tde_pkg kbfx
+#
+# spec file for package kbfx (version R14.0.0)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http:/www.trinitydesktop.org/
+#
+
+# TDE variables
+%define tde_epoch 2
%define tde_version 14.0.0
-
-# If TDE is built in a specific prefix (e.g. /opt/trinity), the release will be suffixed with ".opt".
-%if "%{?tde_prefix}" != "/usr"
-%define _variant .opt
-%endif
-
-# TDE specific building variables
+%define tde_pkg kbfx
+%define tde_prefix /opt/trinity
+%define tde_appdir %{tde_datadir}/applications
%define tde_bindir %{tde_prefix}/bin
%define tde_datadir %{tde_prefix}/share
%define tde_docdir %{tde_datadir}/doc
%define tde_includedir %{tde_prefix}/include
%define tde_libdir %{tde_prefix}/%{_lib}
%define tde_mandir %{tde_datadir}/man
-%define tde_appdir %{tde_datadir}/applications
-
-%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdeappdir %{tde_datadir}/applications/tde
%define tde_tdedocdir %{tde_docdir}/tde
%define tde_tdeincludedir %{tde_includedir}/tde
%define tde_tdelibdir %{tde_libdir}/trinity
-%define _docdir %{tde_docdir}
-
Name: trinity-%{tde_pkg}
-Summary: an alternative to K-Menu for TDE [Trinity]
+Epoch: %{tde_epoch}
Version: 0.4.9.3.1
-Release: %{?!preversion:5}%{?preversion:4_%{preversion}}%{?dist}%{?_variant}
-
-License: GPLv2+
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}%{?_variant}
+Summary: an alternative to K-Menu for TDE [Trinity]
Group: Applications/Utilities
-
-Vendor: Trinity Project
-Packager: Francois Andriot <francois.andriot@free.fr>
URL: http://www.trinitydesktop.org/
-Prefix: %{tde_prefix}
+%if 0%{?suse_version}
+License: GPL-2.0+
+%else
+License: GPLv2+
+%endif
+
+#Vendor: Trinity Desktop
+#Packager: Francois Andriot <francois.andriot@free.fr>
+
+Prefix: %{_prefix}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
-BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
-BuildRequires: trinity-arts-devel >= 1:1.5.10
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
BuildRequires: desktop-file-utils
+BuildRequires: cmake libtool
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+
+# SUSE desktop files utility
+%if 0%{?suse_version}
+BuildRequires: update-desktop-files
+%endif
+
+%if 0%{?opensuse_bs} && 0%{?suse_version}
+# for xdg-menu script
+BuildRequires: brp-check-trinity
+%endif
+
+# IDN support
+BuildRequires: libidn-devel
+
+# GAMIN support
+# Not on openSUSE.
+%if 0%{?rhel} || 0%{?fedora} || 0%{?mgaversion} || 0%{?mdkversion}
+%define with_gamin 1
+BuildRequires: gamin-devel
+%endif
+
+# PCRE support
+BuildRequires: pcre-devel
+
%description
KBFX is an alternative to the classical K-Menu button and its menu.
@@ -60,10 +99,14 @@ bar a try.
Homepage: http://www.kbfx.org
-%if 0%{?suse_version} || 0%{?pclinuxos}
+##########
+
+%if 0%{?pclinuxos} || 0%{?suse_version} && 0%{?opensuse_bs} == 0
%debug_package
%endif
+##########
+
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
@@ -123,6 +166,16 @@ export PATH="%{tde_bindir}:${PATH}"
%__rm -rf %{buildroot}
%__make install DESTDIR=%{buildroot} -C build VERBOSE=1
+# Updates applications categories for openSUSE
+%if 0%{?suse_version}
+%suse_update_desktop_file -G "KBFX Configuration Utility" kbfxconfigapp -r KDE Utility DesktopUtility
+%suse_update_desktop_file %{buildroot}%{tde_datadir}/apps/konqueror/servicemenus/kbfx_prepare_theme.desktop
+%suse_update_desktop_file %{buildroot}%{tde_datadir}/apps/konqueror/servicemenus/kbfx_install_theme.desktop
+%suse_update_desktop_file %{buildroot}%{tde_datadir}/apps/kicker/applets/kbfxspinx.desktop
+%suse_update_desktop_file %{buildroot}%{tde_datadir}/mimelnk/application/x-kbfxtheme.desktop
+%suse_update_desktop_file %{buildroot}%{tde_datadir}/applications/tde/kbfx_theme.desktop
+%endif
+
%clean
%__rm -rf %{buildroot}
@@ -145,6 +198,8 @@ update-desktop-database %{tde_appdir} &> /dev/null
%defattr(-,root,root,-)
%{tde_bindir}/kbfxconfigapp
%{tde_tdeincludedir}/kbfx/
+%dir %{tde_libdir}/kbfx
+%dir %{tde_libdir}/kbfx/plugins
%{tde_libdir}/kbfx/plugins/libkbfxplasmadataplasmoid.la
%{tde_libdir}/kbfx/plugins/libkbfxplasmadataplasmoid.so
%{tde_libdir}/kbfx/plugins/libkbfxplasmadatasettings.la
@@ -161,7 +216,8 @@ update-desktop-database %{tde_appdir} &> /dev/null
%{tde_tdelibdir}/kbfxspinx.so
%{tde_tdeappdir}/kbfx_theme.desktop
%{tde_tdeappdir}/kbfxconfigapp.desktop
-%{tde_datadir}/apps/kbfx/skins/*/*
+%{tde_datadir}/apps/kbfx/
+%dir %{tde_datadir}/apps/kbfxconfigapp
%{tde_datadir}/apps/kbfxconfigapp/kbfxconfigappui.rc
%{tde_datadir}/apps/kicker/applets/kbfxspinx.desktop
%{tde_datadir}/apps/konqueror/servicemenus/kbfx_install_theme.desktop
@@ -178,5 +234,5 @@ update-desktop-database %{tde_appdir} &> /dev/null
%changelog
-* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 0.4.9.3.1-5
+* Fri Jul 05 2013 Francois Andriot <francois.andriot@free.fr> - 2:0.4.9.3.1-1
- Initial release for TDE 14.0.0