summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tde-style-domino/tde-style-domino.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/tde-style-domino/tde-style-domino.spec')
-rw-r--r--redhat/applications/tde-style-domino/tde-style-domino.spec51
1 files changed, 25 insertions, 26 deletions
diff --git a/redhat/applications/tde-style-domino/tde-style-domino.spec b/redhat/applications/tde-style-domino/tde-style-domino.spec
index a2dfdd079..20230ce2c 100644
--- a/redhat/applications/tde-style-domino/tde-style-domino.spec
+++ b/redhat/applications/tde-style-domino/tde-style-domino.spec
@@ -18,7 +18,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.0.0
+%define tde_version 14.1.0
%endif
%define tde_pkg tde-style-domino
%define tde_prefix /opt/trinity
@@ -62,7 +62,7 @@ Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
BuildRequires: trinity-tdelibs-devel >= %{tde_version}
BuildRequires: trinity-tdebase-devel >= %{tde_version}
-BuildRequires: autoconf automake libtool m4
+BuildRequires: cmake
BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: libtool
@@ -86,38 +86,36 @@ of the widgets by customizable color gradients.
%prep
%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
-%__cp -f "/usr/share/aclocal/libtool.m4" "admin/libtool.m4.in"
-%__cp -f "/usr/share/libtool/"*"/ltmain.sh" "admin/ltmain.sh" || %__cp -f "/usr/share/libtool/ltmain.sh" "admin/ltmain.sh"
-%__make -f "admin/Makefile.common"
-
%build
-unset QTDIR QTINC QTLIB
-export PATH="%{tde_bindir}:${PATH}"
-
-%configure \
- --prefix=%{tde_prefix} \
- --exec-prefix=%{tde_prefix} \
- --bindir=%{tde_bindir} \
- --datadir=%{tde_datadir} \
- --includedir=%{tde_tdeincludedir} \
- --libdir=%{tde_libdir} \
- --mandir=%{tde_mandir} \
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
\
- --disable-dependency-tracking \
- --disable-debug \
- --enable-new-ldflags \
- --enable-final \
- --enable-closure \
- --enable-rpath \
- --disable-gcc-hidden-visibility
+ -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
+ -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
+ -DDATA_INSTALL_DIR=%{tde_datadir}/apps \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DBUILD_ALL=ON \
+ ..
%__make %{?_smp_mflags}
%install
-%__rm -rf $RPM_BUILD_ROOT
-%__make install DESTDIR=$RPM_BUILD_ROOT
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot} -C build
%clean
@@ -137,6 +135,7 @@ export PATH="%{tde_bindir}:${PATH}"
%{tde_datadir}/apps/tdedisplay/color-schemes/Domino.kcsrc
%{tde_datadir}/apps/tdestyle/themes/domino.themerc
%{tde_datadir}/apps/twin/domino.desktop
+%lang(de) %{tde_datadir}/locale/de/LC_MESSAGES/tdestyle_domino_config.mo
%changelog