summaryrefslogtreecommitdiffstats
path: root/redhat/applications/tdepacman/tdepacman.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/tdepacman/tdepacman.spec')
-rw-r--r--redhat/applications/tdepacman/tdepacman.spec149
1 files changed, 149 insertions, 0 deletions
diff --git a/redhat/applications/tdepacman/tdepacman.spec b/redhat/applications/tdepacman/tdepacman.spec
new file mode 100644
index 000000000..4588b8bb6
--- /dev/null
+++ b/redhat/applications/tdepacman/tdepacman.spec
@@ -0,0 +1,149 @@
+#
+# spec file for package tdepacman (version R14)
+#
+# Copyright (c) 2014 Trinity Desktop Environment
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+#
+# Please submit bugfixes or comments via http://www.trinitydesktop.org/
+#
+
+# Default version for this component
+%define tde_pkg tdepacman
+%if "%{?tde_version}" == ""
+%define tde_version 14.1.0
+%endif
+
+# TDE specific building variables
+%define tde_prefix /opt/trinity
+%define tde_bindir %{tde_prefix}/bin
+%define tde_confdir %{_sysconfdir}/trinity
+%define tde_datadir %{tde_prefix}/share
+%define tde_docdir %{tde_datadir}/doc
+%define tde_includedir %{tde_prefix}/include
+%define tde_libdir %{tde_prefix}/%{_lib}
+%define tde_mandir %{tde_datadir}/man
+%define tde_appdir %{tde_datadir}/applications
+
+%define tde_tdeappdir %{tde_appdir}/tde
+%define tde_tdedocdir %{tde_docdir}/tde
+%define tde_tdeincludedir %{tde_includedir}/tde
+%define tde_tdelibdir %{tde_libdir}/trinity
+
+%define _docdir %{tde_docdir}
+
+
+Name: trinity-%{tde_pkg}
+Summary: A pacman game for the Trinity Desktop
+Version: 0.3.2
+Release: %{?!preversion:1}%{?preversion:0_%{preversion}}%{?dist}
+
+License: GPLv2+
+Group: Applications/Utilities
+
+Vendor: Trinity Project
+Packager: Francois Andriot <francois.andriot@free.fr>
+URL: http://www.trinitydesktop.org/
+
+Prefix: %{_prefix}
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
+
+BuildRequires: trinity-tqtinterface-devel >= %{tde_version}
+BuildRequires: trinity-arts-devel >= 1:1.5.10
+BuildRequires: trinity-tdelibs-devel >= %{tde_version}
+BuildRequires: trinity-tdebase-devel >= %{tde_version}
+BuildRequires: trinity-tdegames-devel >= %{tde_version}
+BuildRequires: desktop-file-utils
+
+BuildRequires: gettext
+
+BuildRequires: cmake
+BuildRequires: gcc-c++
+BuildRequires: pkgconfig
+BuildRequires: libtool
+
+
+%description
+Pacman is a legendary game with an enthusiastic following from around
+the world. Since its introduction in 1980, Pacman's image has been
+splashed across magazine covers, television screens, T-shirts, and
+bumper stickers. Created by Japan's Namco, and distributed in the
+United States by Bally, Pacman is an icon of 1980's popular culture
+
+%if 0%{?suse_version} || 0%{?pclinuxos}
+%debug_package
+%endif
+
+
+%prep
+%setup -q -n %{name}-%{tde_version}%{?preversion:~%{preversion}}
+
+
+%build
+unset QTDIR QTINC QTLIB
+export PATH="%{tde_bindir}:${PATH}"
+export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
+
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
+
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=OFF \
+ -DCMAKE_INSTALL_RPATH="%{tde_libdir}" \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
+ \
+ -DCMAKE_INSTALL_PREFIX=%{tde_prefix} \
+ -DSHARE_INSTALL_PREFIX=%{tde_datadir} \
+ -DDATA_INSTALL_DIR=%{tde_datadir}/apps \
+ -DLIB_INSTALL_DIR=%{tde_libdir} \
+ -DBUILD_ALL=ON \
+ ..
+
+%__make %{?_smp_mflags}
+
+
+%install
+export PATH="%{tde_bindir}:${PATH}"
+%__rm -rf %{buildroot}
+%__make install DESTDIR=%{buildroot} -C build
+
+%find_lang %{tde_pkg}
+
+
+%clean
+%__rm -rf %{buildroot}
+
+
+%files -f %{tde_pkg}.lang
+%defattr(-,root,root,-)
+%doc AUTHORS ChangeLog COPYING README TODO
+%{tde_bindir}/tdepacman
+%{tde_tdeappdir}/tdepacman.desktop
+%{tde_datadir}/apps/tdepacman/
+%dir %{tde_datadir}/config
+%{tde_datadir}/config/tdepacmanrc
+%lang(de) %{tde_tdedocdir}/HTML/de/tdepacman/
+%{tde_tdedocdir}/HTML/en/tdepacman/
+%{tde_datadir}/icons/hicolor/16x16/apps/tdepacman.png
+%{tde_datadir}/icons/hicolor/32x32/apps/tdepacman.png
+%{tde_datadir}/icons/locolor/16x16/apps/tdepacman.png
+%{tde_datadir}/icons/locolor/32x32/apps/tdepacman.png
+%{tde_mandir}/man1/tdepacman.1*
+
+
+%changelog