summaryrefslogtreecommitdiffstats
path: root/redhat/dependencies/tqca-tls/tqca-tls.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/dependencies/tqca-tls/tqca-tls.spec')
-rw-r--r--redhat/dependencies/tqca-tls/tqca-tls.spec23
1 files changed, 19 insertions, 4 deletions
diff --git a/redhat/dependencies/tqca-tls/tqca-tls.spec b/redhat/dependencies/tqca-tls/tqca-tls.spec
index 1ece07861..639f8ef9e 100644
--- a/redhat/dependencies/tqca-tls/tqca-tls.spec
+++ b/redhat/dependencies/tqca-tls/tqca-tls.spec
@@ -57,6 +57,7 @@ Source0: %{name}-%{tde_version}%{?preversion:~%{preversion}}.tar.gz
BuildRequires: libtqt4-devel >= %{tde_epoch}:4.2.0
BuildRequires: libtqca-devel >= %{tde_epoch}:1.0
+BuildRequires: cmake
BuildRequires: gcc-c++
BuildRequires: openssl-devel >= 0.9.8
@@ -100,15 +101,29 @@ contains the TLS plugin.
%build
unset QTDIR QTINC QTLIB
-./configure \
- --tqtdir=%{_prefix}
+if ! rpm -E %%cmake|grep -q "cd build"; then
+ %__mkdir_p build
+ cd build
+fi
-%__make %{?_smp_mflags}
+%cmake \
+ -DCMAKE_BUILD_TYPE="RelWithDebInfo" \
+ -DCMAKE_C_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS="${RPM_OPT_FLAGS} -DNDEBUG" \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ -DWITH_GCC_VISIBILITY=OFF \
+ \
+ -DWITH_ALL_OPTIONS="ON" \
+ \
+ ..
+
+%__make %{?_smp_mflags} || %__make
%install
%__rm -rf %{?buildroot}
-%__make install INSTALL_ROOT=%{?buildroot}
+%__make install DESTDIR="%{?buildroot}" -C build
%clean